Leaflet Maps Marker v1.5.1 is available

Today Torsten called my attention to a strange behaviour causing layer maps and API links (fullscreen, georss, geojson, wikitude) not to work on his site. I digged into the code and found, that the plugin active check introduced in v1.4 didn´t work for multisite installations. Therefore I changed the code for this function (again) and the plugin should now work on every WordPress installation (up from 3.0). If you find that the plugin is not working on your site though, please don´t hesitate to write a post in the WordPress support forums.

I also did some cleanup in the code and fixed some other bugs, like broken maps on WordPress 3.0 installations

Full changelog:

  • BUGFIX: layer maps and API links did not work on multisite installations
  • BUGFIX: legend link for WMS layer did not work
  • BUGFIX: links in panel had a border with some templates
  • BUGFIX: removed double slashes from LEAFLET_PLUGIN_URL-links
  • BUGFIX: uninstall didnt remove marker-icon-directory on some installations
  • BUGFIX: admin pages for map/layer edit screens broken on WordPress 3.0 installations
  • OPTIMIZED: javascript variable definitions for wms layers and custom overlays get added to sourcecode only when they are active on the current map

Please let me what you think of this new release. If you have any issues, please see this page on how to get support. If an important feature is missing, please add your feature requests on Github. I am also looking for more translations – if you would like to contribute a new one, please visit this page for more information.