Usein kysytyt kysymykset

Virhe ”Pyynnön lähettäminen epäonnistui” yrittäessäsi siirtyä versioon v4

Tämä virhe osoittaa, että AJAX-määrityksissä on joitain ongelmia vastaavasti wp-admin / admin-ajax.php-päätepisteessä.

Vahvista tämä avaamalla selainkonsoli (esim. F12 Firefoxissa tai chromissa), vaihda “Console” -välilehdelle ja lataa sivu uudelleen ja napsauta “Tarkista siirto” uudelleen varmistaaksesi, onko ylimääräisiä virheviestejä:

Jos et näe virheilmoitusta siellä, siirry “Verkko” -välilehteen ja lataa sivu uudelleen ja napsauta “Tarkista siirto” uudelleen varmistaaksesi, onko ylimääräisiä virheviestejä:

Yllä olevasta näytöstä näet, että tila (= HTTP-virhekoodi) 404 epäonnistui - tässä esimerkissä tiedosto /wp-admin/admin-ajax.php ei ollut käytettävissä.

On kuitenkin todennäköisempää, että täällä näkyy tila 500 (= sisäinen palvelinvirhe). 500 sisäinen palvelinvirhe on yleinen kaikki virhe, kun palvelin heittää poikkeuksen. Se on virheviesti, kun mikään tarkempi virheviesti ei sovellu, ja se liittyy useimmissa tapauksissa suoraan palvelimen väärään asetukseen tai ongelmaan.

Joten mitä nyt tehdä?

Yritä ensin poistaa kaikki muut laajennukset väliaikaisesti käytöstä, mutta Maps Marker Pro varmistaa, että tämä ongelma ei johdu laajennusristiriidasta.

Jos tämä ei auta, tutustu palvelimen virhelokiin, kuten PHP- tai Apache-virhelokiin, kun pyyntö esitetään, ja mikä saattaa antaa sinulle vihjeen miksi tämä virhe tapahtuu palvelimellasi.

Jos tämä ei edelleenkään auta, tarkista, voiko jokin seuraavista opetusohjelmista auttaa sinua löytämään syyt palvelinvirheelle:

Jos tämä ei edelleenkään auta, suosittelemme ottamaan yhteyttä isännöintitukiisi, jotta he voivat analysoida miksi /wp-admin/admin-ajax.php -pyyntö epäonnistuu yritettäessä suorittaa siirtotyökalua.

0
0
5091
Arvioi tämä UKK-vastaus

Voidaanko karttoja näyttää 100% korkeudella?

Maps Marker Pron avulla voit asettaa kartan leveyden pikseli- tai% -arvoina:

Korkeusarvo voidaan kuitenkin antaa myös pikseliarvona HTML: n rajoitusten vuoksi.

Jos haluat näyttää kartan koko näytössä, käytä sen sijaan erityistä koko näytön näkymää, johon pysyvä linkki pääsee karttapaneelin kautta

tai käytä HTML5-koko näyttöruudun painiketta kartalla zoomauskuvakkeiden alla:

0
1
517
Arvioi tämä UKK-vastaus

Voidaanko kuntoseurantalaitteiden jälkiä näyttää karttoilla?

Jos kuntoseuranta (kuten garmin fit) sallii tallennettujen kappaleiden viemisen GPX-muodossa, nämä tiedostot voidaan yleensä näyttää myös karttoilla Maps Marker Pron avulla.

Näiden kappaleiden näyttämiseksi luo uusi kartta, siirry välilehdelle “GPX” ja aloita napsauttamalla “Avaa mediakirjasto” -painiketta:

Seuraavaksi siirry välilehdelle “Lataa tiedostot”, valitse ja lähetä gpx-tiedostosi, lopeta napsauttamalla painiketta “Valitse”:

Seurauksena on, että GPX-raita näkyy kartalla ja voit valinnaisesti mukauttaa sen asetuksia edelleen (suositellaan vaihtamista edistyneeseen editoriin kaikille vaihtoehdoille):

0
0
4915
Arvioi tämä UKK-vastaus

Tukeeko Maps Marker Pro muodotiedostoja?

Tällä hetkellä v4.0-muotoisia tiedostoja / shp-tiedostoja ei tueta - pelaamme lisätäksesi tukea tulevalle julkaisulle (julkaisupäivää ei ole vielä saatavana).

Ole hyvä ja ole ajan tasalla viimeisimmästä Maps Marker -kehityksestä tilaa RSS-uutiset, seuraa @MapsMarker viserrys tai Twitterissä Facebook.

0
0
9479
Arvioi tämä UKK-vastaus

Konsolivirhe ”MapsMarkerPro ei ole määritelty”

Jos kartat eivät näy ja selainkonsolissasi on virhe ”MapsMarkerPro ei ole määritelty”, jatka seuraavasti:

  1. Jos käytät välimuistin laajennuksia, yritä ensin tyhjentää kaikki välimuistit.
  2. Tarkista ensin, johtuuko tämä ongelma plugin-ristiriidasta. Varmista tämä poistamalla väliaikaisesti kaikki muut laajennukset, mutta Maps Marker Pro, ja yritä uudelleen.
  3. Jos tämä ei tuottanut tuloksia, tarkista, sisältävätkö mallitiedostot koukut wp_head() otsikoissa.php ja wp_footer() (footer.php) (joita tarvitaan skriptien ja tyylien lataamiseen Maps Marker Prosta).
0
0
8050
Arvioi tämä UKK-vastaus

Karttalaatat (välilehdissä) eivät ole ladattu kokonaan

Jos kartta näyttää yllä olevalta esimerkiltä tai jos se on upotettu välilehteen, ota taustakuvaan käyttöön välilehti -vaihtoehto, jonka pitäisi korjata tämä ongelma:

0
0
8036
Arvioi tämä UKK-vastaus

Näytetään ilmoitus "Virhe: karttakuvia ei voitu ladata"

Jos näet tämän virhesanoman kartan sijasta, sillä voi olla useita syitä:

Todennäköisin on, että käytetty (ulkoinen) laattapalvelin ei ole tällä hetkellä käytettävissä tai sillä on väliaikaisia ​​ongelmia (esim. huoltoikkuna). Valitettavasti meillä ei ole suoraa vaikutusta ulkoisten laattapalvelimien saatavuuteen. Maps Marker Pron avulla voit muodostaa yhteyden karttatietojen näyttämiseen. Kokemuksemme mukaan OpenStreetMap on erittäin luotettava ja näitä virheitä esiintyy hyvin harvoin.

Joka tapauksessa, kuten myös virheilmoituksessa todetaan, voi olla, että käyttäjän puolella on internetyhteyteen liittyviä ongelmia, jotka johtavat siihen, että karttakehyksiä ei voi ladata, vaikka ulkoinen karttalaattapalvelin on käytettävissä.

Kolmas syy tähän virheeseen - viallinen karttakonfiguraatio - on yleensä vain tapaus, jossa käytät mukautettuja laattapalvelinmäärityksiä (esim. Jos olet lisännyt mukautetun pohjakartan, joka näyttää vain tietyn alueen karttalaatat ja panoroit karttasi alueen ulkopuolelle).

Jos kohtaat tämän ongelman usein yhden valitun laattapalveluntarjoajan kanssa, voit yrittää vaihtaa toiseen laattapalveluntarjoajaan karttaasi varten.

1
0
13653
Arvioi tämä UKK-vastaus

Mitkä ovat Maps Marker Pron vähimmäisvaatimukset?

Maps Marker Pron asennuksen on täytettävä seuraavat vähimmäisvaatimukset:

  • PHP 5.4 tai uudempi (nykyistä 7.x-versiota suositellaan, PHP-yhteensopivuus on testattu versioilla 7.0, 7.1, 7.2 ja 7.3)
  • WordPress 4.5 tai uudempi tai ClassicPress.
  • Lisenssiavaimen tarkistamiseksi palvelimen on voitava muodostaa yhteys osoitteeseen www.mapsmarker.com portin 443 kautta
0
0
4937
Arvioi tämä UKK-vastaus

Onko Maps Marker Pro yhteensopiva ClassicPressin kanssa?

ClassicPress on WordPressin muokattu ja parannettu versio (ilman Gutenberg), joka on saatavana osoitteesta https://www.classicpress.net/.

Maps Marker Pro on myös yhteensopiva ClassicPressin kanssa.

1
0
4859
Arvioi tämä UKK-vastaus

Voinko käyttää vientitiedostoa versiosta v3.1.1 tai uudemmasta ja tuoda se versioon v4 tai uudempaan?

Ei, koska v4.0 on kokonaan uusi laajennus, jossa on optimoitu tietokantakaavio (Maps Marker Pro v3.1.1: llä tai uudemmalla luodut CSV / XLS (X) / ODS) -tuontitiedostot eivät ole yhteensopivia Maps Marker Pro v4 -sovelluksen tuonnin kanssa. tai korkeampi.

0
0
34470
Arvioi tämä UKK-vastaus

Kuinka muuntaa muut muodot, kuten KML, GeoJSON: ksi?

Ilmainen online-työkalu osoitteessa https://geoconverter.hsr.ch/ antaa sinun muuntaa KML: n ja muiden muotoja GeoJSONiksi:

Voit sitten lisätä GeoJSON-karttaan Kartta-välilehdessä napsauttamalla painiketta “Lisää GeoJSONista”:

3
0
34383
Arvioi tämä UKK-vastaus

Kuinka korjata yhteensopimattomuus “Geo Redirect” -laajennuksen kanssa

Laajennus “Maantieteellinen uudelleenohjaus”Avulla voit ohjata vierailijoita tai vaihtaa kieltä heidän maansa mukaan. Valitettavasti päivitystä ei ole tehty vuodesta 2013 lähtien, ja tämän laajennuksen käyttäminen yhdessä Maps Marker Pron kanssa aiheuttaa kerroskarttojen rikkoutumisen (koska myös merkkien lataamiseen tarvittava lehtinen-geojson.php-puhelu ohjataan uudelleen.

Korjaa tämä avaamalla tiedosto /wp-content/plugin/geographical-redirect/geo-redirect.php

Löydä koodi

julkisen toiminnan tarkistusIfRedirectNeeded ()
{
if (! is_array ($ this-> geo_redirect_data))
palata;

ja korvata se

julkisen toiminnan tarkistusIfRedirectNeeded ()
{
// info: älä ohjaa Maps Marker Pro -pyyntöjä
$ request_uri = $ tämä-> request_uri;
if (stripot ($ request_uri, 'geojson')! == FALSE) {
palata;
}
if (! is_array ($ this-> geo_redirect_data))
palata;

ja tallenna tiedosto. Seurauksena on, että kerroskarttojen pitäisi toimia uudelleen.

0
0
9270
Arvioi tämä UKK-vastaus

Maantieteellisen sijainnin virhe: Vain turvattu alkuperä on sallittu / https vaaditaan

Chrome 50+: n, Firefox 55+: n ja Safari 10+: n kanssa asiaan liittyvät selaimen toimittajat tekivät merkittäviä muutoksia paikannustietoon: kaikki käyttäjän nykyistä sijaintia pyytävät sovellukset (ei vain Maps Marker Pron paikannusominaisuuden) ovat sallittuja enää hakea käyttäjän nykyinen sijainti, jos sivusto on asetettu toimitettavaksi turvallisesti https: n kautta - käyttäjät näkevät sen sijaan seuraavan tai vastaavan varoituksen:

Maantieteellisen-error-info

Katso lisätietoja Googlen päätöksestä osoitteessa https://developers.google.com/web/updates/2016/04/geolocation-on-secure-contexts-only. Maantieteellinen sijainti toimii edelleen muissa kuin https-sivustoissa, jos käyttäjät pääsevät sivustoon vaihtoehtoisten selainten, kuten Firefoxin, safari tai Internet Explorer - joka tapauksessa voi olla todennäköistä, että nämä selaimet lisäävät tulevaisuudessa myös samanlaisen tietoturvarajoituksen.

Päivitä marraskuu 2016: Koska iOS 10 myös Safari 10+ vaatii nyt https-sijainnin sijainnin tukemiseksi. Toteutus on jopa tiukempi kuin Google Chromen kanssa - maantieteellinen sijainti ei toimi esimerkiksi jos sivustossasi on sekoitetun sisällön varoituksia.

Päivitys 2017: Firefox 55+ vaatii myös https-sijainnin pääsyä varten (Katso yksityiskohdat)

Joten jos tarvitset Maps Marker Pron paikannusominaisuutta sivustollasi (joka v2.7: n avulla tulee jopa käyttökelpoisemmaksi, kun voit lajitella merkitsinluettelon käyttäjän nykyisen sijainnin perusteella), on erittäin suositeltavaa siirtää sivustosi https. Jotkut ylläpitäjät tarjoavat jo ilmaisia ​​https-varmenteita letsencrypt.org esimerkiksi. Tutustu ohjeisiin, kuten WordPress-sivustossasi tarvittavat kokoonpanot, jotta se määritetään tukemaan https: ää https://css-tricks.com/moving-to-https-on-wordpress/.

Koska https: llä on sivustollesi enemmän etuja kuin pelkkä paikkatietojen työskenteleminen uudelleen Google Chrome 50+: n ja Safari 10+: n kanssa (kuten tietojen eheyden turvaaminen, lähettäjien todennus ja käyttäjän yksityisyys sekä korkeampi Google-sijoitus, koska https: ää käytetään sijoitussignaalina), me suosittelemme vaihtamaan sivustosi https: ään vain, jos et ole vielä tehnyt niin.

Jos olet vaihtanut sivustosi https: ään ja saat silti paikannusvirheen (kuten ”Maantieteellisen sijainnin virhe: käyttäjän kieltämä maantieteellinen sijainti”), tarkista laitteen sijaintiasetukset, jos sovellukset / verkkosivustot saavat hakea maantieteellisen sijainnin.

2
0
7302
Arvioi tämä UKK-vastaus

Toimiiko Maps Marker Pro WordPress.com-sivuston isännöimissä sivustoissa?

Ei. WordPress.com-palvelimen käyttöympäristö ei salli lisälaajennusten asentamista, joten Maps Marker Pron asentaminen on mahdotonta. Maps Marker Pro toimii vain itse isännöimissä WordPress-asennuksissa.

0
0
4669
Arvioi tämä UKK-vastaus

Haluan myydä laajennuksesi. Onko sinulla jälleenmyyjäalennuksia?

Kyllä, me teemme. Meillä on ohjelma, jonka avulla voit myydä lisenssejä 20% alennuksella. Jos olet kiinnostunut Maps Marker Pron jälleenmyynnistä, käy ystävällisesti mapsmarker.com/reseller.

2
0
8527
Arvioi tämä UKK-vastaus

Voinko asentaa Maps Marker Pron WordPress MultiSite -asennukseen?

Kyllä, Maps Marker Pron asentaminen WordPress MultiSite -asennukseen on mahdollista. Muista vain, että lisenssimalli perustuu toimialueeseen, joten jos käytät aliverkkotunnuksia monisivustoasennukseen, sinun on aktivoitava lisenssi verkkotunnusta kohden. Jos alisivustosi ovat pääsy pääverkkotunnuksesi alihakemistoihin, vain pääsivusto on aktivoitava.

Löydät yksityiskohtaiset tiedot ja työkalun, jolla voit levittää lisenssisi alisivustoillesi lisenssiasetussivulta.

0
0
7823
Arvioi tämä UKK-vastaus
en English
X