향상된 마커 목록과 새로운 모니터링 도구가 포함 된 Pro v1.8 사용 가능

이 릴리스에서는 레이어 맵 아래의 마커 목록과 관련하여 향상된 기능에 중점을 두었습니다. 이는 사용자가 자주 요청한 기능 향상입니다. 또한 깨진지도에 대한 새로운 모니터링 도구를 추가했습니다. 자세한 내용은 아래를 참조하십시오.


이 새로운 릴리스에 대해 어떻게 생각하는지 알려주세요 검토 제출!

최신지도 마커 개발을 최신 상태로 유지하려면 @MapsMarker 트위터 (= 최신 업데이트) 페이스북, Google+ 를 통해 뉴스를 구독하거나 RSS 또는를 통해 RSS / 이메일.

나는 또한 당신이 우리와 함께 초대합니다 제휴 프로그램 최대 50 %의 수수료를 제공합니다. 리셀러가되고 싶다면 다음을 방문하십시오. https://www.mapsmarker.com/reseller


이제 프로 v1.8의 주요 내용을 살펴 보겠습니다.

레이어 맵 : 마커 중심 목록 및 마커 항목 목록을 클릭하여 팝업 열기

pro v1.8을 사용하면 이제 레이어 맵 아래의 마커 목록에서 마커 이름 또는 마커 아이콘을 클릭하고이 마커의 중심에 맵을 열고 팝업 텍스트를 열 수 있습니다.

리스트 마커 향상

기본적으로지도는 해당 마커를 중심으로하고 팝업을 엽니 다. 다른 클릭 동작을 원하는 경우 설정 /지도 기본값 / 마커 목록 설정으로 이동하여 새 옵션 "아이콘 또는 마커 이름을 클릭하기위한 기본 동작"을 변경하십시오. 당신의 요구에 :

리스트 마커 향상 설정

"이미 삭제 된 맵의 활성 단축 코드"를 모니터링하기위한 새로운 도구

나의 새로운 사이트를 찾을 때 쇼케이스 페이지, 더 이상 존재하지 않는 ID로지도를 표시하려고 시도한 페이지를 발견했습니다 (원래지도가 삭제되고 새지도가 생성되었지만 페이지의 단축 코드가 업데이트되지 않았을 가능성이 높습니다). 따라서지도 대신 다음 오류 이미지가 프런트 엔드의 사용자에게 표시됩니다.

지도 삭제 된 이미지

유효하지 않은 맵 ID에 대한 활성 단축 코드에 대해 알리기 위해, 유효하지 않은 맵 ID에 대한 활성 단축 코드가있는 프론트 엔드 컨텐츠가로드되면 관리자 통지를 표시하는 새로운 모니터링 도구를 추가했습니다. 결과적으로 WordPress 백엔드에 다음과 같은 관리자 통지가 표시됩니다.

모니터링 도구 관리자 알림

해당 링크를 클릭하면 Maps Marker Pro의 도구 섹션으로 이동하여 영향을받는 URL 목록을 표시합니다.

모니터링 도구 도구

다음 단계로 해당 URL로 이동하여 컨텐츠로 변경하여 유효하지 않은 단축 코드를 수정하십시오. 그런 다음 "목록 지우기"버튼을 클릭하면 관리자 알림 경고가 사라집니다.

백엔드에서 Google 지역 정보 자동 완성 API를 비활성화하는 옵션

요한 복음 보고에 따르면 중국에서는 최근에 Google API에 대한 액세스가 차단되었습니다. 영향을받는 사용자를위한 첫 단계로 프론트 엔드에서 Google Maps API 로딩을 비활성화하는 옵션을 소개했습니다. 프로 v1.6.

어쨌든 John은 백엔드에서 Google Places Autocomplete API를 사용하면 영향을받는 사이트의 속도가 크게 느려 졌다고보고했습니다.

따라서 프로 v1.8에서는 백엔드에서 Google Places Autocomplete API 로딩을 비활성화하는 새로운 옵션을 도입했습니다.이 옵션은 설정 / Google Maps / Google Places Autocomplete API에 있습니다.

google-places-status

사용 중지는 권장되지 않으며 백엔드에서 Google API에 연결하지 않으려는 경우에만 수행해야합니다 (예 : 사용자 국가에서 액세스가 차단 된 경우).

결과적으로 주소 별 위치 검색이 더 이상 작동하지 않으므로 클릭 및 확대 / 축소하거나 위도 및 경도 값을 직접 입력하여 위치를 수동으로 찾아야합니다.

google-places-disabled

또한 Google Places Autocomplete API를 사용 중지하면 설정 / Google Maps / Google Maps API에서 Google Map API로드를 사용 중지해야합니다. 그렇지 않으면 백엔드에서지도가 손상됩니다.

google-maps-api-disabled

다른 최적화 및 변경

  • 사전 정의되지 않은 사전 정의 된 MapBox 타일 "MapBox Streets"를 "Natural Earth I"로 교체 (새 설치에만 유효, 현재 사용자는 해당 변경 사항을 적용하기 위해 설정을 재설정해야 함)

버그 수정

  • 백엔드의 마커 및 레이어 확대 / 축소 입력 필드가 모바일 장치에서 너무 작습니다.
  • 단축 코드로만 작성된 맵의 정의되지 않은 인덱스 PHP 경고
  • 팝업 텍스트의 백 슬래시는 레이어 맵이 깨져 슬래시로 대체되었습니다 (Dmitry!).
  • 대시 보드 위젯에서 새 mapsmarker.com 블로그 게시물 및 링크 섹션을 숨기는 옵션이 깨졌습니다.

번역 업데이트

많은 동기를 부여한 기여자 덕분에이 릴리스에는 다음과 같은 업데이트 된 번역이 제공됩니다.

번역에 공헌하고 싶다면 (새로운 힌디어 번역가에게 감사 할 것입니다!) https://translate.mapsmarker.com/projects/lmm 문의주시기 바랍니다.

예를 들어 번역이 50 % 미만으로 완료된 경우 번역가는 번역을 25 % 완료 한 것에 대한 보상으로 € 149 상당의 무료 100 라이센스 팩을받습니다.

전망 – 다음 릴리스에 대한 나의 계획

Pro v1.9의 경우 지리적 위치 지원을 추가 할 계획입니다. 이는지도를보고있는 사용자의 현재 위치를 표시하는 버튼을 추가하는 것을 의미합니다. 데모보기 여기를 클릭해 주세요.

새로운 기능에 대한 출시 날짜를 약속 할 수 없음을 이해하십시오. 주요 새로운 기능 (Google 스트리트 뷰 지원 및 프런트 엔드에서 레이어 필터링 지원)에 대한 로드맵은 여전히 ​​유효합니다. 대부분 사용자 피드백에서 비롯된 계획되지 않은 마이너 릴리스로 최적화 및 버그 수정을 추가 할 수있는 유연성을 유지하고 싶습니다.

또한 로드맵을 참조하십시오 예정된 기능에 대한 대략적인 일정을 보려면이 블로그를 통해 구독하십시오 ( RSS or 이메일) 또는 @MapsMarker 최신 개발 뉴스를 최신 상태로 유지하려면 Twitter (= 최신 업데이트)를 사용하십시오.

전체 변경 내역

레이어 맵 : 마커 중심 목록 및 마커 항목 목록을 클릭하여 팝업 열기
"이미 삭제 된 맵의 활성 단축 코드"를 모니터링하기위한 새로운 도구
백엔드에서 Google 지역 정보 자동 완성 API를 사용 중지하는 옵션 ( 요한 복음 Google API에 대한 액세스가 차단 된 국가의 다른 사용자)
중단 된 사전 정의 된 MapBox 타일 "MapBox Streets"를 "Natural Earth I"로 교체
백엔드의 마커 및 레이어 확대 / 축소 입력 필드가 모바일 장치에서 너무 작습니다.
단축 코드로만 작성된 맵의 정의되지 않은 인덱스 PHP 경고
팝업 텍스트의 백 슬래시는 레이어 맵이 깨져 슬래시로 대체되었습니다 (Dmitry!).
대시 보드 위젯에서 새 mapsmarker.com 블로그 게시물 및 링크 섹션을 숨기는 옵션이 깨졌습니다.
번역 업데이트
번역에 도움이 필요하면 웹 기반 번역 플랫폼
독일어 번역 업데이트
Emre Erkan 덕분에 터키어 번역이 업데이트되었습니다. http://www.karalamalar.net 그리고 Mahir Tosun, http://www.bozukpusula.com

이전 변경 내역 표시

다운로드 / 업데이트 방법

업데이트하는 가장 쉬운 방법은 WordPress 업데이트 프로세스를 사용하는 것입니다. 관리자 권한이있는 사용자로 로그인하고 대시 보드 / 업데이트로 이동 한 후 업데이트 할 플러그인을 선택하고 "플러그인 업데이트"버튼을 누릅니다. 새 버전을 사용할 수 있으면 프로 플러그인에서 12 시간마다 확인합니다. 플러그인으로 이동하여 "Maps Marker Pro"옆에있는 "수동으로 업데이트 확인"링크를 클릭하여 업데이트 확인을 수동으로 트리거 할 수도 있습니다.

수동 업데이트 확인

"업데이트 확인"링크가 표시되지 않고 1.7 미만의 버전을 사용중인 경우 현재 패키지를 다운로드하여 수동으로 한 번 업데이트하십시오. https://www.mapsmarker.com/download-pro FTP를 통해 서버의 기존 플러그인 파일을 덮어 씁니다. 이는 오래된 SSL 라이브러리를 사용하는 여러 호스트에서 필요할 수 있으며, 이로 인해 Maps Marker Pro가 mapsmarker.com에서 업데이트 패키지를 검색하기 위해 보안 연결을 설정할 수 없습니다. Pro v1.7에는 이러한 종류의 서버에 대한 해결 방법이 포함되어 있으며 다음 업데이트는 평소와 같이 다시 작동해야합니다. 영향을 받고 도움이 필요하면 지원 티켓을여십시오..

베타 테스터에 대한 추가 업데이트 정보

플러그인 업데이트에 대한 추가 조치가 필요하지 않습니다.

코멘트를 남겨

XHTML : 다음 태그를 사용할 수 있습니다. <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

en English
X