Info: dette er ikke endringsloggen for siste stabile versjon 4.13.1
se alle skiftelogger

Pro v3.0-støtteblad.js v1.0.3, GoogleMutant, Polylang, ganske permalinks og mye mer er tilgjengelig

Etter 3 måneders utvikling, 3 betaversjoner og 1 utgivelseskandidat er vi stolte av å kunngjøre tilgjengeligheten av Maps Marker Pro v3.0.

En oppdatering til den nyeste versjonen er - som alltid - sterkt anbefalt. For mer informasjon om denne utgivelsen, se nedenfor.


La oss få vite hva du synes om denne nye utgivelsen av sende inn en anmeldelse eller legge igjen en kommentar nedenfor!

Hvis du vil holde deg oppdatert med den siste Maps Marker Pro-utviklingen, følg @MapsMarker på twitter (= siste oppdateringer), på Facebook , Google+ eller abonner på nyheter via RSS eller via RSS / e-post.

Vi vil også invitere deg til å bli med på vår affiliate program som tilbyr provisjoner opptil 50%. Hvis du er interessert i å bli forhandler, kan du gå til https://www.mapsmarker.com/reseller


La oss nå komme til høydepunktene i pro v3.0:

Vi er glade for å ønske den globetrotter ingeniøren Thorsten velkommen som blir med Kart Marker Pro-teamet!

Globetrotting ingeniør Thorsten forsterker våre rekker, og trekker ut fra egen erfaring som bruker: Thorsten bruker Maps Marker Pro for å dokumentere sin kyst-til-kyst biltur gjennom Canada på sin reiseblogg Fuel & Bacon.

oppgradert leaflet.js fra v0.7.7 til v1.0.3

Leaflet.js kan bli referert til som “motoren til Maps Marker Pro” og har blitt oppgradert fra v0.7.7 til v1.0.3, noe som resulterer i høyere ytelse og brukervennlighet.

Vennligst se blogginnlegg på leafletjs.com og full changelog for mer informasjon.

Beta (opt-in): betydelig forbedret ytelse for Google basemaps ved å bruke brosjyren plugin GoogleMutant

Faktisk planla vi også å erstatte (forlatte) implementering av Google Maps brosjyre med shramov med mye mer utøvende GoogleMutant brosjyre-plugin av Iván Sánchez. Uansett ett problem med blokkering fortsatt er åpent (#27 - Hjelp oss 😉) og siden vi ikke ønsket å utsette Maps Marker Pro v3.0 lenger, bestemte vi oss for å ikke endre standard implementeringsmetode ennå.

Du kan teste GoogleMutant-pluginen manuelt ved å endre det relaterte alternativet under Innstillinger / Basemaps / "Google Maps JavaScript API":

Når nr. 27 er løst, vil dette alternativet bli oppdatert for alle brukere med en fremtidig utgivelse av Maps Marker Pro.

byttet automatisk til Algolia Places som standard leverandør av geokoding hvis Mapzen Search uten API-nøkkel brukes. Det anbefales fortsatt registrering)

Dessverre vår anbefalte leverandør av geokoding Mapzen Søk vil endre retningslinjene innen april 2017, og gjøre (gratis) API-nøkler obligatoriske for å bruke deres geokodingstjeneste.

Så i tilfelle du ikke har registrert deg for en API-nøkkel, vil geokoding leverandør automatisk bytte til Algolia steder med Maps Marker Pro v3.0 og Photon @ MapsMarker som tilbydere av tilbakelevering av geokoding.

Siden Mapzen drives av opendata og inkluderer også tilleggsdata fra kilder som openaddresses.io i deres geokodingsresultater, anbefaler vi fortsatt å registrere en gratis Mapzen Search API-nøkkel - den tilhørende opplæringen kan bli funnet franske baguetter..

legg til forhåndsbelastning for kartfliser utenfor kanten av det synlige kartet for å forhindre at det vises bakgrunn bak flisebilder når du panorerer et kart

Med v3.0 integrerte vi også brosjyre-pluginen Leaflet.EdgeBuffer for å støtte forhåndsbelastning utover kanten av det synlige kartet. Som et resultat er det mindre sannsynlig at den svarte bakgrunnen under flisene blir sett, noe som resulterer i en bedre brukeropplevelse mens du panorerer kart:

For et levende eksempel, se sammenligningen kl http://www.tolon.co.uk/Leaflet.EdgeBuffer/comparison.html

Som standard er 2 fliser forhåndsinnlastet med Maps Marker Pro v3.0 - uansett kan du endre denne verdien ved å endre den nye innstillingen “edgeBufferTiles” ved Innstillinger / Kartdefaults / Globale innstillinger for baskart:

Polylang oversettelsesstøtte for flerspråklige kart

Med v2.9 la vi til støtte for flerspråklige kart ved å bruke WPML. På grunn av forespørsler fra mange brukere har vi også lagt til støtte for Polylang oversettelse plugin med v3.0, noe som gir deg mer valg når du gjør kartene dine tilgjengelige på forskjellige språk. Se https://www.mapsmarker.com/flerspråklig for flere detaljer.

Tusen takk Thorsten for implementeringen av denne funksjonen!

støtte for verktøytips for å vise markørnavnet som liten tekst øverst på markørikonene

Markørnavnet vises nå som liten tekst øverst på markørikonene når du holder markørikonet:

Ettersom den opprinnelige Leaflet-verktøytipsfunksjonen som er lagt til med leaflet.js 1.0, blir brukt nå i stedet for HTML-tittelkoder, kan du tilpasse verktøytipets oppførsel i henhold til dine behov under Innstillinger / Kartdefaults / Marker verktøytipsinnstillinger:

nytt alternativ for å åpne popups på musepekeren i stedet for med museklikk

Med v3.0 er det nå også mulig å åpne popups på musepekeren istedenfor museklikk. Dette alternativet er deaktivert som standard og kan aktiveres ved Innstillinger / Kartverdier / Standardverdier for markør popups:

Ganske permalinks med tilpassbar snegle for fullskjermskart og API-er

Med v3.0 fjernet vi også behovet for å få direkte tilgang til plugin-filer for f.eks. Fullskjerm-kart eller API-koblinger. Som standard er sluggen / Kart / brukes nå og kan endres via Innstillinger / Diverse / “Permalinks slug”:

Eksempel lenke til markørkart ID 1 med fullskjerm med ganske permalinks: https://www.mapsmarker.com/maps/fullscreen/marker/1/

Hvis du koblet direkte på fullskjerm-kart eller andre API-koblinger (som https://www.mapsmarker.com/wp-content/plugin/leaflet-maps-marker-pro/leaflet-fullscreen.php?marker=1), trenger du ikke å endre noe - brukere vil automatisk bli videresendt til den nye pene permalinken.

AMP-støtte

v3.0 legger til grunnleggende AMP-støtte, og viser et plassasjonsbilde for kart med lenke til fullskjermvisning på AMP-aktiverte sider - tusen takk Sebastian!

For v3.1 vil vi sjekke om vi kan forbedre denne integrasjonen ved å vise innfødte kart på AMP-aktiverte sider.

Andre endringer og optimaliseringer

  • ~ 15% ytelsesforbedring for API-samtaler ved å eliminere unødvendige WordPress-initialiseringer via wp-load.php (thx Thorsten!)
  • nye funksjoner for MMPAPI: list_markers (), list_layers (), get_layers ($ layer_ids) - fulle dokumenter (Thx mye Thorsten!)
  • nytt alternativ for å deaktivere WPML / Polylang-integrasjon
  • forbedret kompatibilitetssjekk for WP Rocket (som kan føre til at kart går i stykker hvis Maps Marker Pro Javascripts ikke er ekskludert)
  • legg til støtte for PHP APCu-hurtigbufring for økter som brukes i MMP_Geocoding-klassen
  • mulighet for å sortere "liste alle markører" og "liste alle lag" tabeller etter sted (thx Paul!)
  • kompatibilitetssjekk for “Async Javascript” plugin (thx Adam!)
  • opprett brukerøkter for geokoding bare hvis MMP_Geocoding-klasse brukes
  • optimalisert SQL for lasting av markører på (enkelt) lagringssider (thx Thorsten!)
  • oppdatert Leaflet.fullscreen markercluster kodebase til v1.0.2 (thx jfirebaugh!)
  • forbedret ytelse på markør- og lagredigeringssider ved å bruke HTML5 datetime i stedet for timepicker.js bibliotek + avhengigheter (thx Thorsten!)
  • forbedret alternativ "Avregistrere Google Maps API-skripter som er pålagt av tredjeparter" for å forhindre gjenoppretting av skript ved også å avregistrere dem
  • forbedret ytelse for plugin-oppdaterer (kjør backend-sjekk for tilgang til plugin-oppdateringer bare hvis en oppdatering er tilgjengelig - thx Thorsten!)
  • fjernet integrert WPML-installasjonsprogram for å forbedre backend-ytelsen, og det er rapportert om problemer med NextGen Gallery
  • økte maks antall karer for filterkontrollboks fra 4000 til 65535 for å forhindre ødelagte kontrollbokser (thx Michelle!)
  • bruk alltid https for å laste bing kartfliser
  • importør: ikke vis ugyldige verdivarsler for opprettede og oppdaterte rader hvis revisjonsalternativet er av og relaterte kildekolonner er tomme
  • Bruk demokartbilde i stedet for Maps Marker Pro-logoen som plassholderbilde for kart i RSS-feeder
  • endret KML-spørring var navn til merkenavn for å unngå WP-konflikter

Feilrettinger

  • Problemer med WPML-ytelse på nettsteder med 1000+ oversatte kartstrenger (thx Thorsten!)
  • ødelagte innstillingsnavigasjon på grunn av pålagte bootstrap-filer fra tredjeparts plugins (thx Bob!)
  • koblet til oversettelsesside for WPML-streng på lagredigeringssider i stedet til https://mapsmarker.com/multilingual, selv om WPML ikke var tilgjengelig (thx Thorsten!)
  • legg til løsning hvis markørikoner ikke vises på backend på siden med markørredigering og verktøy (thx Ron!)
  • MMPAPI: fikse problemet for valg av lag-ID og søkefeilmelding for grenseboks (thx Thorsten!)
  • konflikt med iThemes Security Pro-plugin og htaccess-konfigurasjoner som forhindrer direkte tilgang til Maps Marker Pro API-endepunkter (thx David!)
  • WP-sesjonsoppføringer i wp_options-tabellen ble ikke slettet via WordPress cron-jobb (thx mye Thorsten!)
  • fikse PHP APC cache deteksjon for importør og MMP_Geocoding klasse
  • markøreksport: søk i lag via select2-bibliotek ble ødelagt
  • PHP-advarsel etter at innstillinger ble tilbakestilt til standardinnstillinger (thx Thorsten!)
  • liste over markører under lagkart: markertellingen kan være feil under visse omstendigheter
  • skillet i zoomkontroll mellom + og - knappene manglet siden v2.9
  • lokasjonssøkefelt som overlapper overføring av GPX-medieopplastning forårsaket av for høy z-verdi
  • sorteringsrekkefølge for siden "list alle lag" ble ødelagt hvis sorteringskriterier ble valgt (thx Thorsten!)
  • markørredigeringsside kan bli ødelagt på grunn av udefinerte variable advarsler kun for spesifikke PHP-konfigurasjoner (thx Nadine!)
  • veibeskrivelseslenke ble lagt til popup-tekst på redigeringssiden for markøren (bare under forhåndsvisning) selv om innstillingen var deaktivert
  • Javascript-feil når du bruker personsøk i listen over markører under lagkart på lagredigeringssider
  • standard popup-egenskaper for markør ble ikke vurdert hvis de ble utløst via geokoding
  • JSON feil når du bruker WebAPI / søkefunksjonen (thx Elizabeth!)
  • tydelige markørzoomnivåer når åpne popups via liste over markørkoblinger ikke ble brukt hvis klynger var deaktivert
  • Å åpne popups via liste over markører kan ødelegge kartsenteret hvis klynging var aktivert (thx Damian!)
  • udefinert JavaScript-advarsel når du klikker på markørnavnet i listen over markører hvis klynger var deaktivert
  • lags midtmarkør på backend ble ikke vist lenger etter at klynger ble lastet inn
  • sorteringsrekkefølge for liste over markører ble ikke gjenopprettet etter å ha ryddet søkefeltet (thx Damian & Thorsten!)
  • bruk av “endre lag-ID” -tool kan føre til feil lagtilordninger (thx Patricia & Thorsten!)
  • CSS-konflikter med valgte temaer (noe som resulterer i grenser rundt fliser på Google Maps)
  • kontrolltegn som faner i markørnavn kan ødelegge gyldigheten av GeoJSON-matrisen for liste over markører (thx Stefan!)
  • ødelagt liste over markører når søkeord ikke gir noen resultater (thx Damian & Thorsten!)
  • lisensbeskyttelsen var for streng for localhost-installasjoner, hvor ubegrenset testing er tillatt (thx Daniel!)
  • fast geolokasjon går tapt når du bruker liste over markører-søkefelt (thx Damian & Thorsten!)

Sikkerhetsfikser

For noen uker siden lanserte vi et privat bounty-program for hackerone-sikkerhetsfeil, som resulterte i følgende sikkerhetsrapporter som ble løst med denne utgivelsen:

  • Lav innvirkning (kan brukes bare for administratorer): Reflektert XSS-sårbarhet på siden med lisensinnstillinger (thx til Deepanker Chawla via hackerone)
  • Lav innvirkning (kan brukes bare for backend-kartredigeringsprogrammer): Lagret XSS-sårbarhet for plassering og markør / lagnavn på "liste alle lag" / "liste alle markører" -siden (thx til Deepanker Chawla via hackerone)
  • Lav innvirkning (kan brukes bare for backend-kartredaktører): Reflektert XSS-sårbarhet på markørredigeringsside (thx til Deepanker Chawla via hackerone)
  • Lav innvirkning (kan brukes bare for administratorer): DOM-basert XSS-sårbarhet på innstillingssiden (thx til Deepanker Chawla via hackerone)

Vi planlegger å offentliggjøres med vårt bounty-program for hackerone-sikkerhetsfeil i løpet av nær fremtid i tilfelle du er interessert i å delta. Følg bloggen vår for mer informasjon.

Kjente problemer

Geolocation-funksjonen fungerer ikke lenger med Google Chrome 50+ og Safari 10+ med mindre nettstedet ditt er sikkert tilgjengelig via https

Med Chrome 50 (og Safari 10) ble betydelige endringer i geolokaliseringsstøtten introdusert av de relaterte nettlesereleverandørene: alle applikasjoner som ber om den nåværende plasseringen til brukeren (ikke bare for Maps Marker Pro 's geolocation-funksjon), er bare tillatt lenger å hente brukerens nåværende posisjon hvis nettstedet er konfigurert til å bli levert sikkert via https - brukere vil se følgende eller en lignende advarsel i stedet:

geolocation-feil-info

Se flere detaljer om denne avgjørelsen fra Google på https://developers.google.com/web/updates/2016/04/geolocation-on-secure-contexts-only. Geolocation vil fortsatt fungere på nettsteder som ikke er https hvis brukerne får tilgang til nettstedet via alternative nettlesere som Firefox, Safari eller Internet Explorer - uansett kan det være sannsynlig at disse nettleserne også vil legge til en lignende sikkerhetsbegrensning i fremtiden.

Oppdater november 2016: siden iOS 10 krever også Safari 10+ https for å støtte geolocation. Implementeringen er enda strengere enn med Google Chrome - geolokalisering vil ikke fungere for eksempel hvis det er advarsler med blandet innhold på nettstedet ditt.

Så hvis du trenger Maps Marker Pro geolocation featue på nettstedet ditt, anbefales det sterkt å migrere nettstedet til https. Noen hosters tilbyr allerede gratis https-sertifikater fra letsencrypt.org for eksempel. For konfigurasjoner som trengs på WordPress-nettstedet ditt for å konfigurere det til å støtte https, kan du ta en titt på veiledninger som https://css-tricks.com/moving-to-https-on-wordpress/.

Ettersom https har flere fordeler for nettstedet ditt enn bare geolokalisering som jobber igjen med Google Chrome 50+ og Safari 10+ (som å sikre dataintegriteten, avsendergodkjenning og brukernes personvern samt høyere Google-rangering etter hvert som https brukes som rangeringssignal), bruker vi anbefaler du å bytte nettstedet ditt til https bare hvis du ikke har gjort det ennå.

Hvis du byttet nettstedet til https og fremdeles får en geolokasjonsfeil (som "Geolocation error: user avslått geolocation"), kan du sjekke enhetens plasseringsinnstillinger hvis det er tillatt for apper / nettsteder å hente geolocation.

Oversettelser oppdateres

Vi har også oppdatert Glotpress-forekomsten vår på https://translate.mapsmarker.com til v2.3.1, slik at oversettere kan merke oversettelser som uklar, tilbakestilt passord tilbakestilt av brukere, designoppdatering og mer.

Takket være mange motiverte bidragsytere inkluderer denne utgivelsen følgende oppdaterte oversettelser:

Hvis du vil bidra til oversettelser (nye hindi-oversettere vil bli satt pris på!), Vennligst besøk https://translate.mapsmarker.com/projects/lmm for mer informasjon.

Vær oppmerksom på at oversetterne også blir kompensert for deres bidrag - for eksempel hvis en oversettelse er ferdig mindre enn 50%, får oversetteren en gratis pakke på 25 lisenser til en verdi av € 249 som kompensasjon for å fullføre oversettelsen til 100%.

Outlook - planer for de neste utgivelsene

Vær oppmerksom på at vi ikke kan love noen utgivelsesdatoer for nye funksjoner. Vi justerer vårt veikart dynamisk basert på tilbakemeldinger fra brukerne våre. Vi holder uansett fleksibiliteten til å legge til optimaliseringer og bugfixes med ganske ikke planlagte mindre utgivelser som hovedsakelig skyldes tilbakemeldinger fra brukerne.

Abonner på denne bloggen (via RSS or E-post) eller følg @MapsMarker på twitter (= mest aktuelle oppdateringer) hvis du vil holde deg oppdatert med de siste utviklingsnyhetene.

Full changelog

Vi er glade for å ønske den globetrotter ingeniøren Thorsten velkommen som blir med Kart Marker Pro-teamet!
oppgradert leaflet.js (“motoren til Maps Marker Pro”) fra v0.7.7 til v1.0.3 for høyere ytelse og brukervennlighet - se blogginnlegg på leafletjs.com og full changelog for mer informasjon
Beta (opt-in): betydelig forbedret ytelse for Google basemaps ved å bruke brosjyren plugin GoogleMutant (thx Ivan!)
legg til forhåndsbelastning for kartfliser utenfor kanten av det synlige kartet for å forhindre at det vises bakgrunn bak flisebilder når du panorerer et kart
Polylang oversettelsesstøtte for flerspråklige kart (thx Thorsten!)
støtte for verktøytips for å vise markørnavnet som liten tekst øverst på markørikonene
nytt alternativ for å åpne popups på musepekeren istedenfor museklikk (deaktivert som standard)
Ganske permalinks med tilpassbar snegle for fullskjermskart og API-er (f.eks. Https://www.mapsmarker.com/dev/pro/kart/ fullskjerm / markør / 1 / - thx Thorsten!)
nye funksjoner for MMPAPI: list_markers (), list_layers (), get_layers ($ layer_ids) - fulle dokumenter (Thx mye Thorsten!)
nytt alternativ for å deaktivere WPML / Polylang-integrasjon
forbedret kompatibilitetssjekk for WP Rocket (som kan føre til at kart går i stykker hvis Maps Marker Pro Javascripts ikke er ekskludert)
legg til støtte for PHP APCu-hurtigbufring for økter som brukes i MMP_Geocoding-klassen
mulighet for å sortere "liste alle markører" og "liste alle lag" tabeller etter sted (thx Paul!)
kompatibilitetssjekk for “Async Javascript” plugin (thx Adam!)
AMP-støtte: vis plassholderbilde for kart med lenke til fullskjermvisning på AMP-aktiverte sider (thx Sebastian!)
byttet automatisk til Algolia Places som standard leverandør av geokoding hvis Mapzen Search uten API-nøkkel brukes (API-nøkler blir obligatoriske innen april 2017 - fortsatt anbefales gratis registrering)
~ 15% ytelsesforbedring for API-samtaler ved å eliminere unødvendige WordPress-initialiseringer via wp-load.php (thx Thorsten!)
opprett brukerøkter for geokoding bare hvis MMP_Geocoding-klasse brukes
optimalisert SQL for lasting av markører på (enkelt) lagringssider (thx Thorsten!)
oppdatert Leaflet.fullscreen markercluster kodebase til v1.0.2 (thx jfirebaugh!)
forbedret ytelse på markør- og lagredigeringssider ved å bruke HTML5 datetime i stedet for timepicker.js bibliotek + avhengigheter (thx Thorsten!)
forbedret alternativ "Avregistrere Google Maps API-skripter som er pålagt av tredjeparter" for å forhindre gjenoppretting av skript ved også å avregistrere dem
forbedret ytelse for plugin-oppdaterer (kjør backend-sjekk for tilgang til plugin-oppdateringer bare hvis en oppdatering er tilgjengelig - thx Thorsten!)
fjernet integrert WPML-installasjonsprogram for å forbedre backend-ytelsen, og det er rapportert om problemer med NextGen Gallery
økte maks antall karer for filterkontrollboks fra 4000 til 65535 for å forhindre ødelagte kontrollbokser (thx Michelle!)
bruk alltid https for å laste bing kartfliser
importør: ikke vis ugyldige verdivarsler for opprettede og oppdaterte rader hvis revisjonsalternativet er av og relaterte kildekolonner er tomme
Bruk demokartbilde i stedet for Maps Marker Pro-logoen som plassholderbilde for kart i RSS-feeder
endret KML-spørring var navn til merkenavn for å unngå WP-konflikter
Problemer med WPML-ytelse på nettsteder med 1000+ oversatte kartstrenger (thx Thorsten!)
ødelagte innstillingsnavigasjon på grunn av pålagte bootstrap-filer fra tredjeparts plugins (thx Bob!)
koblet til oversettelsesside for WPML-streng på lagredigeringssider i stedet til https://mapsmarker.com/multilingual, selv om WPML ikke var tilgjengelig (thx Thorsten!)
legg til løsning hvis markørikoner ikke vises på backend på siden med markørredigering og verktøy (thx Ron!)
MMPAPI: fikse problemet for valg av lag-ID og søkefeilmelding for grenseboks (thx Thorsten!)
konflikt med iThemes Security Pro-plugin og htaccess-konfigurasjoner som forhindrer direkte tilgang til Maps Marker Pro API-endepunkter (thx David!)
WP-sesjonsoppføringer i wp_options-tabellen ble ikke slettet via WordPress cron-jobb (thx mye Thorsten!)
fikse PHP APC cache deteksjon for importør og MMP_Geocoding klasse
markøreksport: søk i lag via select2-bibliotek ble ødelagt
PHP-advarsel etter at innstillinger ble tilbakestilt til standardinnstillinger (thx Thorsten!)
liste over markører under lagkart: markertellingen kan være feil under visse omstendigheter
skillet i zoomkontroll mellom + og - knappene manglet siden v2.9
lokasjonssøkefelt som overlapper overføring av GPX-medieopplastning forårsaket av for høy z-verdi
sorteringsrekkefølge for siden "list alle lag" ble ødelagt hvis sorteringskriterier ble valgt (thx Thorsten!)
markørredigeringsside kan bli ødelagt på grunn av udefinerte variable advarsler kun for spesifikke PHP-konfigurasjoner (thx Nadine!)
veibeskrivelseslenke ble lagt til popup-tekst på redigeringssiden for markøren (bare under forhåndsvisning) selv om innstillingen var deaktivert
Javascript-feil når du bruker personsøk i listen over markører under lagkart på lagredigeringssider
standard popup-egenskaper for markør ble ikke vurdert hvis de ble utløst via geokoding
JSON feil når du bruker WebAPI / søkefunksjonen (thx Elizabeth!)
tydelige markørzoomnivåer når åpne popups via liste over markørkoblinger ikke ble brukt hvis klynger var deaktivert
Å åpne popups via liste over markører kan ødelegge kartsenteret hvis klynging var aktivert (thx Damian!)
udefinert JavaScript-advarsel når du klikker på markørnavnet i listen over markører hvis klynger var deaktivert
lags midtmarkør på backend ble ikke vist lenger etter at klynger ble lastet inn
sorteringsrekkefølge for liste over markører ble ikke gjenopprettet etter å ha ryddet søkefeltet (thx Damian & Thorsten!)
bruk av “endre lag-ID” -tool kan føre til feil lagtilordninger (thx Patricia & Thorsten!)
CSS-konflikter med valgte temaer (noe som resulterer i grenser rundt fliser på Google Maps)
kontrolltegn som faner i markørnavn kan ødelegge gyldigheten av GeoJSON-matrisen for liste over markører (thx Stefan!)
ødelagt liste over markører når søkeord ikke gir noen resultater (thx Damian & Thorsten!)
lisensbeskyttelsen var for streng for localhost-installasjoner, hvor ubegrenset testing er tillatt (thx Daniel!)
fast geolokasjon går tapt når du bruker liste over markører-søkefelt (thx Damian & Thorsten!)
Lav innvirkning (kan brukes bare for administratorer): Reflektert XSS-sårbarhet på siden med lisensinnstillinger (thx til Deepanker Chawla via hackerone)
Lav innvirkning (kan brukes bare for backend-kartredigeringsprogrammer): Lagret XSS-sårbarhet for plassering og markør / lagnavn på "liste alle lag" / "liste alle markører" -siden (thx til Deepanker Chawla via hackerone)
Lav innvirkning (kan brukes bare for backend-kartredaktører): Reflektert XSS-sårbarhet på markørredigeringsside (thx til Deepanker Chawla via hackerone)
Lav innvirkning (kan brukes bare for administratorer): DOM-basert XSS-sårbarhet på innstillingssiden (thx til Deepanker Chawla via hackerone)
Oversettelsesoppdateringer
Hvis du vil hjelpe med oversettelser, kan du gå til nettbasert oversettelsesplattform
oppdatert https://translate.mapsmarker.com til GlotPress 2.3.1 (merk oversettelser som uklar, tilbakestilt passord tilbakestilt av brukere, designoppdatering og mer)
oppdatert nederlandsk oversettelse takket være Marijke Metz - http://www.mergenmetz.nl, Patrick Ruers, http://www.stationskwartiersittard.nl, Fokko van der Leest - http://wandelenrondroden.nl og Hans Temming - http://www.wonderline.nl
oppdatert fransk oversettelse takket være Vincèn Pujol, http://www.skivr.com og Rodolphe Quiedeville, http://rodolphe.quiedeville.org, Fx Benard, http://wp-translator.com, cazal cédric, http://www.cedric-cazal.com, Fabian Hurelle, http://hurelle.fr og Thomas Guignard, http://news.timtom.ch
oppdatert galisisk oversettelse takket være Fernando Coello, http://www.indicepublicidad.com
oppdatert tysk oversettelse takket være Thorsten
oppdatert italiensk oversettelse takket være Luca Barbetti, http://twitter.com/okibone og Angelo Giammarresi - http://www.wocmultimedia.biz
oppdaterte japanske oversettelser takket være Shu Higash og Taisuke Shimamoto
oppdatert latvisk oversettelse takket være Juris Orlovs, http://lbpa.lv og Eriks Remess http://geekli.st/Eriks
oppdatert litauisk oversettelse takket være Donatas Liaudaitis - http://www.transleta.co.uk og Ovidijus - http://www.manokarkle.lt
oppdatert oversettelse fra portugisisk - Brasil (pt_BR) takket være Fabio Bianchi - http://www.bibliomaps.com, Andre Santos - http://pelaeuropa.com.br og Antonio Hammerl
oppdatert russisk oversettelse takket være Ekaterina Golubina (støttet av Teplitsa fra Social Technologies - http://te-st.ru) og Vyacheslav Strenadko, http://slavblog.ru
oppdatert spansk oversettelse takket være David Ramírez, http://www.hiperterminal.com, Alvaro Lara, http://www.alvarolara.com, Victor Guevara, http://1sistemas.net, Ricardo Viteri, http://www.labviteri.com, Juan Valdes og Marta Espinalt, http://www.martika.es
oppdatert svensk oversettelse takket være Olof Odier http://www.historiskastadsvandringar.se, Tedy Warsitha http://codeorig.in/, Dan Paulsson http://www.paulsson.eu, Elger Lindgren, http://bilddigital.se, Anton Andreasson, http://andreasson.org/ og Tony Lygnersjö - https://www.dumsnal.se/
Kjente problemer
Geolocation-funksjonen fungerer ikke lenger med Google Chrome 50+ og iOS / Safari 10+ med mindre nettstedet ditt er sikkert tilgjengelig via https (detaljer)

Vis alle tilgjengelige veksler

Hvordan laste ned / oppdatere

Den enkleste måten å oppdatere er å bruke WordPress-oppdateringsprosessen: logg inn med en bruker som har administratorrettigheter, naviger til Dashboard / Updates, velg plugins som skal oppdateres og trykk på knappen “Update Plugins”. Pro-plugin sjekker hver 24. time om en ny versjon er tilgjengelig. Du kan også utløse oppdateringssjekken manuelt ved å gå til Plugins og klikke på lenken "Manuelt se etter oppdateringer" ved siden av "Maps Marker Pro":

manual-update-sjekk

Hvis du ikke ser lenken "Sjekk etter oppdateringer" og bruker en versjon under 1.7, må du oppdatere manuelt en gang ved å laste ned gjeldende pakke fra https://www.mapsmarker.com/download-pro og overskrive eksisterende plugin-filer på serveren din via FTP. Dette kan være nødvendig på flere verter, som bruker utdaterte SSL-biblioteker, som forhindrer Maps Marker Pro i å opprette en sikker forbindelse for å hente oppdateringspakken fra mapsmarker.com. Pro v1.7 inkluderer en løsning for den typen servere, og følgende oppdateringer skal fungere som vanlig. Hvis du er berørt og trenger hjelp, vær så snill åpne en støtte billett.

Slik bekrefter du integriteten til plugin-pakken

SHA-256 hashverdi:

AAC3E05208CEE2736D0F8514F61F91A43456742516A95DF2FDCBEE4B47BD69E5

Klikk her for en veiledning for å bekrefte integriteten til plugin-pakken (anbefales hvis plugin-pakken for en ny installasjon ikke ble lastet ned fra https://www.mapsmarker.com - bekreftelse er ikke nødvendig, men hvis den automatiske oppdateringsprosessen brukes)

Ytterligere oppdateringsnotater for betatester

Ingen ekstra handlinger for plugin-oppdatering fra beta til endelig versjon er påkrevd.

Legg igjen en kommentar

XHTML: Du kan bruke disse kodene: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

en English
X