Ofte Stilte Spørsmål

Feil "Kunne ikke sende forespørsel" når du prøvde å migrere til v4

Denne feilen indikerer at det er noen problemer med AJAX-konfigurasjonen din henholdsvis wp-admin / admin-ajax.php endepunkt.

For å bekrefte dette, vennligst åpne nettleserkonsollen (f.eks. Med F12 i Firefox eller krom), bytt til "Konsoll" -fanen og last inn siden på nytt og klikk på "Sjekk migrering" igjen for å bekrefte om det er flere feilmeldinger:

Hvis du ikke ser en feilmelding der, kan du bytte til "Nettverk" -fanen og laste inn siden på nytt og klikke på "Sjekk migrering" igjen for å bekrefte om det er flere feilmeldinger:

Fra skjermbildet over ser du at forespørselen mislyktes med Status (= HTTP-feilkode) 404 - i dette eksemplet var filen /wp-admin/admin-ajax.php ikke tilgjengelig.

Det er imidlertid mer sannsynlig at du vil se Status 500 (= Intern serverfeil) her. 500 Internserverfeil er den generelle fangstfeilen når serveren kaster et unntak. Det er feilmeldingen når ikke en mer spesifikk feilmelding er egnet og i de fleste tilfeller er direkte relatert til en serverfeilkonfigurasjon eller -problem.

Så hva gjør nå?

Først, prøv å deaktivere alle andre plugins midlertidig, men Maps Marker Pro for å bekrefte at dette problemet ikke er forårsaket av en plugin-konflikt.

Hvis dette ikke hjelper, kan du ta en titt på serverfeilloggen som PHP eller Apache feillogg når denne forespørselen er laget, og som kan gi deg en anelse om hvorfor denne feilen skjer på serveren din.

Hvis dette fremdeles ikke hjelper, kan du sjekke om en av følgende opplæringsprogrammer kan hjelpe deg med å finne årsakene til denne serverfeilen:

Hvis dette fremdeles ikke hjelper, anbefaler vi at du tar kontakt med hostingstøtten din, slik at de kan analysere hvorfor forespørselen til /wp-admin/admin-ajax.php mislykkes når du prøver å kjøre migreringsverktøyet.

0
0
5091
Ranger dette vanlige svaret

Kan kart vises med 100% høyde?

Maps Marker Pro lar deg stille bredden på et kart i piksel- eller% -verdier:

Høydeverdien kan imidlertid også gis som pikselverdi på grunn av begrensninger i HTML.

Hvis du vil vise et kart på fullskjerm, kan du bruke den dedikerte fullskjermvisningen i stedet, som du kan få tilgang til via en permalink via kartpanelet

eller bruk HTML5 fullskjerm-knappen på kartet under zoomikonene:

0
1
517
Ranger dette vanlige svaret

Kan spor fra treningssporere vises på kart?

Hvis fitness-trackerne dine (som garmin fit) tillater å eksportere innspilte spor som GPX-format, kan disse filene vanligvis også vises på kart med Maps Marker Pro.

For å vise disse sporene, opprett et nytt kart, bytt til fanen “GPX” og start med å klikke på “Åpne mediebiblioteket” -knappen:

Som neste trinn bytter du til fanen "Last opp filer", velg og last opp gpx-filen, avslutt med å klikke på knappen "Velg":

Som et resultat vises GPX-sporet på kartet, og du kan eventuelt tilpasse innstillingene ytterligere (å bytte til avansert redigeringsprogram for alle alternativer anbefales):

0
0
4915
Ranger dette vanlige svaret

Støtter Maps Marker Pro formfiler?

For øyeblikket støttes ikke v4.0-formfiler / shp - vi spiller for å legge til støtte om for en fremtidig utgivelse (ingen utgivelsesdato ennå tilgjengelig).

Hvis du vil holde deg oppdatert med den siste utviklingen av Maps Marker, vennligst abonner på nyhetene våre via RSS, Følg @MapsMarker på twitter eller på Facebook .

0
0
9479
Ranger dette vanlige svaret

Konsollfeil “MapsMarkerPro er ikke definert”

Hvis kartene dine ikke vises og nettleserkonsollen viser feilen "MapsMarkerPro er ikke definert", kan du fortsette som følger:

  1. Hvis du bruker noen hurtigbufring-plugins, må du først prøve å tømme eventuelle involverte hurtigbuffer.
  2. Kontroller først om dette problemet kan være forårsaket av en plugin-konflikt. For å bekrefte dette, må du deaktivere alle andre plugins, men Maps Marker Pro midlertidig og prøve igjen.
  3. Hvis dette ikke ga noen resultater, må du bekrefte om malfilene dine inneholder kroker til wp_head() i header.php og wp_footer() i footer.php (som er nødvendig for å laste skript og stiler ordentlig fra Maps Marker Pro).
0
0
8050
Ranger dette vanlige svaret

Kartfliser (i faner) er ikke lastet helt inn

Hvis kartet ditt ser ut som eksemplet over, eller hvis det er innebygd i en fane, kan du aktivere alternativet "Tabs" på backend, som skal løse dette problemet:

0
0
8036
Ranger dette vanlige svaret

“Feil: kartbilder kunne ikke lastes” vises

Hvis du ser denne feilmeldingen i stedet for et kart, kan det ha flere årsaker:

den mest sannsynlige er at den (eksterne) flisetjeneren som brukes for øyeblikket ikke er tilgjengelig eller har midlertidige problemer (f.eks. et vedlikeholdsvindu). Vi har dessverre ikke direkte innflytelse på tilgjengeligheten av eksterne flisetjenere. Kart Marker Pro lar deg koble til for å vise kartfliser. Fra vår erfaring er OpenStreetMap veldig pålitelig, og disse feilene oppstår svært sjelden.

Uansett, som det også fremgår av feilmeldingen, kan det være at det er problemer med Internett-tilkoblingen på brukersiden, noe som fører til at kartfliser ikke kan lastes, selv om den eksterne kartsteinserveren er tilgjengelig.

De tredje årsakene til denne feilen - feil kartkonfigurasjon - er vanligvis bare tilfelle hvis du bruker tilpassede fliser-serverkonfigurasjoner (f.eks. Hvis du la til et tilpasset basekart som bare viser kartfliser for et bestemt område og du panorerte kartet utenfor det området).

Hvis du ofte opplever dette problemet med en valgt leverandør av flisetjenester, kan du prøve å bytte til en annen leverandør av flisetjenester for kartet ditt.

1
0
13653
Ranger dette vanlige svaret

Hva er minimumskravene for Maps Marker Pro?

For å kunne installere Maps Marker Pro, må følgende minstekrav være oppfylt:

  • PHP 5.4 eller nyere (en gjeldende 7.x-versjon anbefales, PHP-kompatibilitet er testet med 7.0, 7.1, 7.2 og 7.3)
  • WordPress 4.5 eller høyere eller Classic Press.
  • For å bekrefte lisensnøkkelen, må serveren din kunne koble seg til www.mapsmarker.com via port 443
0
0
4937
Ranger dette vanlige svaret

Er Maps Marker Pro kompatibel med ClassicPress?

ClassicPress er en modifisert og forbedret versjon av WordPress (uten Gutenberg) tilgjengelig på https://www.classicpress.net/.

Maps Marker Pro er også kompatibel med ClassicPress.

1
0
4859
Ranger dette vanlige svaret

Kan jeg bruke en eksportfil fra v3.1.1 eller lavere og importere den i v4 eller høyere?

Nei, da v4.0 er en komplett ny plugin med et optimalisert databaseskjema, (CSV / XLS (X) / ODS) importfiler opprettet med Maps Marker Pro v3.1.1 eller lavere, er ikke kompatible med importen i Maps Marker Pro v4 eller høyere.

0
0
34470
Ranger dette vanlige svaret

Hvordan konverterer jeg andre formater som KML til GeoJSON?

Det gratis online verktøyet kl https://geoconverter.hsr.ch/ lar deg konvertere formater som KML og andre til GeoJSON:

Du kan deretter legge til GeoJSON på et kart i fanen "Tegn" ved å klikke på knappen "Legg til fra GeoJSON":

3
0
34383
Ranger dette vanlige svaret

Slik fikser du inkompatibiliteten med pluggen “Geo Redirect”

Plugin “Geo-viderekobling”Lar deg omdirigere besøkende eller bytte språk i henhold til deres land. Dessverre har det ikke vært en oppdatering siden 2013, og bruk av denne pluginen sammen med Maps Marker Pro fører til at lagkart går i stykker (da også brosjyren-geojson.php-samtalen som er nødvendig for å laste inn markørene blir omdirigert.

For å fikse dette, vennligst åpne filen /wp-content/plugin/geographical-redirect/geo-redirect.php

Finn koden

public function checkIfRedirectNeeded ()
{
if (! is_array ($ dette-> geo_redirect_data))
tilbake;

og erstatt den med

public function checkIfRedirectNeeded ()
{
// info: ikke videresendes Maps Marker Pro-forespørsler
$ request_uri = $ dette-> request_uri;
if (stripos ($ request_uri, 'geojson')! == FALSE) {
tilbake;
}
if (! is_array ($ dette-> geo_redirect_data))
tilbake;

og lagre filen. Som et resultat, bør lagkartene fungere igjen.

0
0
9270
Ranger dette vanlige svaret

Geolokasjonsfeil: Det er bare mulig å opprette sekretær / https

Med Chrome 50+ ble Firefox 55+ og Safari 10+ vesentlige endringer i geolokaliseringsstøtten introdusert av de relaterte nettlesereleverandørene: alle applikasjoner som ber om brukerens nåværende posisjon (ikke bare for Maps Marker Pros geolocationfunksjon) er bare tillatt lenger for å hente den nåværende posisjonen til brukeren hvis nettstedet er konfigurert for å bli levert sikkert via https - brukere vil se følgende eller en lignende advarsel i stedet:

geolocation-feil-info

Se flere detaljer om denne avgjørelsen fra Google på https://developers.google.com/web/updates/2016/04/geolocation-on-secure-contexts-only. Geolocation vil fortsatt fungere på nettsteder som ikke er https hvis brukerne får tilgang til nettstedet via alternative nettlesere som Firefox, Safari eller Internet Explorer - uansett kan det være sannsynlig at disse nettleserne også vil legge til en lignende sikkerhetsbegrensning i fremtiden.

Oppdater november 2016: siden iOS 10 krever Safari 10+ nå https for å støtte geolocation. Implementeringen er enda strengere enn med Google Chrome - geolokalisering vil ikke fungere for eksempel hvis det er advarsler med blandet innhold på nettstedet ditt.

Oppdatering 2017: Firefox 55+ krever også https for å få tilgang til geolokalisering (se detaljer)

Så hvis du trenger Maps Marker Pro geolocation featue på nettstedet ditt (som med v2.7 blir enda mer brukbart da du kan sortere listen over markører basert på brukerens nåværende posisjon), anbefales det på det sterkeste å migrere nettstedet til https. Noen hosters tilbyr allerede gratis https-sertifikater fra letsencrypt.org for eksempel. For konfigurasjoner som trengs på WordPress-nettstedet ditt for å konfigurere det til å støtte https, kan du ta en titt på veiledninger som https://css-tricks.com/moving-to-https-on-wordpress/.

Ettersom https har flere fordeler for nettstedet ditt enn bare geolokalisering som jobber igjen med Google Chrome 50+ og Safari 10+ (som å sikre dataintegriteten, avsendergodkjenning og brukernes personvern samt høyere Google-rangering etter hvert som https brukes som rangeringssignal), bruker vi anbefaler du å bytte nettstedet ditt til https bare hvis du ikke har gjort det ennå.

Hvis du byttet nettstedet til https og fremdeles får en geolokasjonsfeil (som "Geolocation error: user avslått geolocation"), kan du sjekke enhetens plasseringsinnstillinger hvis det er tillatt for apper / nettsteder å hente geolocation.

2
0
7302
Ranger dette vanlige svaret

Fungerer Maps Marker Pro på WordPress.com-verttsider?

Nei. WordPress.com-vertplattformen tillater ikke å installere flere plugins, noe som gjør det umulig å installere Maps Marker Pro. Maps Marker Pro fungerer bare på WordPress-installasjoner som er selv vert.

0
0
4669
Ranger dette vanlige svaret

Jeg vil selge pluginen din. Har du forhandlerrabatter?

Ja det gjør vi. Vi har et program som lar deg videreselge lisenser med 20% rabatt. Hvis du er interessert i å videreselge Maps Marker Pro, kan du gå til mapsmarker.com/reseller.

2
0
8527
Ranger dette vanlige svaret

Kan jeg installere Maps Marker Pro på en WordPress MultiSite-installasjon?

Ja, det er mulig å installere Maps Marker Pro på en WordPress MultiSite-installasjon. Bare husk at lisensmodellen er domenebasert, så hvis du bruker underdomener til din flersidige installasjon, må du aktivere en lisens per domene. Hvis underettene dine er tilgjengelige i underkataloger på hoveddomenet ditt, er det bare hovednettstedet som må aktiveres.

Du finner detaljert informasjon og et verktøy som kan formidle lisensen til underordningene dine på lisensinnstillingssiden.

0
0
7823
Ranger dette vanlige svaret
en English
X