Często Zadawane Pytania

Błąd „Nie udało się wysłać żądania” podczas próby migracji do v4

Ten błąd wskazuje, że istnieją pewne problemy z konfiguracją AJAX odpowiednio punktu końcowego wp-admin / admin-ajax.php.

Aby to sprawdzić, otwórz konsolę przeglądarki (np. Z klawiszem F12 w przeglądarce Firefox lub chrome), przejdź do karty „Konsola” i ponownie załaduj stronę, a następnie ponownie kliknij „Sprawdź migrację”, aby sprawdzić, czy są jakieś dodatkowe komunikaty o błędach:

Jeśli nie widzisz tam komunikatu o błędzie, przejdź do karty „Sieć” i ponownie załaduj stronę, a następnie ponownie kliknij „Sprawdź migrację”, aby sprawdzić, czy są jakieś dodatkowe komunikaty o błędach:

Na powyższym ekranie widać, że żądanie nie powiodło się ze statusem (= kod błędu HTTP) 404 - w tym przykładzie plik /wp-admin/admin-ajax.php nie był dostępny.

Bardziej prawdopodobne jest jednak, że zobaczysz tutaj Status 500 (= Wewnętrzny błąd serwera). Błąd wewnętrzny serwera 500 jest ogólnym błędem catch all, gdy serwer zgłasza wyjątek. Jest to komunikat o błędzie, gdy bardziej odpowiedni komunikat o błędzie nie jest odpowiedni i w większości przypadków jest bezpośrednio związany z błędną konfiguracją lub problemem serwera.

Co teraz robisz?

Najpierw spróbuj tymczasowo wyłączyć wszystkie inne wtyczki, ale Maps Marker Pro, aby sprawdzić, czy ten problem nie jest spowodowany konfliktem wtyczek.

Jeśli to nie pomoże, spójrz na dziennik błędów serwera, taki jak dziennik błędów PHP lub Apache, kiedy to żądanie zostanie wysłane, i który może dać ci wskazówkę, dlaczego ten błąd występuje na twoim serwerze.

Jeśli to nadal nie pomoże, sprawdź, czy jeden z poniższych samouczków pomoże ci znaleźć przyczyny tego błędu serwera:

Jeśli to nadal nie pomoże, radzimy skontaktować się ze wsparciem hostingowym, aby mogli oni przeanalizować, dlaczego próba uruchomienia /wp-admin/admin-ajax.php kończy się niepowodzeniem.

0
0
5091
Oceń tę odpowiedź FAQ

Czy mapy mogą być wyświetlane ze 100% wysokością?

Maps Marker Pro pozwala ustawić szerokość mapy w wartościach w pikselach lub%:

Wartość wysokości może być również podana jako wartość w pikselach, ze względu na ograniczenia w HTML.

Jeśli chcesz wyświetlić mapę w trybie pełnoekranowym, użyj zamiast tego dedykowanego widoku pełnoekranowego, do którego można uzyskać bezpośredni link za pomocą panelu mapy

lub użyj przycisku pełnoekranowego HTML5 na mapie poniżej ikon powiększenia:

0
1
517
Oceń tę odpowiedź FAQ

Czy trasy z monitorów fitness mogą być wyświetlane na mapach?

Jeśli Twoje urządzenia monitorujące kondycję (takie jak Garmin Fit) pozwalają na eksport nagranych śladów w formacie GPX, pliki te można zwykle wyświetlać na mapach za pomocą Maps Marker Pro.

Aby wyświetlić te ślady, utwórz nową mapę, przejdź do zakładki „GPX” i zacznij od kliknięcia przycisku „Otwórz bibliotekę multimediów”:

W następnym kroku przejdź do zakładki „Prześlij pliki”, wybierz i prześlij plik GPX, a następnie kliknij przycisk „Wybierz”:

W rezultacie ścieżka GPX jest wyświetlana na mapie i możesz opcjonalnie dodatkowo dostosować jej ustawienia (zalecane jest przejście do zaawansowanego edytora dla wszystkich opcji):

0
0
4915
Oceń tę odpowiedź FAQ

Czy Maps Marker Pro obsługuje pliki kształtów?

Obecnie pliki kształtów w wersji 4.0 / shp nie są obsługiwane - gramy, aby dodać obsługę dla przyszłej wersji (data premiery nie jest jeszcze dostępna).

Jeśli chcesz być na bieżąco z najnowszą wersją Maps Marker, proszę subskrybuj nasze wiadomości przez RSS, podążać @MapsMarker na Twitterze lub na Facebook.

0
0
9479
Oceń tę odpowiedź FAQ

Błąd konsoli „MapsMarkerPro nie jest zdefiniowany”

Jeśli mapy nie są wyświetlane, a konsola przeglądarki wyświetla błąd „MapsMarkerPro nie jest zdefiniowany”, wykonaj następujące czynności:

  1. Jeśli korzystasz z jakichkolwiek wtyczek pamięci podręcznej, spróbuj najpierw wyczyścić wszystkie zaangażowane pamięci podręczne.
  2. Najpierw sprawdź, czy przyczyną problemu może być konflikt wtyczek. Aby to sprawdzić, tymczasowo wyłącz wszystkie inne wtyczki, ale Maps Marker Pro i spróbuj ponownie.
  3. Jeśli to nie zwróci żadnych wyników, sprawdź, czy pliki szablonów zawierają zaczepy dla wp_head() w header.php i wp_footer() w footer.php (które są potrzebne do prawidłowego ładowania skryptów i stylów z Maps Marker Pro).
0
0
8050
Oceń tę odpowiedź FAQ

Kafelki mapy (w zakładkach) nie są ładowane całkowicie

Jeśli twoja mapa wygląda jak w powyższym przykładzie lub jeśli jest osadzona na karcie, włącz opcję „Tabbed” na zapleczu, co powinno rozwiązać ten problem:

0
0
8036
Oceń tę odpowiedź FAQ

Wyświetlany jest komunikat „Błąd: nie można załadować obrazów mapy”

Jeśli zamiast mapy pojawia się ten komunikat o błędzie, może to mieć kilka przyczyn:

najbardziej prawdopodobne jest to, że używany (zewnętrzny) serwer kafelków jest obecnie niedostępny lub ma tymczasowe problemy (np. okno konserwacji). Niestety nie mamy bezpośredniego wpływu na dostępność zewnętrznych serwerów kafelków Maps Marker Pro umożliwia połączenie, aby wyświetlać kafelki mapy. Z naszego doświadczenia wynika, że ​​OpenStreetMap jest bardzo niezawodny, a błędy te występują bardzo rzadko.

W każdym razie, jak stwierdzono również w komunikacie o błędzie, może się zdarzyć, że po stronie użytkownika występują problemy z połączeniem internetowym, które powodują, że kafelki mapy nie mogą zostać załadowane, chociaż zewnętrzny serwer kafelków mapy jest dostępny.

Trzeci powód tego błędu - wadliwa konfiguracja mapy - występuje zwykle tylko wtedy, gdy używasz niestandardowych konfiguracji serwera kafelków (np. Jeśli dodałeś niestandardową mapę bazową, która pokazuje kafelki mapy tylko dla określonego obszaru i przesuwałeś mapę poza tym obszarem).

Jeśli ten problem często występuje u jednego wybranego dostawcy usług kafelkowych, możesz spróbować przełączyć się na innego dostawcę usług kafelkowych dla swojej mapy.

1
0
13653
Oceń tę odpowiedź FAQ

Jakie są minimalne wymagania dotyczące Maps Marker Pro?

Aby móc zainstalować Maps Marker Pro, muszą być spełnione następujące minimalne wymagania:

  • PHP 5.4 lub nowszy (zalecana jest aktualna wersja 7.x, kompatybilność z PHP została przetestowana z 7.0, 7.1, 7.2 i 7.3)
  • WordPress 4.5 lub nowszy lub ClassicPress.
  • Aby zweryfikować klucz licencyjny, twój serwer musi mieć możliwość połączenia się z www.mapsmarker.com przez port 443
0
0
4937
Oceń tę odpowiedź FAQ

Czy Maps Marker Pro jest kompatybilny z ClassicPress?

ClassicPress to zmodyfikowana i ulepszona wersja WordPressa (bez Gutenberga) dostępna pod adresem https://www.classicpress.net/.

Maps Marker Pro jest również kompatybilny z ClassicPress.

1
0
4859
Oceń tę odpowiedź FAQ

Czy mogę użyć pliku eksportu z wersji 3.1.1 lub nowszej i zaimportować go do wersji 4 lub wyższej?

Nie, ponieważ v4.0 jest całkowicie nową wtyczką ze zoptymalizowanym schematem bazy danych, pliki importu (CSV / XLS (X) / ODS) utworzone za pomocą Maps Marker Pro v3.1.1 lub starszej nie są kompatybilne z importem w Maps Marker Pro v4 lub wyżej.

0
0
34470
Oceń tę odpowiedź FAQ

Jak przekonwertować inne formaty, takie jak KML, na GeoJSON?

Darmowe narzędzie online pod adresem https://geoconverter.hsr.ch/ pozwala na konwersję formatów takich jak KML i inne do GeoJSON:

Następnie możesz dodać GeoJSON do mapy w zakładce „Rysuj”, klikając przycisk „Dodaj z GeoJSON”:

3
0
34383
Oceń tę odpowiedź FAQ

Jak naprawić niezgodność za pomocą wtyczki „Geo Redirect”

Wtyczka „Przekierowanie geograficzne”Umożliwia przekierowywanie użytkowników lub zmianę języka w zależności od kraju. Niestety, nie było aktualizacji od 2013 roku i użycie tej wtyczki razem z Maps Marker Pro powoduje uszkodzenie map warstw (ponieważ przekierowywane jest również wywołanie leaflet-geojson.php, które jest potrzebne do załadowania markerów).

Aby to naprawić, otwórz plik /wp-content/plugin/geographical-redirect/geo-redirect.php

Znajdź kod

funkcja publiczna checkIfRedirectNeeded ()
{
if (! is_array ($ this-> geo_redirect_data))
powrotu;

i zastąpić ją

funkcja publiczna checkIfRedirectNeeded ()
{
// info: nie przekierowuj żądań Maps Marker Pro
$ request_uri = $ this-> request_uri;
if (stripos ($ request_uri, 'geojson')! == FALSE) {
powrotu;
}
if (! is_array ($ this-> geo_redirect_data))
powrotu;

i zapisz plik. W rezultacie mapy warstw powinny znów działać.

0
0
9270
Oceń tę odpowiedź FAQ

Błąd geolokalizacji: dozwolone są tylko bezpieczne źródła / wymagany jest protokół https

W Chrome 50+, Firefox 55+ i Safari 10+ znaczące zmiany w obsłudze geolokalizacji zostały wprowadzone przez powiązanych dostawców przeglądarek: wszystkie aplikacje żądające aktualnej pozycji użytkownika (nie tylko dla funkcji geolokalizacji Maps Marker Pro) są dozwolone tylko aby odzyskać bieżącą pozycję użytkownika, jeśli witryna jest skonfigurowana do bezpiecznego dostarczania za pośrednictwem https - użytkownicy zobaczą następujące lub podobne ostrzeżenie:

informacje o błędzie geolokalizacji

Zobacz więcej szczegółów na temat tej decyzji Google pod adresem https://developers.google.com/web/updates/2016/04/geolocation-on-secure-contexts-only. Geolokalizacja będzie nadal działać na stronach innych niż https, jeśli użytkownicy uzyskają dostęp do witryny za pośrednictwem alternatywnych przeglądarek, takich jak Firefox, safari lub Internet Explorer - w każdym razie może się zdarzyć, że przeglądarki te będą dodawać podobne ograniczenia bezpieczeństwa w przyszłości.

Aktualizacja z listopada 2016 r .: od iOS 10 również Safari 10+ wymaga teraz protokołu https do obsługi geolokalizacji. Wdrożenie jest jeszcze bardziej rygorystyczne niż w przypadku Google Chrome - geolokalizacja nie będzie działać na przykład, jeśli w Twojej witrynie są ostrzeżenia o mieszanej zawartości.

Aktualizacja 2017: Firefox 55+ wymaga również https w celu uzyskania dostępu do geolokalizacji (patrz szczegóły)

Jeśli więc potrzebujesz geolokalizacji Maps Marker Pro na swojej stronie (która w wersji v2.7 staje się jeszcze bardziej użyteczna, ponieważ możesz sortować listę markerów na podstawie bieżącej pozycji użytkownika), zdecydowanie zalecamy migrację witryny do https. Niektórzy hostingi udostępniają już bezpłatne certyfikaty https od letsencrypt.org na przykład. Aby uzyskać konfiguracje potrzebne w witrynie WordPress w celu skonfigurowania jej do obsługi protokołu https, zapoznaj się z samouczkami, takimi jak https://css-tricks.com/moving-to-https-on-wordpress/.

Ponieważ https ma więcej zalet dla Twojej witryny niż tylko geolokalizacja współpracująca z Google Chrome 50+ i Safari 10+ (np. Zapewnienie integralności danych, uwierzytelnienia nadawcy i prywatności użytkowników, a także wyższego rankingu Google, ponieważ https jest używany jako sygnał rankingowy), zdecydowanie zalecamy zmianę witryny na https tylko wtedy, gdy jeszcze tego nie zrobiłeś.

Jeśli zmieniłeś witrynę na https i nadal pojawia się błąd geolokalizacji (np. „Błąd geolokalizacji: użytkownik odmówił geolokalizacji”), sprawdź ustawienia lokalizacji urządzenia, jeśli dozwolone jest pobieranie aplikacji / stron internetowych z geolokalizacji.

2
0
7302
Oceń tę odpowiedź FAQ

Czy Maps Marker Pro będzie działał na stronach obsługiwanych przez WordPress.com?

Nie. Platforma obsługiwana przez WordPress.com nie pozwala na instalowanie dodatkowych wtyczek, co uniemożliwia instalację Maps Marker Pro. Maps Marker Pro działa tylko w przypadku hostowanych instalacji WordPress.

0
0
4669
Oceń tę odpowiedź FAQ

Chcę sprzedać twoją wtyczkę. Czy masz zniżki dla sprzedawców?

Tak. Mamy program, który pozwala odsprzedawać licencje z 20% zniżką. Jeśli jesteś zainteresowany odsprzedażą Maps Marker Pro, prosimy odwiedzić mapmarker.com/reseller.

2
0
8527
Oceń tę odpowiedź FAQ

Czy mogę zainstalować Maps Marker Pro na instalacji WordPress MultiSite?

Tak, instalacja Maps Marker Pro na instalacji WordPress MultiSite jest możliwa. Pamiętaj, że model licencji jest oparty na domenie, więc jeśli używasz subdomen do instalacji na wielu serwerach, musisz aktywować licencję na domenę. Jeśli Twoje podwitryny są dostępne w podkatalogach w Twojej domenie głównej, tylko strona główna musi zostać aktywowana.

Na stronie ustawień licencji znajdziesz szczegółowe informacje i narzędzie do propagowania licencji w podwitrynach.

0
0
7823
Oceń tę odpowiedź FAQ
en English
X