Nie można aktywować wtyczki - Błąd krytyczny: Nieprzechwycony błąd: Nie znaleziono klasy „MMP \ SPBAS”

Błąd krytyczny: Nieprzechwycony błąd: nie znaleziono klasy „MMP \ SPBAS” w /wp-content/plugins/maps-marker-pro/classes/maps-marker-pro.php:111

Jeśli powyższy błąd pojawia się po aktywacji wtyczki, prawdopodobne jest, że twój serwer ma warstwę bezpieczeństwa (jak mod_security), co spowodowało usunięcie określonych plików zaciemnionych Map Marker Pro. Pliki te są domyślnie zaciemniane w celu ochrony mechanizmu sprawdzania poprawności licencji, a jeśli warstwa zabezpieczeń jest skonfigurowana ściśle, pliki te można fałszywie zidentyfikować jako złośliwe oprogramowanie.

Aby to naprawić, zaktualizuj do wersji 4.10 lub nowszej. Jeśli nadal masz problemy, proszę otworzyć zgłoszenie do pomocy technicznej.

Aby to naprawić, skontaktuj się z usługodawcą hostingowym i poproś go o dodanie następujących 3 plików do białej listy warstwy zabezpieczeń:

  • /wp-content/plugins/maps-marker-pro/classes/menu-license.php
  • /wp-content/plugins/maps-marker-pro/classes/shortcodes.php
  • /wp-content/plugins/maps-marker-pro/classes/spbas.php

Jeśli tak się stanie, ponownie pobierz plik aktualny pakiet wtyczek (odpowiednio wersja, z której korzystasz nasze archiwa wydań jeśli nie jest bieżący) i ręcznie ponownie załaduj 3 powyższe pliki za pośrednictwem FTP.

0
0
4608
Oceń tę odpowiedź FAQ

Zostaw komentarz

XHTML: Możesz użyć tych tagów: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

en English
X