Часто задаваемые вопросы

Ошибка «Не удалось отправить запрос» при попытке перехода на v4

Эта ошибка указывает на то, что существуют некоторые проблемы с вашей конфигурацией AJAX, соответственно, с конечной точкой wp-admin / admin-ajax.php.

Чтобы убедиться в этом, откройте консоль браузера (например, с F12 в Firefox или chrome), переключитесь на вкладку «Консоль», перезагрузите страницу и снова нажмите «Проверить миграцию», чтобы проверить, есть ли дополнительные сообщения об ошибках:

Если вы не видите там сообщения об ошибке, перейдите на вкладку «Сеть», перезагрузите страницу и снова нажмите «Проверить миграцию», чтобы проверить наличие дополнительных сообщений об ошибках:

На приведенном выше экране вы видите, что запрос не выполнен с состоянием (= код ошибки HTTP) 404 - в этом примере файл /wp-admin/admin-ajax.php был недоступен.

Однако более вероятно, что вы увидите здесь состояние 500 (= внутренняя ошибка сервера). Внутренняя ошибка сервера 500 - это общая ошибка перехвата всех ошибок, когда сервер генерирует исключение. Это сообщение об ошибке, когда более конкретное сообщение об ошибке не подходит и в большинстве случаев напрямую связано с неправильной настройкой или проблемой сервера.

Так что же теперь делать?

Сначала попробуйте временно отключить все остальные плагины, кроме Maps Marker Pro, чтобы убедиться, что эта проблема не вызвана конфликтом плагинов.

Если это не помогает, пожалуйста, посмотрите на журнал ошибок сервера, такой как PHP или журнал ошибок Apache, когда этот запрос сделан, и который может дать вам подсказку, почему эта ошибка происходит на вашем сервере.

Если это по-прежнему не помогает, проверьте, может ли одно из следующих руководств помочь вам найти причины этой ошибки сервера:

Если это по-прежнему не помогает, мы советуем обратиться в службу поддержки вашего хостинга, чтобы они могли проанализировать причину сбоя запроса к /wp-admin/admin-ajax.php при попытке запустить инструмент миграции.

0
0
5171
Оцените этот FAQ ответ

Вы не можете оценивать это сообщение.

Могут ли карты отображаться с высотой 100%?

Maps Marker Pro позволяет вам установить ширину карты в пикселях или в% значениях:

Однако значение высоты также может быть задано как значение в пикселях из-за ограничений в HTML.

Если вы хотите отобразить карту в полноэкранном режиме, используйте вместо этого выделенный полноэкранный режим, к которому можно получить постоянную ссылку через панель карт.

или используйте полноэкранную кнопку HTML5 на карте под значками увеличения:

0
1
552
Оцените этот FAQ ответ

Вы не можете оценивать это сообщение.

Можно ли отображать треки с фитнес-трекеров на картах?

Если ваши фитнес-трекеры (например, Garmin Fit) позволяют экспортировать записанные треки в формате GPX, эти файлы обычно также могут отображаться на картах с помощью Maps Marker Pro.

Чтобы отобразить эти треки, создайте новую карту, перейдите на вкладку «GPX» и начните, нажав кнопку «Открыть медиатеку»:

В качестве следующего шага перейдите на вкладку «Загрузить файлы», выберите и загрузите свой файл gpx, завершите, нажав кнопку «Выбрать»:

В результате трек GPX отображается на карте, и вы можете дополнительно настроить его параметры (рекомендуется переключиться на расширенный редактор для всех параметров):

0
0
4988
Оцените этот FAQ ответ

Вы не можете оценивать это сообщение.

Поддерживает ли Maps Marker Pro файлы форм?

В настоящее время с v4.0 файлы форм / shp не поддерживаются - мы играем, чтобы добавить поддержку для будущего выпуска (дата выпуска пока не доступна).

Если вы хотите быть в курсе последних разработок Maps Marker, пожалуйста, подпишитесь на наши новости через RSS, следовать @MapsMarker в твиттере или на Facebook.

0
0
9565
Оцените этот FAQ ответ

Вы не можете оценивать это сообщение.

Ошибка консоли «MapsMarkerPro не определен»

Если ваши карты не отображаются, а в консоли браузера отображается ошибка «MapsMarkerPro не определен», выполните следующие действия:

  1. Если вы используете какие-либо плагины для кеширования, попробуйте сначала очистить все связанные кеши.
  2. Сначала проверьте, может ли эта проблема быть вызвана конфликтом плагинов. Чтобы убедиться в этом, временно отключите все другие плагины, кроме Maps Marker Pro, и повторите попытку.
  3. Если это не вернуло никаких результатов, проверьте, есть ли в ваших файлах шаблонов хуки для wp_head() в header.php и wp_footer() в footer.php (которые необходимы для правильной загрузки скриптов и стилей из Maps Marker Pro).
0
0
8123
Оцените этот FAQ ответ

Вы не можете оценивать это сообщение.

Плитки карты (во вкладках) загружены не полностью

Если ваша карта выглядит, как в примере выше, или если она встроена во вкладку, включите опцию «Tabbed» в бэкэнде, которая должна решить эту проблему:

0
0
8087
Оцените этот FAQ ответ

Вы не можете оценивать это сообщение.

«Ошибка: не удалось загрузить изображения карты»

Если вы видите это сообщение об ошибке вместо карты, это может иметь несколько причин:

наиболее вероятным является то, что используемый (внешний) сервер плиток в настоящее время недоступен или имеет временные проблемы (например, окно обслуживания). К сожалению, мы не имеем прямого влияния на доступность внешних серверов плиток. Maps Marker Pro позволяет вам подключаться для отображения плиток карты. Исходя из нашего опыта, OpenStreetMap очень надежен, и такие ошибки встречаются очень редко.

Как бы то ни было, как указано в сообщении об ошибке, возможно, что на стороне пользователя есть проблемы с подключением к Интернету, которые приводят к невозможности загрузки листов карты, хотя доступен внешний сервер листов карт.

Третья причина этой ошибки - неправильная конфигурация карты - обычно имеет место только в том случае, если вы используете пользовательские конфигурации сервера плиток (например, если вы добавили настраиваемую базовую карту, которая отображает плитки карты только для определенной области, и вы панорамировали свою карту за пределами этой области).

Если вы часто сталкиваетесь с этой проблемой с одним выбранным поставщиком услуг листов, вы можете попробовать переключиться на другого поставщика услуг листов для вашей карты.

1
0
13704
Оцените этот FAQ ответ

Вы не можете оценивать это сообщение.

Каковы минимальные требования для Maps Marker Pro?

Чтобы установить Maps Marker Pro, необходимо выполнить следующие минимальные требования:

  • PHP 5.4 или выше (рекомендуется текущая версия 7.x, совместимость PHP была протестирована с 7.0, 7.1, 7.2 и 7.3)
  • WordPress 4.5 или выше или ClassicPress.
  • Для проверки лицензионного ключа ваш сервер должен иметь возможность подключиться к www.mapsmarker.com через порт 443
0
0
4981
Оцените этот FAQ ответ

Вы не можете оценивать это сообщение.

Совместим ли Maps Marker Pro с ClassicPress?

ClassicPress - это модифицированная и улучшенная версия WordPress (без Гутенберга), доступная по адресу https://www.classicpress.net/.

Карты Marker Pro также совместимы с ClassicPress.

1
0
4904
Оцените этот FAQ ответ

Вы не можете оценивать это сообщение.

Могу ли я использовать файл экспорта из v3.1.1 или ниже и импортировать его в v4 или выше?

Нет, поскольку v4.0 является полностью новым плагином с оптимизированной схемой базы данных, файлы импорта (CSV / XLS (X) / ODS), созданные с помощью Maps Marker Pro v3.1.1 или ниже, не совместимы с импортом в Maps Marker Pro v4 или выше.

0
0
34684
Оцените этот FAQ ответ

Вы не можете оценивать это сообщение.

Как мне конвертировать другие форматы, такие как KML, в GeoJSON?

Бесплатный онлайн-инструмент на https://geoconverter.hsr.ch/ позволяет конвертировать форматы, такие как KML и другие, в GeoJSON:

Затем вы можете добавить GeoJSON к карте на вкладке «Рисование», нажав кнопку «Добавить из GeoJSON»:

3
0
34601
Оцените этот FAQ ответ

Вы не можете оценивать это сообщение.

Как исправить несовместимость с плагином «Geo Redirect»

Плагин «Гео редирект”Позволяет вам перенаправлять посетителей или переключать язык в соответствии с их страной. К сожалению, с 2013 года не было обновлений, и использование этого плагина вместе с Maps Marker Pro приводит к разрыву карт слоев (так как перенаправляется также вызов leaflet-geojson.php, необходимый для загрузки маркеров.

Чтобы исправить это, откройте файл /wp-content/plugin/geographic-redirect/geo-redirect.php

Найти код

публичная функция checkIfRedirectNeeded ()
{
if (! is_array ($ this-> geo_redirect_data))
вернуться;

и заменить его

публичная функция checkIfRedirectNeeded ()
{
// информация: не перенаправлять запросы Maps Marker Pro
$ request_uri = $ this-> request_uri;
if (stripos ($ request_uri, 'geojson')! == FALSE) {
вернуться;
}
if (! is_array ($ this-> geo_redirect_data))
вернуться;

и сохраните файл. В результате карты слоев должны снова работать.

0
0
9349
Оцените этот FAQ ответ

Вы не можете оценивать это сообщение.

Ошибка геолокации: разрешены только источники безопасности / требуется https

В Chrome 50+, Firefox 55+ и Safari 10+ значительные изменения в поддержке геолокации были внесены соответствующими поставщиками браузеров: все приложения, запрашивающие текущую позицию пользователя (не только для функции геолокации в Maps Marker Pro), разрешены только больше, чтобы узнать текущую позицию пользователя, если сайт настроен для безопасной доставки через https - вместо этого пользователи увидят следующее или подобное предупреждение:

геолокации ошибок-инфо

Подробнее об этом решении Google читайте на https://developers.google.com/web/updates/2016/04/geolocation-on-secure-contexts-only, Geolocation будет по-прежнему работать на сайтах, отличных от https, если пользователи получат доступ к сайту через альтернативные браузеры, такие как Firefox, сафари или Internet Explorer - в любом случае вполне вероятно, что эти браузеры также добавят подобное ограничение безопасности в будущем.

Обновление ноябрь 2016: с iOS 10 также Safari 10+ теперь требует https для поддержки геолокации. Реализация еще более строгая, чем в Google Chrome - геолокация не будет работать, например, если на вашем сайте есть предупреждения со смешанным содержанием.

Обновление 2017: Firefox 55+ также требует https для доступа к геолокации (смотрите подробности)

Поэтому, если вам нужен геолокационный компонент Maps Marker Pro на вашем сайте (который с v2.7 даже становится более удобным, так как вы можете сортировать список маркеров в зависимости от текущей позиции пользователя), настоятельно рекомендуется перенести ваш сайт на HTTPS. Некоторые хостеры уже предоставляют бесплатные сертификаты https от letsencrypt.org например. Для конфигураций, необходимых на вашем сайте WordPress для того, чтобы настроить его на поддержку https, пожалуйста, посмотрите учебники, такие как https://css-tricks.com/moving-to-https-on-wordpress/.

Так как https имеет больше преимуществ для вашего сайта, чем просто геолокация, снова работая с Google Chrome 50+ и Safari 10+ (например, обеспечение целостности данных, аутентификация отправителя и конфиденциальность пользователя, а также более высокий рейтинг Google, поскольку https используется в качестве сигнала ранжирования), мы Настоятельно советуем переключить ваш сайт на https, только если вы этого еще не сделали.

Если вы переключили свой сайт на https и по-прежнему получаете ошибку геолокации (например, «Ошибка геолокации: пользователь отклонил геолокацию»), проверьте настройки местоположения вашего устройства, если приложениям / веб-сайтам разрешено получать геолокацию.

2
0
7393
Оцените этот FAQ ответ

Вы не можете оценивать это сообщение.

Будет ли Maps Marker Pro работать на сайтах WordPress.com?

Нет. Платформа WordPress.com не позволяет устанавливать дополнительные плагины, что делает невозможным установку Maps Marker Pro. Maps Marker Pro работает только при самостоятельной установке WordPress.

0
0
4713
Оцените этот FAQ ответ

Вы не можете оценивать это сообщение.

Я хочу продать твой плагин. У вас есть скидки для реселлеров?

Да. У нас есть программа, которая позволяет перепродавать лицензии со скидкой 20%. Если вы заинтересованы в перепродаже Maps Marker Pro, пожалуйста, посетите mapsmarker.com/reseller.

2
0
8632
Оцените этот FAQ ответ

Вы не можете оценивать это сообщение.

Могу ли я установить Maps Marker Pro на установку WordPress MultiSite?

Да, установка Maps Marker Pro на WordPress MultiSite возможна. Просто помните, что модель лицензии основана на домене, поэтому, если вы используете субдомены для многоузловой установки, вам нужно активировать лицензию для каждого домена. Если ваши дочерние сайты доступны в подкаталогах вашего основного домена, необходимо активировать только главный сайт.

Вы найдете подробную информацию и инструмент для распространения вашей лицензии на своих дочерних сайтах на странице настроек лицензии.

0
0
7896
Оцените этот FAQ ответ

Вы не можете оценивать это сообщение.

en English
X