支持/知识库

搜索
通用过滤器
只有完全匹配
在标题搜索
在内容搜索
在搜索摘录
通过自定义文章类型过滤器
用户指南
相关文章
常见问题解答
参考文献
  • 用户指南
  • 相关文章
  • 常见问题解答
  • 参考文献
  • 服务台



帐户和许可证管理

发布商

配置设置–地理编码

配置设置-图层

安装与设定

管理工具–导入和导出



入门指南

中英口译 笔译

使用API

使用地图–聚类

使用地图–过滤器

使用地图– GPX轨道

使用地图–标记清单



配置设置–地理编码

配置设置-图层



中英口译 笔译



帐户和许可证管理

发布商

我想在我的网站上使用链接和横幅宣传Maps Marker Pro。 你有会员计划吗?

是的,我们做的。

当您加入我们的会员计划时,将获得一系列放置在您网站内的标语和文本链接。 当用户点击您网站上的链接并在mapsmarker.com上购买商品时,您将获得佣金。 我们的佣金最高可达50%,而三层的佣金则为每个级别的5%。

在以下位置查看详细信息 mapsmarker.com/affiliates.

0
0
4604
评价此常见问题解答

配置设置-图层

Maps Marker Pro还能显示天气地图吗?

Maps Marker Pro允许您使用通过WMTS或WMS标准提供的各种地图。 可以通过“设置” /“图层” /“自定义”添加这些自定义图层:

可在以下位置找到社区策划的自定义图层列表 https://mapsmarker.com/custom-layers

有关专用天气图层,请查看 https://gis.stackexchange.com/questions/6345/listing-available-online-wms-services-weather-land-data-place-names 作为起点–许多配置也可以在Maps Marker Pro中使用。

0
0
10057
评价此常见问题解答

如何使用官方的奥地利地图basemap.at

底图 是奥地利的官方地图,可作为 开放的数据 并且是Maps Marker Pro v4.0 +中的预定义底图:

0
0
5184
评价此常见问题解答

安装与设定

如何卸载Maps Marker Pro

如果要卸载Maps Marker Pro,请使用管理员帐户登录WordPress网站,导航至“插件”,然后首先停用Maps Marker Pro:

下一步,请点击“删除”:

接下来,请点击“确定”以确认删除(注意:所有创建的地图和标记也会被删除,除非您恢复备份,否则无法撤消该操作!)

如果您还希望删除我们服务器上的客户帐户和许可证,请 打开支持票.

0
0
8150
评价此常见问题解答

Maps Marker Pro是否与Gutenberg / WordPress 5.x兼容?

是的,Maps Marker Pro与WordPress 5和新的Gutenberg编辑器兼容。 有关Maps Marker Pro的一般最低要求,请参阅 这个FAQ.

对于将来的发行版,我们还计划添加一个自定义地图块,使您可以轻松地搜索地图并添加地图的短代码(直到您需要将地图的短代码复制并粘贴到块中):

步骤1 –例如,从地图编辑页面复制简码

步骤2 –将短代码粘贴到Gutenberg编辑器中,这将自动创建一个短代码块

0
0
8202
评价此常见问题解答

解析错误:语法错误,maps-marker-pro.php中出现意外的T_OBJECT_OPERATOR

Plugin could not be activated because it triggered a fatal error.
Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /wp-content/plugins/maps-marker-pro/maps-marker-pro.php on line 66

如果您在尝试激活Maps Marker Pro时看到上述错误,则通常意味着您的服务器上使用的PHP版本太低。

自5.4年5.4月起,Maps Marker Pro至少需要PHP 2015才能正常运行,因为PHP XNUMX已经过时并且不再接收更新(包括安全修复!),我们强烈建议您使用 当前支持的PHP版本 (7.x)。

要解决此问题,请在可能的情况下通过托管控制面板切换PHP版本,或与托管提供商支持联系以为您切换PHP版本。

0
0
8818
评价此常见问题解答

Maps Marker Pro的最低要求是什么?

为了能够安装Maps Marker Pro,必须满足以下最低要求:

  • PHP 5.4或更高版本(建议使用当前的7.x版本,PHP兼容性已通过7.0、7.1、7.2和7.3测试)
  • WordPress 4.5或更高版本 经典出版社.
  • 为了验证许可证密钥,您的服务器需要能够通过端口443连接到www.mapsmarker.com。
0
0
4922
评价此常见问题解答

Maps Marker Pro是否与ClassicPress兼容?

ClassicPress是WordPress的修改和增强版本(无Gutenberg),可从以下网站获得 https://www.classicpress.net/.

Maps Marker Pro也与ClassicPress兼容。

1
0
4847
评价此常见问题解答

Maps Marker Pro是否可以在WordPress.com托管站点上工作?

不能。WordPress.com托管平台不允许安装其他插件,因此无法安装Maps Marker Pro。 Maps Marker Pro仅适用于自托管的WordPress安装。

0
0
4654
评价此常见问题解答

我可以在WordPress MultiSite安装上安装Maps Marker Pro吗?

是的,可以在WordPress MultiSite安装上安装Maps Marker Pro。 请记住,许可证模型是基于域的,因此,如果您在多站点安装中使用子域,则需要为每个域激活一个许可证。 但是,如果您的子站点可在主域的子目录上访问,则仅需激活主站点。

在许可证设置页面上,您会找到详细的信息和将许可证传播到子站点的工具工具。

0
0
7809
评价此常见问题解答

如何回滚到旧版本的Maps Marker Pro?

如果更新后有任何问题,请 打开支持票。 如果问题很严重并且影响到所有用户,我们将立即着手开发一个修补程序,我们将尽快(通常在12-24小时之内)提供该修补程序。

如果要在此修补程序可用之前切换回旧版本,请从以下位置下载旧版本: https://www.mapsmarker.com/updates_pro/archive/ 并覆盖服务器上目录/ wp-content / plugins / maps-marker-pro /(v4 +)或/ wp-content / plugins / leaflet-maps-marker-pro /(v3.1.1或更低版本)中的插件文件。

请不要卸载并重新安装插件以回滚到旧版本,因为卸载插件还会删除所有地图数据!

0
0
7825
评价此常见问题解答

该插件与WordPress多站点兼容吗?

您还需要至少一个许可证才能在WordPress多站点实例上安装Maps Marker Pro。 专业版甚至包括一些其他管理工具,使您可以将许可证密钥或自定义设置传播到所有子站点。

1
0
12538
评价此常见问题解答

我想在wordpress.com上使用此插件

不幸的是,目前这还不可能,因为wordpress.com的插件是由automattic选择的。 尽管如此,您可以写一封电子邮件到 plugins@wordpress.org 并询问将来是否可以包含此插件(我非常感谢😉)

0
0
4631
评价此常见问题解答


Maps Marker Pro是否支持形状文件?

当前不支持v4.0形状文件/ shp –我们努力增加对将来版本的支持(尚无可用的发布日期)。

如果您想了解最新的Maps Marker开发,请 通过RSS订阅我们的新闻, 跟随 @MapsMarker 在推特上 Facebook.

0
0
9466
评价此常见问题解答

我也想使用这种形式-源代码是否可以作为开源代码使用?

是的,实际上我什至构建了一个WordPress插件,您可以从以下位置下载 http://wordpress.org/plugins/bitcoin-order-form-for-mapsmarkercom/ 该代码也可以在Github上找到,网址为 https://github.com/robertharm/bitcoin-order-form

请注意,此插件是为MapsMarker.com定制的,没有用于自定义后端产品的选项。 我为开发人员共享了代码,以使他们不必重新发明轮子,而仅当他们想在自己的站点上使用自定义版本时才更改代码中的某些表单参数。

0
0
13987
评价此常见问题解答

我可以尝试Maps Marker Pro的现场演示吗?

是:Test Maps Marker Pro的直播时间为 https://demo.mapsmarker.com,您可以在此处登录后端并测试Maps Marker Pro的管理页面,然后再 购买许可证 or 开始30天免费试用 在你的服务器上。

1
0
8152
评价此常见问题解答

我想在下一个版本的插件中添加XY功能

请检查 Maps Marker Pro的路线图 如果您的功能已在此处列出。 如果没有,请在此处添加评论。

0
0
7314
评价此常见问题解答

定价

我想卖你的插件。 您有经销商折扣吗?

是的,我们愿意。 我们有一个程序,可让您以20%的折扣转售许可证。 如果您有兴趣转销Maps Marker Pro,请访问 mapsmarker.com/reseller.

2
0
8485
评价此常见问题解答

我可以尝试Maps Marker Pro的现场演示吗?

是:Test Maps Marker Pro的直播时间为 https://demo.mapsmarker.com,您可以在此处登录后端并测试Maps Marker Pro的管理页面,然后再 购买许可证 or 开始30天免费试用 在你的服务器上。

1
0
8152
评价此常见问题解答

如果我不想再使用Maps Marker Pro,可以退款吗?

不,对不起,你不能。 为避免买家后悔,请在购买前随意尝试:Maps Marker Pro提供了 免费30日试用版 无需任何隐藏成本,即可让您测试该插件是否符合您的需求并在托管环境中运行。 如果在此期间出现任何问题,请不要犹豫 请与我们联系.

1
0
5281
评价此常见问题解答

因此…有效的许可证密钥确实意味着我购买许可证一次后就可以永远使用Maps Marker Pro吗?

是的,我们就是这样做的。 我们不会强迫您续约,但会努力使您想续订我们的许可证,以获取我们的频繁更新,最新版本和超赞的支持。

1
0
9276
评价此常见问题解答

30天免费试用期过后,我是否有义务?

不,绝对不是。 您可以测试Maps Marker Pro的全部功能 30天免费 没有任何风险。 30天后,除非您输入有效的许可证密钥,否则插件将仅停止工作。 (如果您已经从免费的lite版本升级,则可以切换回它。)

请注意,我们绝不会与任何第三方共享您的数据-请参阅我们的 私隐政策 有关我们的道德守则的详细信息。

1
0
9498
评价此常见问题解答

我可以切换回免费版本而不丢失数据吗?

是的,如果您使用专业升级程序启动了30天的免费试用期,并希望在30天的免费试用期到期后回滚到免费版本,则可能会发生数据丢失。

由于Maps Marker Pro v4.0具有完整的重写功能,并且不再与Leaflet Maps Marker共享任何代码库,因此不再可能从免费版本回滚到pro版本,因为以前使用Maps Marker Pro v3.1.1是不可能的。 由于两个插件都使用不同的数据库表,因此您可以随时在这两个版本之间进行切换–自Maps Marker Pro v4.0起,专业版的更改将不再反映在免费版中。

1
0
5304
评价此常见问题解答

从免费版本升级时,我可以重用地图数据吗?

是的,随着您的地图数据迁移到Maps Marker Pro数据库架构,使用Maps Marker Pro,您将能够使用通过插件的免费版本创建的标记和图层地图。

2
0
8024
评价此常见问题解答

我可以在商业环境中使用此插件吗?

是的,您可以在商业环境中使用Leaflet Maps Marker和Maps Marker Pro。 无论如何,都要求不要从通过您网站上的插件显示的每张地图中删除已使用地图的许可条件的归属链接。

Maps Marker Pro未获得GPL 2.0的许可,但当然也可以在商业环境中使用。 专业版还允许您删除指向MapsMarker.com的反向链接-请查看 服务条款 以获得更多细节。

根据需要额外注册的地理编码或底图提供程序,可能会适用其他要求,请在注册前检查外部提供程序的服务条款以了解更多详细信息。

3
0
9032
评价此常见问题解答

经销商

我想卖你的插件。 您有经销商折扣吗?

是的,我们愿意。 我们有一个程序,可让您以20%的折扣转售许可证。 如果您有兴趣转销Maps Marker Pro,请访问 mapsmarker.com/reseller.

2
0
8485
评价此常见问题解答

故障排除

无法激活插件–致命错误:未捕获的错误:找不到类'MMP \ SPBAS'

致命错误:未捕获的错误:在/wp-content/plugins/maps-marker-pro/classes/maps-marker-pro.php:111中找不到类“ MMP \ SPBAS”

如果您在激活插件时收到上述错误,则可能是您的服务器具有安全层(例如mod_security),从而导致在特定的混淆Maps Marker Pro文件上被删除。 默认情况下会模糊处理这些文件,以保护许可证验证机制;如果将安全层严格配置为该文件,则可以将这些文件伪造为恶意软件。

要解决此问题,请更新至v4.10或更高版本。 如果您仍然遇到问题, 请打开支持票.

要解决此问题,请与您的托管人联系,并要求他们将以下3个文件添加到安全层的白名单中:

  • /wp-content/plugins/maps-marker-pro/classes/menu-license.php
  • /wp-content/plugins/maps-marker-pro/classes/shortcodes.php
  • /wp-content/plugins/maps-marker-pro/classes/spbas.php

完成后,请重新下载 当前的插件包 (分别是您使用的版本 我们的发行档案 (如果不是当前文件),然后通过FTP手动重新上传上述3个文件。

0
0
4596
评价此常见问题解答

使用报纸主题时,不显示Google地图图块

如果您使用的主题是报纸 在Envato市场上可用可能是Google底图的地图图块不可见:

这是由主题的style.css引起的-我们已经与支持人员联系,希望该问题将在不久后通过新版本的报纸主题得到解决。

在此修复程序可用之前,您可以通过导航到“报纸/主题面板”,选择“自定义代码”标签,然后将以下CSS添加到“自定义CSS”部分中来解决此问题:

body.td-animation-stack-type0 .td-animation-stack .entry-thumb,
body.td-animation-stack-type0 .post img {
    opacity: unset !important;
}

作为替代,您还可以添加以下CSS:

.maps-marker-pro img {
    opacity: 1 !important;
}

0
0
5496
评价此常见问题解答

我无法更新地图或标记,因为保存按钮被禁用了

如果地图或标记编辑页面上的“保存”按钮被禁用并且无法单击,则可能是由于插件冲突引起的。 要验证这一点,请禁用除Maps Marker Pro之外的所有其他插件,然后重试。

如果这没有帮助,则一般的WordPress AJAX终结点可能存在问题。 查看浏览器控制台(例如,可以使用F11键打开),看是否有任何错误消息。 将这些错误消息发送给我们 支持票 这样我们就可以仔细看一看。

0
0
10239
评价此常见问题解答

地理编码错误“ OVER_QUERY_LIMIT”

如果在尝试将Google设置为地理编码提供商的地址进行地理编码时遇到错误OVER_QUERY_LIMIT,则表明您通过以下方式超出了Google Maps Platform网络服务的使用限制:

  • 每天发送太多请求,例如
  • 发送请求太快,即每秒太多请求

通过组合两种方法可以解决上述问题:

  1. 通过优化应用程序以更有效地使用Web服务来降低使用率。
  2. 在可能的情况下,通过购买Google Maps API for Work许可的额外配额来提高使用限制。

我们建议您登录到您的 Google API控制台 并在那里检查和调整使用限制。

或者,您可以切换到另一个 地理编码提供者.

1
1
14092
评价此常见问题解答

没有针对特定地址或位置的地址解析结果

Maps Marker Pro允许您从不同的地理编码提供者中进行选择,这可以使您根据需要获得最佳结果。 有关可用的地理编码提供程序的列表以及有关如何激活它们的说明,请查看 https://www.mapsmarker.com/kb/article/geocoding/.

请注意,每个地理编码提供商都使用具有不同更新周期的不同来源。 尽管如此,仍然可以找到地址的结果,尽管该地址确实存在。 如果您是这种情况,建议您切换到其他地理编码提供商,以验证是否在其中找到了确切的地址,例如,使用显示所有活动地理编码提供商的下拉菜单:

如果仍然找不到结果,则可以通过提交地址来帮助所有基于OpenStreetMap的地理编码服务(除Google地理编码之外的所有地理编码服务)来改善其数据集。 有关如何帮助改善OpenStreetMap的地址数据的更多信息,请访问以下站点:

0
0
12759
评价此常见问题解答

尝试上传gpx文件时出现“出于安全原因,文件类型不允许”错误

Maps Marker Pro v4.3和更高版本应解决此问题-请更新至最新版本以应用此修复程序。

如果仍然遇到此问题,请在wp-config.php中添加以下代码,该代码应重新启用.gpx文件的上载:

define('ALLOW_UNFILTERED_UPLOADS', true);

如果这对您的网站没有帮助,请查看以下提供的其他选项 本外部教程.

如果您之后仍然遇到问题,请 打开支持票.

3
0
8747
评价此常见问题解答

标记图标窗口被地图覆盖

如果您想更改标记的图标,并且在单击图标的“更改”按钮时图标窗口隐藏在地图后面,则通常是由插件冲突引起的(某些插件未遵循最佳做法并嵌入了它们的JavaScript和每个管理页面上的CSS文件,而不仅仅是在需要的地方)。

您可以找到并禁用导致此问题的插件,也可以在您的末尾添加以下代码
theme´s functions.php修复了这个问题:

/ * Maps Marker Pro-修复了使用jquery ui被其他插件或主题隐藏的图标模式* /函数mmp_icon_modal_visibility_workaround(){$ current_screen = get_current_screen(); if((($ current_screen-> base =='maps-marker-pro_page_mapsmarkerpro_marker')||($$ _ current_screen-> base =='maps-marker-pro_page_mapsmarkerpro_map')){echo'<style> .ui-dialog {z-索引:99999! } </ style>'; }} add_action('admin_head','mmp_icon_modal_visibility_workaround');
0
1
13082
评价此常见问题解答

解析错误:语法错误,maps-marker-pro.php中出现意外的T_OBJECT_OPERATOR

Plugin could not be activated because it triggered a fatal error.
Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /wp-content/plugins/maps-marker-pro/maps-marker-pro.php on line 66

如果您在尝试激活Maps Marker Pro时看到上述错误,则通常意味着您的服务器上使用的PHP版本太低。

自5.4年5.4月起,Maps Marker Pro至少需要PHP 2015才能正常运行,因为PHP XNUMX已经过时并且不再接收更新(包括安全修复!),我们强烈建议您使用 当前支持的PHP版本 (7.x)。

要解决此问题,请在可能的情况下通过托管控制面板切换PHP版本,或与托管提供商支持联系以为您切换PHP版本。

0
0
8818
评价此常见问题解答

Google底图上的“仅供开发用途”错误

默认情况下,Maps Marker Pro将OpenStreetMap用于地图,无需任何强制性的API密钥注册即可使用。 但是,如果您使用的是Google Maps,并且Google API密钥设置不完整/不正确,则会遇到以下问题:

如果您在使用Google底图的地图上看到错误“仅出于开发目的”,请打开浏览器控制台(例如,通过按Firefox或Chrome中的F12键),然后切换到“控制台”标签e,以查看有关错误:

在上面的示例中,错误是 NoApiKeys,这意味着缺少必需的Google Maps Javascript API密钥。

无论如何,大多数错误与您的Google Maps Javascript API密钥有关,这是正确显示Google Maps所必需的。

因此,要解决此问题,请按以下步骤操作:

  1. 确保您注册了Google Maps Javascript API密钥,请参见 教程 有关详细信息。 另外,请确保已将您的信用卡详细信息保存在Google API控制台中,因为自 Google ToS变更 从2018年夏季开始。
  2. 如果你的错误是 RefererNotAllowedMapError 请从中重新检查步骤6 教程 并确保已正确配置嵌入地图的域的接受引荐来源网址,例如 *.yourdomain.com/*

对于所有其他错误,请查看错误参考,网址为 https://developers.google.com/maps/documentation/javascript/error-messages#deverrorcodes 在这里您还将找到可能的解决方案。

如果仍然不能解决问题,请打开 支持票 我们很乐意为您提供帮助。

7
2
23502
评价此常见问题解答

尝试迁移到v4时出现错误“无法发送请求”

此错误表明您的AJAX配置分别在wp-admin / admin-ajax.php端点上存在一些问题。

要验证这一点,请打开浏览器控制台(例如Firefox或chrome中的F12),切换到“控制台”选项卡并重新加载页面,然后再次单击“检查迁移”以确认是否还有其他错误消息:

如果您在此没有看到错误消息,请切换到“网络”选项卡并重新加载页面,然后再次单击“检查迁移”以确认是否还有其他错误消息:

从上面的屏幕中,您可以看到请求失败,并显示状态(= HTTP错误代码)404 –在此示例中,文件/wp-admin/admin-ajax.php不可用。

但是,更有可能在此处看到状态500(=内部服务器错误)。 500内部服务器错误是服务器抛出异常时的一般捕获所有错误。 当没有更具体的错误消息适合并且在大多数情况下与服务器配置错误或问题直接相关时,它是错误消息。

那现在该怎么办?

首先,请尝试暂时停用除Maps Marker Pro以外的所有其他插件,以验证此问题不是由插件冲突引起的。

如果这样做没有帮助,请在发出该请求时查看服务器错误日志(例如PHP或Apache错误日志),这可能会为您提供线索为什么在服务器上发生此错误。

如果仍然不能解决问题,请检查以下教程之一是否可以帮助您找到此服务器错误的原因:

如果仍然不能解决问题,我们建议您与托管支持联系,以便他们可以分析尝试运行迁移工具时对/wp-admin/admin-ajax.php的请求失败的原因。

0
0
5076
评价此常见问题解答

控制台错误“未定义MapsMarkerPro”

如果未显示地图,并且浏览器控制台显示错误“未定义MapsMarkerPro”,请按照以下步骤操作:

  1. 如果您使用任何缓存插件,请先尝试清除所有涉及的缓存。
  2. 首先检查此问题是否可能是由插件冲突引起的。 为了验证这一点,请暂时禁用除Maps Marker Pro之外的所有其他插件,然后重试。
  3. 如果未返回任何结果,请验证您的模板文件是否包含用于 wp_head() 在header.php和 wp_footer() 在footer.php中(需要从Maps Marker Pro正确加载脚本和样式)。
0
0
8035
评价此常见问题解答

地图图块(在标签中)未完全加载

如果您的地图看起来像上面的示例,或者嵌入在选项卡中,请在后端启用“ Tabbed”选项,这可以解决此问题:

0
0
8016
评价此常见问题解答

显示“错误:无法加载地图图像”

如果您看到此错误消息而不是地图,则可能有以下几个原因:

最有可能的原因是所使用的(外部)切片服务器当前不可用或存在临时问题(例如,维护窗口)。 不幸的是,我们对外部图块服务器的可用性没有直接影响。MapsMarker Pro使您可以连接以显示地图图块。 根据我们的经验,OpenStreetMap非常可靠,并且很少会发生这些错误。

无论如何,也如错误消息中所述,可能是由于用户端存在Internet连接问题,尽管外部地图图块服务器可用,但导致地图图块无法加载。

导致此错误的第三个原因(错误的地图配置)通常仅在使用自定义切片服务器配置的情况下出现(例如,如果添加了仅显示特定区域的地图切片并且在该区域外平移地图的自定义底图)。

如果您与一个选定的图块服务提供商经常遇到此问题,则可以尝试为地图切换到另一个图块服务提供商。

1
0
13638
评价此常见问题解答

如何使用“地理位置重定向”插件解决不兼容问题

插件“地理位置重定向”可让您重定向访问者或根据他们的国家/地区切换语言。 不幸的是,自2013年以来没有进行过任何更新,并且将此插件与Maps Marker Pro一起使用会导致图层地图损坏(因为加载标记所需的leaflet-geojson.php调用也已重定向。

要解决此问题,请打开文件/wp-content/plugin/geographical-redirect/geo-redirect.php

查找代码

公共功能checkIfRedirectNeeded()
{
如果(!is_array($ this-> geo_redirect_data))
返回;

并替换它

公共功能checkIfRedirectNeeded()
{
// info:不要重定向Maps Marker Pro请求
$ request_uri = $ this-> request_uri;
if(stripos($ request_uri,'geojson')!== FALSE){
返回;
}
如果(!is_array($ this-> geo_redirect_data))
返回;

并保存文件。 因此,图层贴图应该可以再次工作。

0
0
9256
评价此常见问题解答

地理位置错误:仅允许使用安全来源/必须使用https

在Chrome 50 +,Firefox 55+和Safari 10+中,相关的浏览器供应商对地理位置支持进行了重大更改:仅允许请求用户当前位置的所有应用程序(不仅适用于Maps Marker Pro的地理位置功能)如果将站点设置为通过https安全交付,则可以再次检索用户的当前位置-用户将看到以下警告或类似警告:

地理位置错误信息

在以下位置查看有关Google这项决定的更多详细信息: https://developers.google.com/web/updates/2016/04/geolocation-on-secure-contexts-only。 如果用户通过其他浏览器(例如Firefox, 苹果浏览器 或Internet Explorer –无论如何,这些浏览器将来可能还会添加类似的安全限制。

2016年10月更新:由于iOS 10和Safari XNUMX+现在也需要https支持地理位置。 实施比使用Google Chrome浏览器更加严格–例如,如果您的网站上存在混合内容警告,则地理位置定位将无法工作。

2017年更新:Firefox 55+还需要使用https访问地理位置(查看具体信息)

因此,如果您需要网站上的Maps Marker Pro地理定位功能(v2.7甚至更有用,因为您可以根据用户的当前位置对标记列表进行排序),强烈建议您将网站迁移到https。 一些托管服务商已经提供了免费的https证书, letsencrypt.org 例如。 为了在WordPress网站中进行配置以使其支持https,需要进行配置,请查看类似的教程 https://css-tricks.com/moving-to-https-on-wordpress/.

由于https与您再次使用Google Chrome 50+和Safari 10+进行地理定位相比,对您的网站具有更多的优势(例如,确保数据完整性,发件人身份验证和用户隐私,以及将https用作排名信号,因此Google排名更高),我们强烈建议您仅将站点切换为https。

如果您将网站切换到https并仍然遇到地理位置错误(例如“地理位置错误:用户被拒绝的地理位置”),请检查设备的位置设置(如果允许应用/网站检索地理位置)。

2
0
7275
评价此常见问题解答

如何解决kriesi.at的与Enfold主题不兼容的问题

28年2016月2.8日更新:如果您使用的是Maps Marker Pro v3.11,Leaflet Maps Marker vXNUMX或更高版本,则不再需要以下解决方法。

流行的Enfold主题,作者: kriesi.at 使Google javascript在所有管理页面上排队,导致Google Autocomplete API(=地址搜索)中断。 要解决此问题,您必须完全禁用主题添加的映射功能:

打开wp-content / themes / enfold / functions.php(如果使用的是子主题,则分别来自子主题的functions.php),并在底部添加以下代码:

add_filter('avf_load_google_map_api', 'disable_google_map_api', 10, 1);
function disable_google_map_api($load_google_map_api) {
        $load_google_map_api = false;
        return $load_google_map_api;
}

有关更多信息,请访问 http://www.kriesi.at/support/topic/google-maps-element-javascript-conflict-with-maps-marker-pro-plugin/

0
0
5070
评价此常见问题解答

我没有看到有关新版本的插件更新通知

Maps Marker Pro插件每12小时检查一次新版本是否可用。 您还可以通过转到插件并单击“ Maps Marker Pro”旁边的“手动检查更新”链接来手动触发更新检查:

手动更新检查

如果您没有看到“手动检查更新”链接,或者单击该链接,则不会显示 最新版本 可用,请按照以下步骤操作:

请首先检查您使用的是v1.5.9还是v1.6。 在v1.5.9中,添加了通过SSL交付插件更新的功能,以提高安全性。 不幸的是,我们发现尽管此功能运行良好,但在SSL库过时或不完整的服务器上可能会出现问题。 这样可以阻止您的插件与mapsmarker.com通信以检查新的插件更新。

要解决此问题,请手动更新到最新版本,其中包括针对这些服务器的解决方法。 要手动更新插件,请从下载最新的软件包 https://mapsmarker.com/download-pro,解压缩插件包,然后通过FTP将解压缩后的文件夹/ maps-marker-pro /中的文件复制到您的服务器,覆盖目录youdomain.com/wp-content/中的所有文件和子目录插件/地图标记-PRO /

请注意:如果您要通过WordPress管理界面卸载并重新安装插件,则所有创建的地图都会在卸载时被删除,因此如果您已经创建了一些地图,请通过FTP进行手动更新!

如果更新到最新版本仍不能解决问题,请向您的托管服务商寻求帮助。 可能有特殊的安全预防措施,阻止您的服务器直接与https://www.mapsmarker.com通信(GET请求,端口443)

也可能是您的服务器仅允许通过代理进行直接连接(如果您未收到任何WordPress核心或插件更新,则可以进行验证)。 如果是这种情况,则必须在wp-config.php中配置代理服务器(请向您的托管人询问有关代理的详细信息):

define('WP_PROXY_HOST', '192.168.xx.xxx');
define('WP_PROXY_PORT', '8080');
define('WP_PROXY_USERNAME', 'my_user_name');
define('WP_PROXY_PASSWORD', 'my_password');
define('WP_PROXY_BYPASS_HOSTS', 'localhost, www.example.com');

如果您未使用代理,但仍看不到可用的新插件版本,请从以下位置安装调试栏插件 https://wordpress.org/extend/plugins/debug-bar/。 该插件使您可以调试与mapsmarker.com上更新服务器的通信。 激活此插件后,单击 调试 在管理栏中,然后选择 PUC(传单地图标记专业版) 从侧边栏。 之后,您可以通过单击按钮来检查与更新服务器的通信 查要更多信息现在检查:

调试栏步骤

如果您或您的托管服务商也无法帮助您解决从调试栏插件中检索到的信息,请 打开支持票 我们很高兴为您解决问题!

2
0
8480
评价此常见问题解答

“错误:无法获取新的本地许可证密钥。” 激活许可证后显示

连接错误

如果尝试在许可证设置页面上激活许可证密钥后看到上面的错误,则表明您的服务器无法连接到https://www.mapsmarker.com进行许可证验证。

请在这里向托管服务商寻求帮助。 可能有特殊的安全预防措施,阻止您的服务器直接与https://www.mapsmarker.com通信(GET请求,端口443)

也可能是您的服务器仅允许通过代理进行直接连接(如果您未收到任何WordPress核心或插件更新,则可以进行验证)。 如果是这种情况,则必须在wp-config.php中配置代理服务器(请向您的托管人询问有关代理的详细信息):

define('WP_PROXY_HOST', '192.168.xx.xxx');
define('WP_PROXY_PORT', '8080');
define('WP_PROXY_USERNAME', 'my_user_name');
define('WP_PROXY_PASSWORD', 'my_password');
define('WP_PROXY_BYPASS_HOSTS', 'localhost, www.example.com');

如果那也无济于事,请 打开支持票 我们很高兴为您解决问题!

0
0
4747
评价此常见问题解答

保存标记时,出现错误“ ID为0的标记不存在!”

此常见问题仅对Maps Marker Pro v3.1.1或更低版本有效:

请通过登录数据库工具(通常为phpmyadmin)并检查这些表是否创建了Maps Marker Pro所需的数据库表

  • wp_leafletmapsmarker_markers和
  • wp_leafletmapsmarker_layers

存在。 如果是,请打开WordPress调试(通过添加 define('WP_DEBUG',true); 到wp-config.php),如果可能的话,还可以查看PHP错误日志并打开一个 支持票 与记录的结果。

0
0
8008
评价此常见问题解答

使用Google Maps路线时的起点不正确

默认情况下,Google Maps被用作地图面板中的路线链接以及添加到每个标记的popuptext中的路线链接的路线提供者。

如果输入了您所在位置的地址,则此地址将用作方向的起点,如果仅输入了纬度和经度坐标(并且地址字段为空),则这些坐标将用作方向的起点。

如果您发现打开的Google地图上的起点不正确,则是因为默认情况下,Google始终会使用汽车作为首选的运输方式来计算路线。 因此,汽车可以自动到达您所在位置最近的位置作为起点。

不幸的是,这不能在Google Maps上解决,因为这不是bug,而是功能😉–无论如何,有几种方法可以解决此问题:

–如果仅依靠步行路线,则可以导航至“设置” /“路线设置” /“ Google地图”路线设置,然后选中“步行路线”复选框。

–如果这不是您的选择(此方向将忽略汽车的道路),请导航至“设置” /“方向设置” /“一般方向”设置,并设置其他方向提供者(如“兵力图”),该提供者将准确获取您所在位置的坐标并且不会更改起点。

0
1
9491
评价此常见问题解答

HTML5全屏模式不适用于iframe中的地图

如果您嵌入带有iframe标签的地图,则必须在此标签中添加以下代码,HTLM5-全屏模式(仅限专业版)才能正常工作:

allowfullscreen =“ true” mozallowfullscreen =“ true” webkitallowfullscreen =“ true”

0
0
7104
评价此常见问题解答

我只有“正在加载地图–请稍候……”,而没有地图

要分析此问题,请按照以下教程进行操作 https://www.mapsmarker.com/kb/article/need-support-please-read-me-first/

0
1
9613
评价此常见问题解答

我收到错误消息“无法加载地图-请启用Javascript!”

Maps Marker Pro需要支持Javascript的浏览器才能显示地图。 通用浏览器的当前版本(火狐, ,Internet Explorer或Safari)开箱即用地支持Javascript-如果您使用的是旧版本,请更新到当前版本(通常,您会从中受益,相信我!)。

如果这样做没有帮助,请检查您是否已安装了相同的Javascript阻止加载项/插件(如NoScript)并处于活动状态–需要禁用这些加载项才能显示地图。

如果这也没有帮助,请 打开支持票 我们将仔细查看为什么不显示您的地图。

1
1
28814
评价此常见问题解答

与其他插件的已知不兼容

在Leaflet Maps Marker的v2.1版本中,我添加了自动检查不兼容插件的说明,并说明了如何解决相应的错误(如果可能)。 如果发现不兼容,则会在您的WordPress管理区域中显示管理员通知(以及如何解决此问题的说明)。 此列表在每个新发行版上都会自动更新。

0
0
8284
评价此常见问题解答

存档–数据库警告“找到的行,其中auto_increment列的值为0”(仅v3.1.1或更低版本)

此常见问题仅对Maps Marker Pro v3.1.1或更低版本有效!

当使用备份插件(例如BackWPup)或通过phpmyadmin直接在数据库中工作时,您可能会注意到以下警告:

警告:wp_leafletmapsmarker_layers的表检查结果是:找到的行,其中auto_increment列的值为0

通常无需担心–表wp_leafletmapsmarker_layers设计为以值0开头–不幸的是,更改此值以抑制警告是不可能的,因为第0层用于未分配给该层的所有标记。

1
0
4826
评价此常见问题解答

使用地图– GPX轨道

尝试上传gpx文件时出现“出于安全原因,文件类型不允许”错误

Maps Marker Pro v4.3和更高版本应解决此问题-请更新至最新版本以应用此修复程序。

如果仍然遇到此问题,请在wp-config.php中添加以下代码,该代码应重新启用.gpx文件的上载:

define('ALLOW_UNFILTERED_UPLOADS', true);

如果这对您的网站没有帮助,请查看以下提供的其他选项 本外部教程.

如果您之后仍然遇到问题,请 打开支持票.

3
0
8747
评价此常见问题解答

健身追踪器的追踪记录可以显示在地图上吗?

如果您的健身追踪器(如garmin fit)允许将记录的轨道导出为GPX格式,则这些文件通常也可以使用Maps Marker Pro显示在地图上。

为了显示这些曲目,创建一个新地图,切换到选项卡“ GPX”,然后单击“打开媒体库”按钮开始:

下一步,切换到“上传文件”标签,选择并上传您的gpx文件,单击“选择”按钮完成操作:

结果,GPX轨迹显示在地图上,您可以选择进一步自定义其设置(建议将所有选项切换到高级编辑器):

0
0
4903
评价此常见问题解答

我可以在地图上添加多个GPX轨道吗?

您只能在地图上添加一个GPX文件-如果要在一张地图上显示多个GPX轨道,则必须先合并这些文件-您可以在以下位置使用在线工具: http://joewein.net/bike/gpxmerge/ 为了这个。

v4.0 尽管一个GPX文件中的多个轨道也受支持,并且可以通过海拔图中的相关控制框进行选择:

1
0
10595
评价此常见问题解答

我可以在地图上手动绘制GPX轨迹吗?

从v4.3开始,我们增加了折线支持,该支持使您可以直接在地图上使用折线,多边形,圆形和矩形等几何图层直接在地图上绘制:

请参见以下动画,了解如何编辑折线(动画由Sumit Kunar提供-请注意,Maps Marker Pro不支持动画中所示的标记添加功能-如果要添加标记,请使用“添加标记”功能):

1
2
8746
评价此常见问题解答

我可以在地图上显示路线(GPX)吗?

是的,此功能自Maps Marker Pro开始可用 v1.2.

v4.0 一个文件内还支持GPX高程图,航点和多个航迹。

0
0
4863
评价此常见问题解答

使用标记

我可以在多个地图上添加标记吗?

是的,使用Maps Marker Pro v4.0 +可以实现。

在后端打开标记,然后从地图选择框中选择要分配给的地图:

0
0
4706
评价此常见问题解答

我可以添加自定义地图图标吗?

是的,您可以从超过1000个图标中选择标记 https://mapicons.mapsmarker.com –有关如何上传和使用新图标的更多说明,请查看 本用户指南.

0
0
7932
评价此常见问题解答




要获得专用的1:1支持,请登录客户区并 打开新的支持票.

en English
X