Pro v2.4-beta1 with support for assigning markers to multiple layers is available

I kindly invite all interested users in testing v2.4-beta1 and reporting any issues by using the helpdesk, leaving a comment or using the contact form.

The highlight of the upcoming release is support for assigning markers to multiple layers, so I kindly ask beta testers to take a special focus on that new feature:

layers-assignment-demo

Updated translations have not been included yet but will be extracted from https://translate.mapsmarker.com/ shortly before the final release.

The final release v2.4 with more detailed release notes is planned to be released within the next week, depending on issues reported by beta testers.

Please see the end of this post on how to update to v2.4-beta1.

Preliminary changelog

assign markers to multiple layers (thx Waseem!)
support for displaying MaqQuest basemaps via https (thx Duncan!)
option to hide link “download GPX file” in GPX panel  
add gpx_url and gpx_panel to GeoJSON output for markers and layers  
option to select markers from multiple layers when exporting to XLSX/XLS/CSV/ODS  
compatibility check for Autoptimize plugin which can breaks maps if not properly configured 
multisite: option to activate license key on custom domains  
enhanced examples for customizing geolocation styling options (thx Bart!)
Visualead API for creating QR codes now uses secure https by default
distorted minimap controlbox icon if CSS box-sizing was applied to all elements by themes like enfold
XML output for search results via MapsMarker API was not valid  
QR code cache image for layers was not deleted via API  
XLSX importer for marker updates: if layer set does not exist, value was set to unassigned instead of current value 
fix compatibility for WordPress installations using HHVM (thx Rolf!) 
Translation updates
In case you want to help with translations, please visit the web-based translation plattform
Afrikaans (af) translation thanks to Hans, http://bmarksa.org/nuus/ 
Arabic (ar) translation thanks to Abdelouali Benkheil, Aladdin Alhamda – http://bazarsy.com, Nedal Elghamry – http://arabhosters.com, yassin and Abdelouali Benkheil – http://www.benkh.be 
Finnish (fi_FI) translation thanks to Jessi Björk – @jessibjork 
Greek (el) translation thanks to Philios Sazeides – http://www.mapdow.com, Evangelos Athanasiadis – http://www.wpmania.gr and Vardis Vavoulakis – http://avakon.com 
Hebrew (he_IL) translation thanks to Alon Gilad – http://pluto2go.co.il and kobi levi 
Lithuanian (lt_LT) translation thanks to Donatas Liaudaitis – http://www.transleta.co.uk 
Thai (th) translation thanks to Makarapong Chathamma and Panupong Siriwichayakul – http://siteprogroup.com/ 
Uighur (ug) translation thanks to Yidayet Begzad – http://ug.wordpress.org/ 
updated German translation
Known issues
Internet Explorer can crash with WordPress 4.2 to 4.2.2 due to Emoji conflict (details) – planned to be fixed with WordPress 4.2.3 & 4.3, workaround until WordPress 4.2.3 & 4.3 is available: disable Emojis

how to update to 2.4-beta1

Warning: it is not recommended to install 2.4-beta1 on production sites and it is advised to backup your site regularly (which is advised anyway)!

In order to be able to update to 2.4-beta1, you first have to set beta-testing in settings / misc to enabled:

beta-testing-setting

As next step after saving your settings, navigate to Plugins and click on the link “Manually check for updates” next to Maps Marker Pro:

manual-update-check

update-now

Finish by clicking on the link “Update now”.

feedback and suggestions?

Please use the helpdesk for bugreports, feedback or suggestions or leave a comment – any feedback is welcome!

Leave a Reply

Your email address will not be published. Required fields are marked *