Info: dette er ikke ændringsloggen for seneste stabile version 4.13.1
se alle skifter

Pro v1.5.7 med brud på API-ændringer og brugervenlighedsoptimeringer er tilgængelig

Med pro v1.5.7 fokuserede jeg endnu en gang på at forbedre eksisterende funktioner og generel brugervenlighed for backend. Godkendelsesmetoden til Maps Marker API er også ændret fuldstændigt, og den gamle godkendelsesmetode med kun offentlig nøgle understøttes ikke længere! Så hvis du bruger API til at administrere dine kort, skal du opgradere din applikation, før du opdaterer plugin til den nyeste version! Se nedenfor for flere detaljer.


Lad mig vide, hvad du synes om denne nye udgivelse af indsender en anmeldelse!

Hvis du vil holde dig opdateret med den seneste udvikling af Maps Marker, skal du følge @MapsMarker på twitter (= mest aktuelle opdateringer), den Facebook, Google+ eller abonnere på nyheder via RSS eller via RSS / e-mail.

Jeg vil også gerne invitere dig til at deltage i vores affiliate program som tilbyder provisioner op til 50%.


Lad os nu komme til højdepunkterne i pro v1.5.7:

support til dynamisk skift mellem forenklet og avanceret editor

Du kan nu skifte dynamisk mellem forenklet og avanceret editor på backend uden at skulle genindlæse siden - bare klik på redigeringsskiftlinket på markør eller lagredigeringssider:

dynamisk-editor-switching

Den opdaterede indstilling gemmes, når den er færdig ved at offentliggøre eller opdatere en markør eller lagkort.

mere sikker godkendelsesmetode til MapsMarker API

Indtil v1.5.6 skulle du kun bruge en offentlig nøgle til at udføre API-handlinger. Selvom der er flere ekstra sikkerhedslag tilgængelige (som at kun acceptere anmodninger fra specifikke IP'er eller specificere en henvisning, der er nødvendig), havde denne godkendelsesmetode sine mangler: enhver, der blev kendt med denne offentlige nøgle (ved at trykke på netværkstrafik eller have adgang til at anmode om logfiler for eksempel) kunne udføre en hvilken som helst API-handling (især hvis der ikke var flere ekstra sikkerhedslag aktive).

Da v1.5.7 skal alle API-anmodninger nu godkendes ved hjælp af en udløbende signatur, der kræver en offentlig og privat nøgle samt en udløbsværdi. Dette svarer til den tilgang, som Amazon bruger til at sikre adgang til deres S3 Storage API. Når de er godkendt, kan alle aktiverede API-handlinger udføres.

Jeg tilføjede eksempler på PHP, JavaScript og C # i MapsMarker API-dokumenter om, hvordan man programmatisk opretter en gyldig signatur.

Derudover er en "API URL Generator" og en "API URL Tester" tilføjet til værktøjssiden, så du kan oprette en signatur manuelt:

api-url-generator

api-url-tester

I det mindste anbefales det ikke rigtig, da den sikrere fremgangsmåde er at programmatisk oprette en signatur, der for eksempel udløber automatisk om 1 minut!

Bemærk, at den gamle godkendelsesmetode kun med offentlig nøgle ikke understøttes længere! Opgrader din ansøgning, før du opdaterer til v1.5.7!

Ud over de sikkerhedsforanstaltninger, der håndhæves af API, anbefales det stærkt at implementere SSL til WordPress-webstedet (uden for denne APIs rækkevidde).

For mere information se den opdaterede MapsMarker API-dokumenter - hvis du har oprettet en cool applikation ved hjælp af Maps Marker API, Lad mig venligst vide og jeg vil tilføje det til showcases!

ny MapsMarker API-søgefunktion med support til afgrænsningsboksen søgninger og mere

Med v1.5.7 tilføjede jeg også den nye API-handling "search". Med denne handling kan du udføre søgninger efter alle attributter for markør- eller lagkort. Se parametertabellerne i MapsMarker API-dokumenter for en oversigt.

Søgehandlingen tillader også at udføre afgrænsningsbokssøgninger ("Vis mig alle markører inden for et område") og datointervalssøgninger ("Vis mig alle markører oprettet før 2013-01-01").

For mere information se den opdaterede MapsMarker API-dokumenter.

optimeret markør- og lagsider på backend

Marker- og lagredigeringssider på backend er også optimeret med v1.5.7. Jeg forsøgte at fjerne hvidrum hvor det var muligt for en bedre brugeroplevelse, tilføjede manglende etiketter til at danne elementer til bedre valg, tilføjede en række "Avancerede indstillinger" (hvor WMS-lag blev flyttet til for eksempel) og optimerede visningen og valg af markørikoner, som nu er bedre visuelt understøttet:

markør-ikoner-optimerede

support til filtrering af markørikoner på backend (baseret på filnavn)

Som anmodet af brugere kan listen over ikoner nu også filtreres på backend baseret på filnavnet, og viser resultaterne dynamisk:

filter-ikoner

support til ændring af markør-id'er og lag-id'er fra værktøjssiden

På værktøjssiden tilføjede jeg to nye handlinger, så du kunne ændre ID'erne for markør- og lagkort:

ændring-markør-lag-id

Husk, at der er en begrænsning, når du skifter ID'et til et lag: hvis laget er en del af et flerlagskort, skal du manuelt tildele laget med det nye ID til flerlagskortet , da dette ikke opdateres automatisk!

support til bulkopdateringer af markørkort på værktøjssiden kun for valgte lag

Indtil v1.5.6 havde bulkopdateringsfunktionen for markørkort på værktøjssiden en mangel: du kunne kun ændre alle eksisterende markørkort og ikke foretage noget valg.

Dette er nu ændret med v1.5.7, så du kun kan udføre bulkopdateringer for alle markørkort for markørkort kun fra valgte lag:

bulk--markør-opdateringer-filter

enkelte citater i markørkortnavne blev undslippe

Indtil v1.5.6 blev tegnet 'undslået som \', da det blev brugt i markør- eller lagnavne. Dette er nu rettet (thx Eric til rapporten!). Husk, at denne rettelse ikke påvirker allerede oprettede kort med 'i navnet - så efter opdateringen til v1.5.7, skal du åbne de berørte kort, rette navnet og gemme dem igen.

Andre optimeringer og ændringer

  • afkrydsningsfeltet for kort i flere lag er nu også synligt som standard på lagredigeringssider
  • WMS-legenden link er ikke føjet til WMS attribution, hvis legend legend er tom
  • butik på mapsmarker.com accepterer nu også Diners Club-kreditkort

Fejlrettelser

  • dobbelt citater i markørkortnavne ville ødelægge kort, hvis markøren blev opdateret / oprettet via import
  • dobbelt citater i markørkortnavne ville ødelægge kort, hvis markøren blev opdateret via API
  • parameterklynger om lagvisningshandling i Maps Marker API gav ingen resultater

Oversættelser opdateringer

Takket være mange motiverede bidragydere kommer denne udgivelse med følgende opdaterede oversættelser:

Hvis du vil bidrage til oversættelser (nye hindi-oversættere vil blive værdsat!), Kan du besøge https://translate.mapsmarker.com/projects/lmm for mere information. Bemærk, at oversættere også kompenseres for deres bidrag - for eksempel hvis en oversættelse er færdig med mindre end 50%, får oversætteren en gratis 25 licenspakke til en værdi af € 199 som en kompensation for at afslutte oversættelsen til 100%.

Outlook - mine planer for den næste udgivelse

Vær opmærksom på, at jeg ikke kan love nogen frigivelsesdatoer for nye funktioner. Køreplanen for større nye funktioner (support til Google Street View med v1.6 og support til filtrering af lag på frontend til v1.7) er stadig gyldig, jeg vil bare beholde fleksibiliteten til at tilføje optimeringer og bugfixes med temmelig ikke planlagt mindre frigivelser, der hovedsageligt hidrører fra brugerens feedback.

Venligst også se køreplanen for en grov plan for planlagte funktioner, og abonner venligst på denne blog (via RSS or E-mail) eller følg @MapsMarker på twitter (= mest aktuelle opdateringer), hvis du vil holde dig opdateret med de seneste udviklingsnyheder.

Fuld changelog

support til dynamisk skift mellem forenklet og avanceret editor (der behøves ikke flere genindlæsninger)
mere sikker godkendelsesmetode til MapsMarker API (gammel metode med kun offentlig nøgle understøttes ikke længere!)
ny MapsMarker API søgehandling med support til afgrænsningsboksen søgninger og mere
support til filtrering af markørikoner på backend (baseret på filnavn)
support til ændring af markør-id'er og lag-id'er fra værktøjssiden
support til bulkopdateringer af markørkort på værktøjssiden kun for valgte lag
butik på mapsmarker.com accepterer nu også Diners Club-kreditkort
optimeret markør- og lagsider på backend (optimerede markørikoner vises, mindre hvidafstand for bedre arbejdsgang, tilføjet række "Avancerede indstillinger")
afkrydsningsfeltet for kort i flere lag er nu også synligt som standard på lagredigeringssider
WMS-legenden link er ikke føjet til WMS attribution, hvis legend legend er tom
optimeret input på backend ved at tilføje etiketter til alle formelementer
enkelte citater i markørkortnavne blev undslået (thx Eric!)
dobbelt citater i markørkortnavne ville ødelægge kort, hvis markøren blev opdateret / oprettet via import
dobbelt citater i markørkortnavne ville ødelægge kort, hvis markøren blev opdateret via API
parameterklynger om lagvisningshandling i Maps Marker API gav ingen resultater
Oversættelsesopdateringer
Hvis du vil hjælpe med oversættelser, kan du besøge webbaseret oversættelsesplatform
opdateret kinesisk oversættelse takket være John Shen, http://www.synyan.net og ck
opdateret tjekkisk oversættelse takket være Viktor Kleiner og Vlad Kuzba, http://kuzbici.eu
opdateret hollandsk oversættelse takket være Patrick Ruers, http://www.stationskwartiersittard.nl
opdateret fransk oversættelse takket være Vincèn Pujol, http://www.skivr.com og Rodolphe Quiedeville, http://rodolphe.quiedeville.org, Fx Benard, http://wp-translator.com, cazal cédric, http://www.cedric-cazal.com og Fabian Hurelle, http://hurelle.fr
opdateret tysk oversættelse
opdateret rumænsk oversættelse takket være Arian, http://administrare-cantine.ro og Daniel Codrea, http://www.inadcod.com
opdateret slovakisk oversættelse takket være Zdenko Podobny
Kendte problemer
tilpassede markørklyngefarver vises ikke på backendlagskort, hvis WordPress <3.7 bruges - opdatering anbefales!

Vis tidligere skifter

Sådan downloades / opdateres

Den nemmeste måde at opdatere er at bruge WordPress-opdateringsprocessen: log ind med en bruger, der har administratorrettigheder, naviger til Dashboard / Updates, vælg plugins, der skal opdateres, og tryk på knappen “Update Plugins”.

Pro-plugin kontrollerer hver 12. time, hvis en ny version er tilgængelig. Du kan også udløse opdateringskontrollen manuelt ved at gå til Plugins og klikke på linket "Manuelt kontrollere for opdateringer" ved siden af ​​"Maps Marker Pro":

check-til-updates-nyt

Yderligere opdateringsnotater til betatestere

Ingen yderligere handling ved plugin-opdatering kræves.

Efterlad en kommentar

XHTML: Du kan bruge disse tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

en English
X