Info: dette er ikke ændringsloggen for seneste stabile version 4.13.1
se alle skifter

Pro v1.5.8 med WordPress 3.9-kompatibilitet og forbedringer baseret på en sikkerhedsrevision af Wien er tilgængelig

v1.5.8 er hovedsageligt en kompatibilitets- og sikkerhedsrelateret udgivelse, da den løser problemer med WordPress 3.9, som snart frigives. Det inkluderer også forbedringer baseret på Wien's anden sikkerhedsrevision.

Ikke desto mindre er der også foretaget masser af under-the-hood-forbedringer, der gør det lettere, især for udviklere at bruge Leaflet API til specifikke kort eller lettere tilføje tilpassede stilarter. Se nedenfor for flere detaljer.


Lad mig vide, hvad du synes om denne nye udgivelse af indsender en anmeldelse!

Hvis du vil holde dig opdateret med den seneste udvikling af Maps Marker, skal du følge @MapsMarker på twitter (= mest aktuelle opdateringer), den Facebook, Google+ eller abonnere på nyheder via RSS eller via RSS / e-mail.

Jeg vil også gerne invitere dig til at deltage i vores affiliate program som tilbyder provisioner op til 50%.


Lad os nu komme til højdepunkterne i pro v1.5.8:

forbedret pluginsikkerhed ved at implementere henstillinger, der stammer fra anden sikkerhedsrevision af Wien

Da byen Wien planlægger at tilbyde deres kunder brug af Maps Marker Pro, gennemførte de en omfattende sikkerhedsrevision. Alle opdagede (potentielle) sårbarheder blev adresseret og rettet med dette problem. Derfor anbefales en opdatering til v1.5.8 - som altid -.

erstattet mulighed "maksimal bredde for billeder i popups" med indstillingen "CSS for billeder i popups"

Indstillingen "maksimal bredde for billeder i popups" fundet i Indstillinger / Kortdefaults / "Standardværdier for markør popups" er erstattet med den mere fleksible indstilling "CSS for billeder i popups":

css-popup-billeder

Bemærk, at din handling er nødvendig her, hvis du ændrede den maksimale bredde for billeder i popups! Bare ændre max-bredde: 234px! vigtigt; til værdien af ​​"maksimal bredde for billeder i popups", du havde før.

skift til vedvarende javascript-variabelnavne i stedet for tilfældige tal på frontend

Takket være feedback fra Sascha bruger Maps Marker Pro nu vedvarende javascript-variabelnavne i stedet for tilfældige tal på frontend (identificeret ved ID), f.eks. Markermap_4 eller layermap_1 i stedet for lmm_map_2a0552a5.

Denne ændring giver dig mulighed for at bruge Brochure-API udefra plugin. Nedenfor et eksempel på javascript-kode (som skal tilføjes sidefoden til dit tema) for at ændre zoomniveauet på markørkort ID 4 til 21:

<script type="text/javascript">
markermap_4.setZoom (21);
</ Script>

tilføj css klasser markering / layermap og marker-ID / lag-ID til hver kortdiv for bedre tilpasset styling

Hvert kort har nu også nye CSS-klasser, der giver mulighed for mere præcis styling:

  • hvert kort har CSS-klassen mapsmarker
  • derudover får markørkort CSS-klassen markermap og lagkort får CSS-klassen layermaps
  • derudover tilføjes en CSS-klasse med korttype og ID, f.eks markør-1 or lag-4

mulighed for automatisk at tilføje marknavne til popups

Som anmodet af brugere er det nu også muligt automatisk at tilføje mærkenavnet til popup-teksten:

markername-in-popups

Som standard er denne indstilling deaktiveret. Hvis du vil aktivere det, skal du navigere til Indstillinger / Kortdefaults / Standardværdier for markør popups:

add-markername-popup

tillade administratorer at ændre oprettet og information om markør- og lagkort

Administratorer har nu også tilladelse til at ændre info for oprettet og skabt til markør- og lagkort:

revision-skift-administratorer

Regelmæssige brugere kan ikke redigere disse formularfelter.

vis en advarsel om ændringer, der ikke er gemt, før markerings- / lagredigerings- eller indstillingssider forlades

Denne udgivelse tilføjer også en advarsels popup, hvis du forsøger at efterlade en markør eller lagside på backend eller indstillingssiden med ikke-gemte ændringer, da du ved dette fra redigering af indlæg eller sider. Nedenfor et eksempel på et websted med tysk som landestandard:

ugemte ændringer

nyt værktøj til at rydde cache for QR-koder

Et nyt værktøj er også føjet til denne udgivelse, som giver dig mulighed for at rense QR-kode billeder cache:

klar-QR-kode-billeder

Uanset hvad anbefales brugen af ​​dette værktøj kun, når en ny QR-kodebakgrund er konfigureret, eller hvis webadresserne til fuldskærmskortene er ændret (f.eks. Ved at flytte til et andet domæne).

Andre optimeringer og ændringer

  • kort flytter tilbage til udgangsposition på markørkort, når popup er lukket
  • tilføjet support til gif- og jpg-markørikoner
  • optimerede backend-belastningstider på markør + lag-opdateringer (indlæser ikke plugin-header to gange mere; næste: AJAX 😉
  • fjerne understøttelse af Cloudmade basemaps, når gratis flisetjeneste ophører (-> ændre basemap til OSM for kort ved hjælp af Cloudmade)
  • lag midtstift på backend forbliver nu altid på toppen af ​​markører og er nu lidt gennemsigtig (thx Sascha!)
  • optimeret live preview af popup-indhold på markørens redigeringsside (viser nu også den aktuelle adresse til link til rutevejledning)
  • fjernet mulighed "ekstra CSS til tabelceller" til liste over markører
  • licensbekræftelsesopkald udføres nu via WordPress HTTP API, som understøtter proxier, der er konfigureret i wp-config.php
  • Brug WordPress HTTP API i stedet for cURL () til brugerdefinerede markørikoner og skyggetjek
  • Brug wp_handle_upload () til upload af ikoner i stedet for WP_Filesystem () for bedre sikkerhed
  • opdater markørklyngekodebase (ved hjælp af build 14/03/14 i stedet for 21/01/14)
  • indstil passende titel til HTML5-fuldskærmsknap (se fuldskærm / afslutte fuldskærm)

Fejlrettelser

  • markørikonvalg på backend blev brudt på Internet Explorer 11 (brug af andre browsere anbefales generelt)
  • Maps Marker API: gyldighedskontrol af indlægsanmodninger om opretteton / opdateret parameter mislykkedes (thx Sascha!)
  • tilføjet klart: begge; til retnings-link i popup-tekst for at rette visning af flydende billeder (thx Sascha!)
  • brugerdefineret css til markørklynger blev ikke brugt, hvis der anvendes en kortkode i en skabelonfil eller widget
  • link til retningsindstillinger i markør-popup-tekster på markørredigeringssider blev brudt (kun synlig på avanceret editor)
  • dynamisk preview af WMS-lag blev brudt på backend siden v1.5.7
  • potentielle scriptingsproblemer på tværs af websteder (hovedsageligt udnyttes kun af administratorbrugere)
  • wpdb :: forbered () advarselsmeddelelse på Wikitude API-output til lagkort
  • visual tinyMCE editor blev brudt på markørredigering og værktøjssider siden WordPress 3.9-alpha
  • ikon upload-knap blev brudt siden WordPress 3.9-alpha
  • undslip af inputværdier med mysql_real_escape_string () blev brudt siden WordPress 3.9-alpha (nu erstattet med esc_sql ())
  • nulstilling af indstillingerne blev brudt siden WordPress 3.9-alpha (nu erstattet med esc_sql ())

Oversættelser opdateringer

Takket være mange motiverede bidragydere kommer denne udgivelse med følgende opdaterede oversættelser:

Hvis du vil bidrage til oversættelser (nye hindi-oversættere vil blive værdsat!), Kan du besøge https://translate.mapsmarker.com/projects/lmm for mere information. Bemærk, at oversættere også kompenseres for deres bidrag - for eksempel hvis en oversættelse er færdig med mindre end 50%, får oversætteren en gratis 25 licenspakke til en værdi af € 149 som en kompensation for at afslutte oversættelsen til 100%.

Outlook - mine planer for den næste udgivelse

Vær opmærksom på, at jeg ikke kan love nogen frigivelsesdatoer for nye funktioner. Køreplanen for større nye funktioner (support til Google Street View med v1.6 og support til filtrering af lag på frontend til v1.7) er stadig gyldig, jeg vil bare beholde fleksibiliteten til at tilføje optimeringer og bugfixes med temmelig ikke planlagt mindre frigivelser, der hovedsageligt hidrører fra brugerens feedback.

Venligst også se køreplanen for en grov plan for planlagte funktioner, og abonner venligst på denne blog (via RSS or E-mail) eller følg @MapsMarker på twitter (= mest aktuelle opdateringer), hvis du vil holde dig opdateret med de seneste udviklingsnyheder.

Fuld changelog

tilføj css klasser markering / layermap og marker-ID / lag-ID til hver kortdiv for bedre tilpasset styling
mulighed for automatisk at tilføje marknavne til popups (standard = falsk)
tillade administratorer at ændre oprettet og information om markør- og lagkort
vis en advarsel om ændringer, der ikke er gemt, før markerings- / lagredigerings- eller indstillingssider forlades
nyt værktøj til at rydde cache for QR-koder
kort flytter tilbage til udgangsposition på markørkort, når popup er lukket
tilføjet support til gif- og jpg-markørikoner
erstattet mulighed "maksimal bredde for billeder i popups" med indstillingen "CSS for billeder i popups" (handling er nødvendig, hvis du ændrede maksimal bredde for billeder i popups!)
skift til vedvarende javascript-variabelnavne i stedet for tilfældige tal på frontend (thx Sascha!)
fjerne understøttelse af Cloudmade basemaps, når gratis flisetjeneste ophører (-> ændre basemap til OSM for kort ved hjælp af Cloudmade)
lag midtstift på backend forbliver nu altid på toppen af ​​markører og er nu lidt gennemsigtig (thx Sascha!)
optimeret live preview af popup-indhold på markørens redigeringsside (viser nu også den aktuelle adresse til link til rutevejledning)
fjernet mulighed "ekstra CSS til tabelceller" til liste over markører
optimerede backend-belastningstider på markør + lag-opdateringer (indlæser ikke plugin-header to gange mere; næste: AJAX 😉
forbedret pluginsikkerhed ved at implementere henstillinger, der stammer fra anden sikkerhedsrevision af Wien
licensbekræftelsesopkald udføres nu via WordPress HTTP API, som understøtter proxier, der er konfigureret i wp-config.php
Brug WordPress HTTP API i stedet for cURL () til brugerdefinerede markørikoner og skyggetjek
Brug wp_handle_upload () til upload af ikoner i stedet for WP_Filesystem () for bedre sikkerhed
opdater markørklyngekodebase (ved hjælp af build 14/03/14 i stedet for 21/01/14)
indstil passende titel til HTML5-fuldskærmsknap (se fuldskærm / afslutte fuldskærm)
markørikonvalg på backend blev brudt på Internet Explorer 11 (brug af andre browsere anbefales generelt)
Maps Marker API: gyldighedskontrol af indlægsanmodninger om opretteton / opdateret parameter mislykkedes (thx Sascha!)
tilføjet klart: begge; til retnings-link i popup-tekst for at rette visning af flydende billeder (thx Sascha!)
brugerdefineret css til markørklynger blev ikke brugt, hvis der anvendes en kortkode i en skabelonfil eller widget
link til retningsindstillinger i markør-popup-tekster på markørredigeringssider blev brudt (kun synlig på avanceret editor)
dynamisk preview af WMS-lag blev brudt på backend siden v1.5.7
potentielle scriptingsproblemer på tværs af websteder (hovedsageligt udnyttes kun af administratorbrugere)
wpdb :: forbered () advarselsmeddelelse på Wikitude API-output til lagkort
visual tinyMCE editor blev brudt på markørredigering og værktøjssider siden WordPress 3.9-alpha
ikon upload-knap blev brudt siden WordPress 3.9-alpha
undslip af inputværdier med mysql_real_escape_string () blev brudt siden WordPress 3.9-alpha (nu erstattet med esc_sql ())
nulstilling af indstillingerne blev brudt siden WordPress 3.9-alpha (nu erstattet med esc_sql ())
OversættelsesopdateringerHvis du vil hjælpe med oversættelser, kan du besøge webbaseret oversættelsesplatform
opdateret hollandsk oversættelse takket være Patrick Ruers, http://www.stationskwartiersittard.nl
opdateret tysk oversættelse
opdateret lettisk oversættelse takket være Juris Orlovs, http://lbpa.lv og Eriks Mind http://geekli.st/Eriks
opdateret rumænsk oversættelse takket være Arian, http://administrare-cantine.ro og Daniel Codrea, http://www.inadcod.com
opdateret spansk oversættelse takket være Alvaro Lara, http://www.alvarolara.com, Victor Guevara, http://1sistemas.net og Ricardo Viteri, http://www.labviteri.com
opdateret svensk oversættelse takket være Olof Odier http://www.historiskastadsvandringar.se, Tedy Warsitha http://codeorig.in/, Dan Paulsson http://www.paulsson.eu og Elger Lindgren, http://20x.se

Vis tidligere skifter

Sådan downloades / opdateres

Den nemmeste måde at opdatere er at bruge WordPress-opdateringsprocessen: log ind med en bruger, der har administratorrettigheder, naviger til Dashboard / Updates, vælg plugins, der skal opdateres, og tryk på knappen “Update Plugins”.

Pro-plugin kontrollerer hver 12. time, hvis en ny version er tilgængelig. Du kan også udløse opdateringskontrollen manuelt ved at gå til Plugins og klikke på linket "Manuelt kontrollere for opdateringer" ved siden af ​​"Maps Marker Pro":

check-til-updates-nyt

Yderligere opdateringsnotater til betatestere

Ingen yderligere handling ved plugin-opdatering kræves.

Efterlad en kommentar

XHTML: Du kan bruge disse tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

en English
X