Info: Dies ist nicht das Changelog für die neueste stabile Version 4.13.1
Alle Änderungsprotokolle anzeigen

Pro v1.7 mit leaflet.js v0.7.3 und Kompatibilitätskorrekturen ist verfügbar

Diese Version aktualisiert die leaflet.js Bibliothek, die ich als "die Engine des Plugins" bezeichne - danke an alle Mitwirkenden, insbesondere an Trauernde ab mapbox.com, die die Entwicklung führt.

Außerdem habe ich Problemumgehungen für Installationen auf Servern mit veralteten SSL-Bibliotheken erstellt. Einige Benutzer dieses Servers haben beispielsweise beim Versuch, ihren Lizenzschlüssel zu aktivieren, Probleme gemeldet. Daher wurde mit Pro v1.7 eine Problemumgehung für diese Server hinzugefügt.

Wenn Sie nicht sehen, dass das aktuelle Update verfügbar ist, sind Sie möglicherweise ebenfalls von diesem Problem betroffen und müssen das Plugin daher einmal manuell auf Pro v1.7 aktualisieren. Weitere Informationen finden Sie im Abschnitt „Herunterladen / Aktualisieren“. Wenn Sie betroffen sind und sich nicht sicher sind, was Sie tun sollen, bitte Öffnen Sie ein Support-Ticket!


Lassen Sie mich wissen, was Sie über diese neue Version von denken eine Bewertung abgeben!

Wenn Sie über die neueste Entwicklung von Maps Marker auf dem Laufenden bleiben möchten, folgen Sie bitte @MapsMarker auf Twitter (= die aktuellsten Updates), auf Facebook, Google+ oder abonnieren Sie Nachrichten über RSS oder über RSS / E-Mail.

Ich möchte Sie auch einladen, sich unserem anzuschließen Affiliate-Programm das bietet Provisionen bis zu 50%. Wenn Sie daran interessiert sind, Wiederverkäufer zu werden, besuchen Sie bitte https://www.mapsmarker.com/reseller


Kommen wir nun zum Highlight von Pro v1.7:

Upgrade auf leaflet.js v0.7.3

Leaflet.jswurde die Javascript-Kernbibliothek dieses Plugins veröffentlicht. Diese Version ist als Wartungsversion mit 8 Bugfixes gekennzeichnet. vollständiges Änderungsprotokoll.

Andere Optimierungen und Änderungen

  • Aktualisieren der Markercluster-Codebasis (mit Build 28/05/14 anstelle von 14/03/14)
  • Zeigen Sie detailliertere Fehlermeldungen zu Problemen mit Mapsmarker.com-Lizenz-API-Aufrufen an

Fehlerbehebung

  • Bildbearbeitung + Entfernen von Overlay-Schaltflächen im TinyMCE-Editor für Popup-Texte auf Markierungsbearbeitungsseiten fehlten seit WordPress 3.9 (thx braun)
  • Kacheln für Google Maps verschwanden beim Zoomen, wenn Sie auf Mobiltelefonen zoomen
  • API-Aufrufe für defekte Lizenzen auf Servern mit veralteten SSL-Bibliotheken

Übersetzungsaktualisierungen

Dank vieler motivierter Mitwirkender enthält diese Version die folgenden aktualisierten Übersetzungen:

Wenn Sie zu Übersetzungen beitragen möchten (neue Hindi-Übersetzer wären willkommen!), Besuchen Sie bitte https://translate.mapsmarker.com/projects/lmm .

Bitte beachten Sie, dass Übersetzer auch für ihren Beitrag entschädigt werden. Wenn beispielsweise eine Übersetzung zu weniger als 50% abgeschlossen ist, erhält der Übersetzer ein kostenloses 25-Lizenzpaket im Wert von 149 € als Entschädigung für die Fertigstellung der Übersetzung zu 100%.

Ausblick - meine Pläne für die nächste Veröffentlichung

Bitte haben Sie Verständnis dafür, dass ich keine Veröffentlichungstermine für neue Funktionen versprechen kann. Die Roadmap für wichtige neue Funktionen (Unterstützung für Google Street View und Unterstützung für das Filtern von Ebenen im Frontend) ist weiterhin gültig. Ich möchte nur die Flexibilität beibehalten, Optimierungen und Bugfixes mit eher ungeplanten Nebenversionen hinzuzufügen, die hauptsächlich aus dem Feedback der Benutzer resultieren.

Bitte auch siehe die Roadmap Für einen groben Zeitplan für geplante Funktionen abonnieren Sie bitte diesen Blog (via RSS or E–Mail) oder folge @MapsMarker auf Twitter (= die aktuellsten Updates), wenn Sie über die neuesten Entwicklungsnachrichten auf dem Laufenden bleiben möchten.

Vollständiges Änderungsprotokoll

Upgrade auf leaflet.js v0.7.3 (Wartungsversion mit 8 Bugfixes, Changelog)
Aktualisieren der Markercluster-Codebasis (mit Build 28/05/14 anstelle von 14/03/14)
Zeigen Sie detailliertere Fehlermeldungen zu Problemen mit Mapsmarker.com-Lizenz-API-Aufrufen an
Bildbearbeitung + Entfernen von Overlay-Schaltflächen im TinyMCE-Editor für Popup-Texte auf Markierungsbearbeitungsseiten fehlten seit WordPress 3.9 (thx braun)
Kacheln für Google Maps verschwanden beim Zoomen, wenn Sie auf Mobiltelefonen zoomen
API-Aufrufe für defekte Lizenzen auf Servern mit veralteten SSL-Bibliotheken
Aktualisierungen der Übersetzungen Wenn Sie bei Übersetzungen helfen möchten, besuchen Sie bitte die webbasierte Übersetzungsplattform
aktualisierte deutsche Übersetzung
aktualisierte italienische Übersetzung dank Luca Barbetti, http://twitter.com/okibone
aktualisierte rumänische Übersetzung dank Arian, http://administrare-cantine.roDaniel Codrea, http://www.inadcod.com und Flo Bejgu, http://www.inboxtranslation.com

Vorherige Änderungsprotokolle anzeigen

Herunterladen / Aktualisieren

Der einfachste Weg zum Aktualisieren ist die Verwendung des WordPress-Aktualisierungsprozesses: Melden Sie sich mit einem Benutzer an, der über Administratorrechte verfügt, navigieren Sie zu Dashboard / Updates, wählen Sie die zu aktualisierenden Plugins aus und klicken Sie auf die Schaltfläche „Plugins aktualisieren“. Das Pro-Plugin überprüft alle 12 Stunden, ob eine neue Version verfügbar ist. Sie können die Update-Prüfung auch manuell auslösen, indem Sie unter "Plugins" auf den Link "Manuell nach Updates suchen" neben "Maps Marker Pro" klicken:

manuelle-Update-Prüfung

Wenn Sie den Link „Nach Updates suchen“ nicht sehen und eine Version unter 1.7 verwenden, aktualisieren Sie diese bitte einmal manuell, indem Sie das aktuelle Paket von herunterladen https://www.mapsmarker.com/download-pro und Überschreiben der vorhandenen Plugin-Dateien auf Ihrem Server über FTP. Dies kann auf mehreren Hosts erforderlich sein, die veraltete SSL-Bibliotheken verwenden, wodurch verhindert wird, dass Maps Marker Pro eine sichere Verbindung zum Abrufen des Aktualisierungspakets von mapsmarker.com herstellt. Pro v1.7 enthält eine Problemumgehung für diese Art von Servern, und die folgenden Updates sollten wie gewohnt wieder funktionieren. Wenn Sie betroffen sind und Hilfe benötigen, bitte Öffnen Sie ein Support-Ticket.

Zusätzliche Update-Hinweise für den Beta-Tester

Keine zusätzliche Aktion zum Plugin-Update erforderlich.

Eine Antwort auf "Pro v1.7 mit leaflet.js v0.7.3 und Kompatibilitätskorrekturen ist verfügbar"

Hinterlasse einen Kommentar

XHTML: Sie können diese Tags verwenden: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

en English
X