Información: este no es el registro de cambios para el última versión estable 4.13.1
ver todos los registros de cambios

Pro v2.7.1 con correcciones de errores (especialmente para mapas en móviles) está disponible

v2.7.1 es una versión de corrección de errores que soluciona un problema con el zoom del mapa en dispositivos móviles y también incluye algunas otras correcciones de errores menores, especialmente para los filtros que agregamos con v2.7.

Una actualización a la última versión es, como siempre, muy recomendable. Para obtener más detalles sobre esta versión, consulte a continuación.


Háganos saber lo que piensa sobre este nuevo lanzamiento de enviando una reseña o dejando un comentario a continuación!

Si desea mantenerse al día con el último desarrollo de Maps Marker Pro, siga @MapsMarker en twitter (= actualizaciones más actuales), en Facebook, Google+ o suscribirse a las noticias a través de RSS o a través RSS / correo electrónico.

También nos gustaría invitarle a unirse a nuestro programa de afiliados que ofrece comisiones de hasta el 50%. Si está interesado en convertirse en revendedor, visite https://www.mapsmarker.com/reseller


Ahora veamos los aspectos más destacados de pro v2.7.1:

Presentamos WPRuby: nuestro socio oficial para el desarrollo personalizado de Maps Marker Pro

Si desea ampliar Maps Marker Pro más allá de sus funciones, tenemos el API de Maps Marker Pro listo para que lo construyas. Y si necesita ayuda con eso, también lo tenemos cubierto ahora: vea https://www.mapsmarker.com/wpruby-com para más detalles sobre nuestra nueva asociación con WPRuby.com.

Otros cambios y optimizaciones

  • agregar clase CSS icono-filtros-mlm para filtrar la caja de control para permitir un estilo personalizado mejor y más fácil (¡gracias Paige!)
  • elimine la verificación de HTML5-URL predeterminada del campo de entrada para que los iconos de filtro también admitan URL que comiencen con // (¡gracias Chris!)

Corrección de errores

  • los mapas podrían romperse en dispositivos móviles si se usara el nivel de zoom máximo (¡gracias Giampiero!)
  • Los íconos de marcadores cargados con tamaños personalizados no se redimensionaron al tamaño predeterminado en la lista de marcadores (¡gracias Patrick!)
  • "Capa duplicada y marcadores asignados" y "eliminar capa y marcadores asignados" para mapas de una sola capa se rompió con v2.7
  • La salida de GeoJSON para capas se rompió si el parámetro GET completo se estableció en sí
  • los diálogos de confirmación en el backend se rompen en parte si se usa la traducción al italiano (¡gracias Giampiero!)
  • la fila de capas en la página "listar todas las capas" no se ocultaba si se eliminaba la capa
  • la tabla de marcador asignada en la página de edición de capa no estaba oculta en las acciones "duplicar capa solamente" y "agregar nueva capa"
  • la navegación del encabezado del backend no se mostraba si los marcadores se duplicaban de la página “listar todos los marcadores”
  • El reproductor de audio predeterminado de WordPress no era visible en los textos emergentes en los mapas de capas (¡gracias Jochen!)
  • La fila "utilizado en el contenido" en las páginas de edición de marcador y capa no se ocultaba al duplicar un marcador / capa existente

Problemas conocidos

La función de geolocalización ya no funciona con Google Chrome 50+ a menos que su sitio sea accesible de forma segura a través de https

Con Chrome 50, Google realizó un cambio significativo en el soporte de geolocalización de su navegador: todas las aplicaciones que solicitan la posición actual del usuario (no solo para la función de geolocalización de Maps Marker Pro) solo pueden recuperar la posición actual del usuario si el sitio está configurado para entregarse de manera segura a través de https; en cambio, los usuarios verán la siguiente advertencia:

información de error de geolocalización

Ver más detalles sobre esta decisión de Google en https://developers.google.com/web/updates/2016/04/geolocation-on-secure-contexts-only. La geolocalización seguirá funcionando en sitios que no sean https si los usuarios acceden al sitio a través de navegadores alternativos como Firefox, Safari o Internet Explorer; de todos modos, es probable que esos navegadores también agreguen una restricción de seguridad similar en el futuro.

Por lo tanto, si necesita la función de geolocalización Maps Marker Pro en su sitio (que con v2.7 incluso se vuelve más útil ya que puede ordenar la lista de marcadores según la posición actual del usuario), se recomienda migrar su sitio a https. Algunos proveedores de alojamiento ya proporcionan certificados https gratuitos de letsencrypt.org por ejemplo. Para las configuraciones necesarias dentro de su sitio de WordPress para configurarlo para que sea compatible con https, eche un vistazo a tutoriales como https://css-tricks.com/moving-to-https-on-wordpress/.

Como https tiene más ventajas para su sitio que solo la geolocalización trabajando de nuevo con Google Chrome 50+ (como asegurar la integridad de los datos, la autenticación del remitente y la privacidad del usuario, así como una clasificación más alta de Google, ya que https se usa como señal de clasificación), le recomendamos encarecidamente que cambie su sitio a https solo si aún no lo ha hecho.

Actualizaciones de traducciones

Gracias a muchos colaboradores motivados, esta versión incluye las siguientes traducciones actualizadas:

Si desea contribuir a las traducciones (¡se agradecerán los nuevos traductores de hindi!), Visite https://translate.mapsmarker.com/projects/lmm .

Tenga en cuenta que los traductores también son compensados ​​por su contribución; por ejemplo, si una traducción finaliza menos del 50%, el traductor recibe un paquete de 25 licencias gratis por valor de € 249 como compensación por completar la traducción al 100%.

Outlook: planes para las próximas versiones

Por favor, comprenda que no podemos prometer ninguna fecha de lanzamiento para nuevas funciones. los hoja de ruta para las principales características nuevas le da una idea de hacia dónde se dirige Maps Marker Pro; de todos modos, solo queremos mantener la flexibilidad para agregar optimizaciones y correcciones de errores con lanzamientos menores bastante imprevistos que resultan principalmente de los comentarios de los usuarios.

Suscríbete a este blog (a través de RSS or Correo electrónico) o sigue @MapsMarker en twitter (= actualizaciones más actuales) si desea mantenerse al día con las últimas noticias de desarrollo.

Registro de cambios completo

Presentamos WPRuby: nuestro socio oficial para el desarrollo personalizado de Maps Marker Pro
agregar clase CSS icono-filtros-mlm para filtrar la caja de control para permitir un estilo personalizado mejor y más fácil (¡gracias Paige!)
elimine la verificación de HTML5-URL predeterminada del campo de entrada para que los iconos de filtro también admitan URL que comiencen con // (¡gracias Chris!)
los mapas podrían romperse en dispositivos móviles si se usara el nivel de zoom máximo (¡gracias Giampiero!)
Los íconos de marcadores cargados con tamaños personalizados no se redimensionaron al tamaño predeterminado en la lista de marcadores (¡gracias Patrick!)
"Capa duplicada y marcadores asignados" y "eliminar capa y marcadores asignados" para mapas de una sola capa se rompió con v2.7
La salida de GeoJSON para capas se rompió si el parámetro GET completo se estableció en sí
los diálogos de confirmación en el backend se rompen en parte si se usa la traducción al italiano (¡gracias Giampiero!)
la fila de capas en la página "listar todas las capas" no se ocultaba si se eliminaba la capa
la tabla de marcador asignada en la página de edición de capa no estaba oculta en las acciones "duplicar capa solamente" y "agregar nueva capa"
la navegación del encabezado del backend no se mostraba si los marcadores se duplicaban de la página “listar todos los marcadores”
El reproductor de audio predeterminado de WordPress no estaba visible en los textos emergentes en los mapas de capas (gracias Jochen!)
La fila "utilizado en el contenido" en las páginas de edición de marcador y capa no se ocultaba al duplicar un marcador / capa existente
La función de geolocalización ya no funciona con Google Chrome 50+ a menos que su sitio sea accesible de forma segura a través de https (detalles)
Actualizaciones de la traducción
En caso de que quiera ayudar con las traducciones, visite el plataforma de traducción basada en web
traducción al catalán actualizada gracias a Efraim Bayarri, http://replicantsfactory.com, Vicent Cubells, http://vcubells.net y Marta Espinalt, http://www.martika.es
traducción checa actualizada gracias a Viktor Kleiner y Vlad Kuzba, http://kuzbici.eu
traducción alemana actualizada
traducción griega actualizada gracias a Philios Sazeides - http://www.mapdow.com, Evangelos Athanasiadis - http://www.wpmania.gr y Vardis Vavoulakis - http://avakon.com
traducción lituana actualizada gracias a Donatas Liaudaitis - http://www.transleta.co.uk
traducción rusa actualizada gracias a Ekaterina Golubina (con el apoyo de Teplitsa of Social Technologies - http://te-st.ru) y Vyacheslav Strenadko, http://slavblog.ru
traducción al español actualizada gracias a David Ramírez, http://www.hiperterminal.comAlvaro Lara http://www.alvarolara.comVictor Guevara http://1sistemas.netRicardo Viteri http://www.labviteri.comJuan Valdés y Marta Espinalt http://www.martika.es

mostrar todos los registros de cambios disponibles

Cómo descargar / actualizar

La forma más fácil de actualizar es usar el proceso de actualización de WordPress: inicie sesión con un usuario que tenga privilegios de administrador, navegue hasta Tablero / Actualizaciones, seleccione complementos para actualizar y presione el botón "Actualizar complementos". El plugin pro verifica cada 12 horas si hay una nueva versión disponible. También puede activar manualmente la verificación de actualización yendo a Complementos y haciendo clic en el enlace "Buscar actualizaciones manualmente" junto a "Maps Marker Pro":

manual-update-check

Si no ve el enlace "Buscar actualizaciones" y está utilizando una versión inferior a 1.7, actualice manualmente una vez descargando el paquete actual de https://www.mapsmarker.com/download-pro y sobrescribir los archivos de complementos existentes en su servidor a través de FTP. Esto podría ser necesario en varios hosts, que usan bibliotecas SSL obsoletas, que impiden que Maps Marker Pro establezca una conexión segura para recuperar el paquete de actualización de mapsmarker.com. Pro v1.7 incluye una solución para ese tipo de servidores y las siguientes actualizaciones deberían funcionar de nuevo como de costumbre. Si está afectado y necesita ayuda, por favor abrir un ticket de soporte.

Cómo verificar la integridad del paquete de complemento

Valor hash SHA-256:

3989501CDD34DC26D87AB8FC76C867CE3B1A0279D9AD64E9F07AE085D2C40550

Haga clic aquí para obtener un tutorial sobre cómo verificar la integridad del paquete de complemento (recomendado si el paquete de complemento para una nueva instalación no se descargó de https://www.mapsmarker.com; sin embargo, no es necesaria la verificación si se utiliza el proceso de actualización automática)

Notas de actualización adicionales para beta tester

No se requieren pasos adicionales si está actualizando desde una versión beta.

Deja un comentario

XHTML: Puedes usar estas etiquetas: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

en English
X