How to resolve the incompatibility with the Enfold theme by kriesi.at

Update 28. October 2016: the following workaround is not needed anymore if you are using Maps Marker Pro v2.8, Leaflet Maps Marker v3.11 or greater.

The popuplar Enfold theme by kriesi.at enqueues Google javascript on all admin pages, resulting in Google Autocomplete API (=address search) to break. To fix this, you have to completely disable the mapping functionality added by the theme:

open wp-content/themes/enfold/functions.php (respectively the functions.php from your child theme if you are using one) and add the following code at the bottom:

add_filter('avf_load_google_map_api', 'disable_google_map_api', 10, 1);
function disable_google_map_api($load_google_map_api) {
        $load_google_map_api = false;
        return $load_google_map_api;
}

More infos at http://www.kriesi.at/support/topic/google-maps-element-javascript-conflict-with-maps-marker-pro-plugin/

Mark as helpful. 4