情報:これはの変更ログではありません 最新の安定バージョン4.14.3
すべての変更ログを表示

ブートストラップタブとセキュリティ修正をサポートするPro v2.3.1が利用可能です

Maps Marker Proはサーバー上で実行されるため、安全な製品を提供することが非常に重要です。

24時間前に、 アカマイ Maps Marker Proを徹底的にセキュリティレビューし、3つの潜在的なXSS脆弱性を発見した人。 悪用可能性はかなり低いと報告されていましたが、すぐにこのリリースに取り組み始め、これらの問題を修正しました。 責任ある開示については、特にアカマイのチャドに感謝します!

最新バージョンへの更新は、いつものように、そしてこの場合は特に、強くお勧めします。


この新しいリリースについてのご意見をお聞かせください レビューを提出する またはコメントを残してください!

最新のマップマーカー開発について最新情報を入手するには、@をフォローしてください。MapsMarker Twitter(=最新の更新)、 Facebook, Google+の または経由でニュースを購読 RSS または経由 RSS /メール.

また、私たちに参加することを勧めます アフィリエイトプログラム 最大50%のコミッションを提供します。 リセラーになることに興味がある場合は、 https://www.mapsmarker.com/reseller


それでは、プロv2.3.1のその他のハイライトを見てみましょう。

ブートストラップタブにマップを表示するためのサポートを追加

マップは、ブートストラップタブ(およびv1.1.2以降ですでにサポートされているjQuery UIタブ)にロードされたときにも正しく表示されるようになりました。

その他の変更と最適化

  • 最適化されたインストールおよび更新ルーチンスクリプト(必要なデータベースクエリが少ない)

バグの修正

  • によって発見された3つの潜在的なXSS脆弱性 アカマイ –責任ある開示に感謝します!

翻訳の更新

多くのやる気のある貢献者のおかげで、このリリースには以下の翻訳の更新が含まれています。

  • Inge Tangによるノルウェー語(ブークモール)の翻訳、http://drommemila.no
  • エカテリーナゴルビナのおかげでロシア語に翻訳(ソーシャルテクノロジーのテプリツァがサポート) http://te-st.ru)およびVyacheslav Strenadko、http://poi-gorod.ru

翻訳に貢献したい場合(新しいヒンディー語翻訳者を歓迎します!)、 https://translate.mapsmarker.com/projects/lmm 詳細についてはこちら。

翻訳者はその貢献に対しても報酬が支払われることに注意してください。たとえば、翻訳が50%未満で終了した場合、翻訳者は翻訳を25%完了した場合の補償として、149ユーロ相当の100ライセンスパックを無料で受け取ります。

既知の問題点

残念ながら、現在Maps Marker Pro内で直接解決できない問題がXNUMXつあります。

WordPress 4.2では、絵文字のサポートが追加されました。 残念ながら、未解決のバグがあります(細部)Internet Explorerでマップがフリーズしたりクラッシュしたりする可能性があるため、WordPress 4.2、4.2.1、4.2.2が影響を受けます。 関連するtracチケットによると、修正はすでに利用可能で、うまくいけばWordPress 4.2.3でまもなく展開されるでしょう。

WordPress 4.2.3が利用可能になるまでの回避策としては、 絵文字を無効にする 現在のところ、マップはInternet Explorerでも正しく機能します。

この問題については本当に申し訳ありませんが、これは私たちの影響を超えています。WordPressの男性と女性にすでに連絡しており、絵文字/ SVGバグの修正がまもなく利用可能になることを願っています。

Outlook –次のリリースの計画

新機能のリリース日をお約束することはできませんのでご了承ください。 の ロードマップ 主要な新機能については、Maps Marker Proの方向性を示しています。とにかく、最適化とバグ修正を追加できる柔軟性を維持したいだけで、主にユーザーのフィードバックに起因する計画外のマイナーリリースが発生します。

このブログを購読してください(経由 RSS or メールアドレス )または@をフォローMapsMarker 最新の開発ニュースで最新情報を入手したい場合は、twitter(=最新の更新)をご利用ください。

完全な変更ログ

ブートストラップタブにマップを表示するためのサポートを追加
最適化されたインストールおよび更新ルーチンスクリプト(必要なデータベースクエリが少ない)
によって発見された3つの潜在的なXSS脆弱性 アカマイ –責任ある開示に感謝します!
翻訳の更新
翻訳を手伝いたい場合は、 ウェブベースの翻訳プラットフォーム
Inge Tang(http://drommemila.no)のおかげでノルウェー語(ブークモール)の翻訳を更新
Ekaterina Golubinaのおかげで更新されたロシア語翻訳(Social TechnologiesのTeplitsaによるサポート– http://te-st.ru)およびVyacheslav Strenadko、http://poi-gorod.ru
既知の問題点
絵文字の競合が原因で、Internet ExplorerがWordPress 4.2から4.2.2でクラッシュする可能性があります(細部)– WordPress 4.2.3で修正される予定です。WordPress4.2.3が利用可能になるまでの回避策: 絵文字を無効にする

以前の変更ログを表示

ダウンロード/アップデート方法

更新する最も簡単な方法は、WordPressの更新プロセスを使用することです。管理者権限を持つユーザーでログインし、ダッシュボード/更新に移動し、更新するプラグインを選択して、[プラグインの更新]ボタンを押します。 proプラグインは、新しいバージョンが利用可能かどうかを12時間ごとにチェックします。 プラグインに移動し、「Maps Marker Pro」の横にある「手動で更新を確認する」リンクをクリックして、更新チェックを手動でトリガーすることもできます。

手動更新チェック

「アップデートの確認」リンクが表示されておらず、1.7より前のバージョンを使用している場合は、現在のパッケージをからダウンロードして手動でXNUMX回アップデートしてください https://www.mapsmarker.com/download-pro FTP経由でサーバー上の既存のプラグインファイルを上書きします。 これは、古いSSLライブラリを使用するいくつかのホストで必要になる場合があり、Maps Marker Proが安全な接続を確立してmapsmarker.comから更新パッケージを取得するのを妨げます。 Pro v1.7には、これらの種類のサーバーに対する回避策が含まれており、以下のアップデートは通常どおり再び機能します。 影響を受けて助けが必要な場合は、 サポートチケットを開く.

プラグインパッケージの整合性を確認する方法

SHA-256ハッシュ値:

0a182d9736c28763819daf006cc236408a18482c1653bfc9bc8f9522a249a7ef

プラグインパッケージの整合性を確認する方法のチュートリアルについては、ここをクリックしてください (新規インストール用のプラグインパッケージがhttps://www.mapsmarker.comからダウンロードされなかった場合に推奨–自動更新プロセスが使用されている場合は検証は不要です)

ベータテスターの追加アップデートノート

プラグインの更新に追加のアクションは必要ありません。

コメント

XHTML: あなたはこれらのタグを使うことができます: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

en English
X