Pro v2.6.1 with significantly decreased loadtimes for OpenStreetMap-based maps is available

Although we tested v2.6 intensively, some user reported issues immediately after the release last weekend. This was quite frustrating for us in the beginning as we aim to deliver a high quality premium mapping plugin. Anyway after intensive research we found that the main issue was caused by other plugins also loading the Google Maps API which resulted in problems on layer maps.

When searching for a fix, we discovered a great optimization as a sideeffect which will significantly decrease the loadtime of your OpenStreetMap based maps – saving your visitors up to 370kb on each page view with an embedded OpenStreetMap based map.

We hope that this optimization will compensate you for any issues you may have experienced with v2.6 🙂 An update to the latest version is – as always – highly recommended.


이 새로운 릴리스에 대한 의견을 알려주세요. 검토 제출 또는 아래에 의견을 남기십시오!

최신 Maps Marker Pro 개발을 최신 상태로 유지하려면 @MapsMarker 트위터 (= 최신 업데이트) 페이스북, Google+ 를 통해 뉴스를 구독하거나 RSS 또는를 통해 RSS / 이메일.

우리는 또한 당신이 우리를 가입 초대합니다 제휴 프로그램 최대 50 %의 수수료를 제공합니다. 리셀러가되고 싶다면 다음을 방문하십시오. https://www.mapsmarker.com/reseller


이제 프로 v2.6.1의 주요 내용을 살펴 보겠습니다.

OpenStreetMap 기반 맵의로드 시간을 크게 줄였습니다.

If you are using OpenStreetMap or other non-Google-based basemaps for your maps, your maps will now load much faster with v2.6.1. This is achieved by conditional & deferred Google Maps API loading.

This means that the Google Maps API scripts are only loaded if either Google Maps is used as basemap your map or if you switch to a Google basemap in the layer controlbox.

This new loading approach saves your visitors up to ~370kb uncompressed data transmission for each page view with an embedded OpenStreetMap based or other non-Google based basemap. Depending on the internet connection speed of your visitors, this may decrease the loadtime of your page by up to 5 seconds (assumption: ADSL user with 512kbit/s bandwidth, source: http://www.download-time.com/)

This optimization is enabled by default – you just have to upgrade to v2.6.1 to take advantage of this optimization.

다른 변경 및 최적화

  • v2.6에 도입 된 URL 해시는 새 업데이트에 대해 기본적으로 비활성화되어 있습니다.
  • 최적화 된 URL 해시 (startListening을 두 번 호출하는 경우 이벤트를 두 번 등록하지 마십시오)
  • 도구 페이지 / 마커 이동-대량 작업 : 마커를 멀티 레이어 맵에 직접 할당 할 수 없으므로 멀티 레이어 맵이 제외되었습니다 (thx Andres!).
  • 이제 중국어 로케일로 WordPress 설치를 위해 https를 통해 http를 통해서만 Google Maps API를로드합니다 (중국에서 https의 성능 문제가보고 됨)
  • ID 오름차순으로 레이어 편집 페이지에서 멀티 레이어 맵 선택을위한 "마커 목록"정렬

버그 수정

  • “used in content” warnings if special widget configurations were used
  • occassionally wrong “used in content”-results linking to contents where shortcode is not used (thx Hans-Georg!)
  • 일부 장치에서는 반응 형 테이블이 올바르게 표시되지 않았습니다 (절대 너비 대신 상대 열)
  • 마커 편집 페이지 대신 레이어 편집 페이지에 연결된 전체 화면 맵의 마커 편집 링크
  • 다른 플러그인이나 테마에도 Google Maps API가 포함 된 경우 레이어 맵이 최근에 깨질 수 있음
  • marker count for multi-layer-maps on “list all layers”-page was broken
  • 마커 편집 페이지의 마커 복제 버튼이 할당 된 레이어를 복제하지 않았지만 레이어에서 마커를 할당하지 않았습니다.
  • v4.7에 도입 된 "WPBakery Visual Composer"플러그인 v2.6 +에 대한 수정이 모든 사이트에서 올바르게 작동하지 않습니다
  • 레이어 맵에 대한 대량 작업으로 하위 레이어에서 마커를 삭제하거나 다시 할당하지 않았습니다.
  • Web API: assigned markers are not deleted or re-assigned if using delete action for layer maps

번역 업데이트

많은 동기를 부여한 기여자 덕분에이 릴리스에는 다음과 같은 업데이트 된 번역이 포함됩니다.

번역에 공헌하고 싶다면 (새로운 힌디어 번역가에게 감사 할 것입니다!) https://translate.mapsmarker.com/projects/lmm 문의주시기 바랍니다.

예를 들어 번역이 50 % 미만으로 완료된 경우 번역가는 번역을 25 %로 완료 한 것에 대한 보상으로 € 149에 해당하는 100 개의 라이센스 팩을 무료로받습니다.

Outlook – 다음 릴리스 계획

새로운 기능에 대한 출시 날짜는 약속하지 않습니다. 그만큼 로드맵 새로운 주요 기능의 경우 Maps Marker Pro가 어디로 향하고 있는지 알 수 있습니다. 어쨌든 대부분 사용자 피드백에서 비롯된 계획되지 않은 마이너 버전으로 최적화 및 버그 수정을 추가 할 수있는 유연성을 유지하려고합니다.

이 블로그를 통해 구독하십시오 RSS or 이메일) 또는 @MapsMarker 최신 개발 뉴스를 최신 상태로 유지하려면 Twitter (= 최신 업데이트)를 사용하십시오.

전체 변경 내역

조건부 및 지연된 Google Maps API 로딩을 지원하여 OpenStreetMap 기반 맵의로드 시간을 크게 줄였습니다 (~ 370kb (!) 적은 비 압축 데이터 전송)
v2.6에 도입 된 URL 해시는 새 업데이트에 대해 기본적으로 비활성화되어 있습니다.
최적화 된 URL 해시 (startListening을 두 번 호출하는 경우 이벤트를 두 번 등록하지 마십시오)
도구 페이지 / 마커 이동-대량 작업 : 마커를 멀티 레이어 맵에 직접 할당 할 수 없으므로 멀티 레이어 맵이 제외되었습니다 (thx Andres!).
이제 중국어 로케일로 WordPress 설치를 위해 https를 통해 http를 통해서만 Google Maps API를로드합니다 (중국에서 https의 성능 문제가보고 됨)
ID 오름차순으로 레이어 편집 페이지에서 멀티 레이어 맵 선택을위한 "마커 목록"정렬
“used in content” warnings if special widget configurations were used
occassionally wrong “used in content”-results linking to contents where shortcode is not used (thx Hans-Georg!)
일부 장치에서는 반응 형 테이블이 올바르게 표시되지 않았습니다 (절대 너비 대신 상대 열)
마커 편집 페이지 대신 레이어 편집 페이지에 연결된 전체 화면 맵의 마커 편집 링크
다른 플러그인이나 테마에도 Google Maps API가 포함 된 경우 레이어 맵이 최근에 깨질 수 있음
marker count for multi-layer-maps on “list all layers”-page was broken
마커 편집 페이지의 마커 복제 버튼이 할당 된 레이어를 복제하지 않았지만 레이어에서 마커를 할당하지 않았습니다.
v4.7에 도입 된 "WPBakery Visual Composer"플러그인 v2.6 +에 대한 수정이 모든 사이트에서 올바르게 작동하지 않습니다
레이어 맵에 대한 대량 작업으로 하위 레이어에서 마커를 삭제하거나 다시 할당하지 않았습니다.
Web API: assigned markers are not deleted or re-assigned if using delete action for layer maps
번역 업데이트
번역에 도움이 필요하면 웹 기반 번역 플랫폼
독일어 번역 업데이트
Ekaterina Golubina 덕분에 러시아어 번역 업데이트 (Teplitsa of Social Technologies – http://te-st.ru) 및 Vyacheslav Strenadko, http://slavblog.ru
Olof Odier http://www.historiskastadsvandringar.se, Tedy Warsitha http://codeorig.in/, Dan Paulsson 덕분에 스웨덴어 번역 업데이트 http://www.paulsson.eu린드그렌 엘거 http://bilddigital.se Anton Andreasson과 http://andreasson.org/

이전 변경 내역 표시

다운로드 / 업데이트 방법

업데이트하는 가장 쉬운 방법은 WordPress 업데이트 프로세스를 사용하는 것입니다. 관리자 권한이있는 사용자로 로그인하고 대시 보드 / 업데이트로 이동 한 후 업데이트 할 플러그인을 선택하고 "플러그인 업데이트"버튼을 누릅니다. 새 버전을 사용할 수 있으면 프로 플러그인에서 12 시간마다 확인합니다. 플러그인으로 이동하여 "Maps Marker Pro"옆에있는 "수동으로 업데이트 확인"링크를 클릭하여 업데이트 확인을 수동으로 트리거 할 수도 있습니다.

수동 업데이트 확인

"업데이트 확인"링크가 표시되지 않고 1.7 미만의 버전을 사용중인 경우 현재 패키지를 다운로드하여 수동으로 한 번 업데이트하십시오. https://www.mapsmarker.com/download-pro FTP를 통해 서버의 기존 플러그인 파일을 덮어 씁니다. 이는 오래된 SSL 라이브러리를 사용하는 여러 호스트에서 필요할 수 있으며, 이로 인해 Maps Marker Pro가 mapsmarker.com에서 업데이트 패키지를 검색하기 위해 보안 연결을 설정할 수 없습니다. Pro v1.7에는 이러한 종류의 서버에 대한 해결 방법이 포함되어 있으며 다음 업데이트는 평소와 같이 다시 작동해야합니다. 영향을 받고 도움이 필요하면 지원 티켓을여십시오..

플러그인 패키지의 무결성을 확인하는 방법

SHA-256 해시 값 :

B2CB348D5DA5F56FC1ABE0A8B1682A7F30341D988C58315008FDFD67BD671AC7

플러그인 패키지의 무결성을 확인하는 방법에 대한 자습서를 보려면 여기를 클릭하십시오 (새 설치용 플러그인 패키지가 https://www.mapsmarker.com에서 다운로드되지 않은 경우 권장 됨 – 자동 업데이트 프로세스를 사용하는 경우 확인이 필요하지 않습니다)

베타 테스터에 대한 추가 업데이트 정보

베타 릴리스에서이 최종 릴리스로 업데이트 할 때 추가 조치가 필요하지 않습니다.

코멘트를 남겨

XHTML : 다음 태그를 사용할 수 있습니다. <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

en English
X