특이한 WordPress 설정을위한 Pro v3.0.1 호환 릴리스를 사용할 수 있습니다

Pro v3.0.1은 v에 도입 된 퍼머 링크 기능에 대한 호환성 확인 및 호환성 옵션을 추가 한 호환성 릴리스입니다.3.0비정상적인 WordPress 설정에 문제가 발생할 수 있습니다.

항상 최신 버전으로 업데이트하는 것이 좋습니다. 이 릴리스에 대한 자세한 내용은 아래를 참조하십시오.


이 새로운 릴리스에 대한 의견을 알려주세요. 검토 제출 또는 아래에 의견을 남기십시오!

최신 Maps Marker Pro 개발을 최신 상태로 유지하려면 @MapsMarker 트위터 (= 최신 업데이트) 페이스북, Google+ 를 통해 뉴스를 구독하거나 RSS 또는를 통해 RSS / 이메일.

우리는 또한 당신이 우리를 가입 초대합니다 제휴 프로그램 최대 50 %의 수수료를 제공합니다. 리셀러가되고 싶다면 다음을 방문하십시오. https://www.mapsmarker.com/reseller


이제 프로 v3.0.1의 주요 내용을 살펴 보겠습니다.

비정상적인 WordPress 설정을 지원하고 잠재적 인 구성 오류를 수정하기위한 퍼머 링크 호환성 검사 및 기본 URL 옵션

v3.0에서는 전체 화면 맵 및 API 엔드 포인트에 대한 꽤 영구적 인 링크 지원이 추가되었습니다. 예를 들어 마커 ID 1의 전체 화면보기는 이제 https://www.mapsmarker.com/maps/fullscreen/marker/1/을 통해 액세스 할 수 있습니다. https://www.mapsmarker.com/wp-content/plugin/leaflet-maps-marker-pro/leaflet-fullscreen.php?marker=1 슬러그 지도 설정 / 기타 / 워드 프레스 통합 설정 / 옵션 "Permalinks slug"를 통해 사용자 지정할 수도 있습니다.

안타깝게도 베타 버전 및 릴리스 테스트에는 사용자 사이트의 퍼머 링크 구성에 대한 비정상적인 설정 및 일반적인 문제가 포함되지 않아 소수의 사용자가 퍼머 링크가 끊어졌습니다.

v3.0.1에서는 비정상적인 WordPress 설정이 사용되거나 잠재적 인 구성 오류가있는 경우 경고를 표시하는 호환성 검사가 추가되었습니다.

경고의 링크는 설정 / 기타 / 호환성 설정에있는 새로운 호환성 옵션 "Permalink base URL"로 연결됩니다.

이 경고가 표시되고 사이트가 영향을받는 경우 (예 : 마커가 레이어 맵에 표시되지 않음) 여기에 WordPress 폴더의 URL을 입력하고 설정을 저장하십시오. 경고가 계속 나타나면, 제발 지원 티켓을여십시오. 우리에게 도움을 청합니다.

알려진 문제

https를 통해 사이트에 안전하게 액세스하지 않으면 Chrome 50 이상 및 Safari 10 이상에서 위치 정보 기능이 더 이상 작동하지 않습니다.

Chrome 50 (및 Safari 10)을 사용하면 관련 브라우저 공급 업체에서 지리적 위치 지원에 대한 중요한 변경 사항을 도입했습니다. 사용자의 현재 위치를 요청하는 모든 응용 프로그램 (Maps Marker Pro의 지리적 위치 기능이 아닌)은 더 이상 사이트가 https를 통해 안전하게 전달되도록 설정된 경우 사용자의 현재 위치 – 대신 다음과 유사한 경고가 표시됩니다.

지리적 위치 오류 정보

Google의이 결정에 대한 자세한 내용은 https://developers.google.com/web/updates/2016/04/geolocation-on-secure-contexts-only. 사용자가 Firefox와 같은 대체 브라우저를 통해 사이트에 액세스하는 경우에도 비 https 사이트에서 위치 정보가 작동합니다. 원정 여행 또는 Internet Explorer – 어쨌든 해당 브라우저도 향후 유사한 보안 제한을 추가 할 수 있습니다.

2016 년 10 월 업데이트 : iOS 10부터 Safari XNUMX 이상부터 위치 정보를 지원하려면 https가 필요합니다. 구현은 Chrome보다 훨씬 더 엄격합니다. 예를 들어 사이트에 혼합 콘텐츠 경고가있는 경우 지리적 위치 정보가 작동하지 않습니다.

따라서 사이트에 Maps Marker Pro 지리적 위치 기능이 필요한 경우 사이트를 https로 마이그레이션하는 것이 좋습니다. 일부 호스트는 이미 무료 https 인증서를 제공합니다. letsencrypt.org 예를 들어. https를 지원하도록 WordPress 사이트 내에서 구성을 구성하려면 다음과 같은 자습서를 살펴보십시오. https://css-tricks.com/moving-to-https-on-wordpress/.

https는 Google 크롬 50 이상 및 Safari 10 이상에서 다시 작동하는 지리적 위치 (데이터 무결성, 발신자 인증 및 사용자 개인 정보 보호, https가 순위 신호로 사용되는 Google 순위 상승 등)보다 사이트에 더 많은 이점을 제공하므로 아직하지 않은 경우에만 사이트를 https로 전환하는 것이 좋습니다.

사이트를 https로 전환 했는데도 여전히 지리적 위치 오류 (예 : "지역 위치 오류 : 사용자 거부 지리적 위치")가 발생하는 경우 앱 / 웹 사이트가 지리적 위치를 검색하도록 허용 된 경우 장치의 위치 설정을 확인하십시오.

번역 업데이트

또한 https://translate.mapsmarker.com의 Glotpress 인스턴스를 v2.3.1로 업데이트하여 번역자가 번역을 사용자가 퍼지하고 다시 활성화 한 암호 재설정, 디자인 업데이트 등으로 표시 할 수 있도록했습니다.

많은 동기를 부여한 기여자 덕분에이 릴리스에는 다음과 같은 업데이트 된 번역이 포함됩니다.

번역에 공헌하고 싶다면 (새로운 힌디어 번역가에게 감사 할 것입니다!) https://translate.mapsmarker.com/projects/lmm 문의주시기 바랍니다.

예를 들어 번역이 50 % 미만으로 완료된 경우 번역가는 번역을 25 %로 완료 한 것에 대한 보상으로 € 249에 해당하는 100 개의 라이센스 팩을 무료로받습니다.

Outlook – 다음 릴리스 계획

새로운 기능에 대한 출시 날짜는 약속하지 않습니다. 우리는 사용자의 의견에 따라 로드맵을 동적으로 조정하고 있습니다. 어쨌든 우리는 대부분 사용자 피드백에서 비롯된 계획되지 않은 부 릴리스로 최적화 및 버그 수정을 추가 할 수있는 유연성을 유지합니다.

이 블로그를 통해 구독하십시오 RSS or 이메일) 또는 @MapsMarker 최신 개발 뉴스를 최신 상태로 유지하려면 Twitter (= 최신 업데이트)를 사용하십시오.

전체 변경 내역

비정상적인 WordPress 설정을 지원하고 잠재적 인 구성 오류를 수정하기위한 퍼머 링크 호환성 검사 및 기본 URL 옵션
번역 업데이트
번역에 도움이 필요하면 웹 기반 번역 플랫폼
John Shen 덕분에 중국어 번역 업데이트, http://www.synyan.net 그리고 ck
Thorsten 덕분에 독일어 번역 업데이트
알려진 문제
https를 통해 사이트에 안전하게 액세스 할 수 없으면 Chrome 50 이상 및 iOS / Safari 10 이상에서 위치 정보 기능이 더 이상 작동하지 않습니다 (세부설명)

사용 가능한 모든 변경 로그 표시

다운로드 / 업데이트 방법

업데이트하는 가장 쉬운 방법은 WordPress 업데이트 프로세스를 사용하는 것입니다. 관리자 권한이있는 사용자로 로그인하고 대시 보드 / 업데이트로 이동 한 후 업데이트 할 플러그인을 선택하고 "플러그인 업데이트"버튼을 누릅니다. 새 버전을 사용할 수 있으면 프로 플러그인에서 24 시간마다 확인합니다. 플러그인으로 이동하여 "Maps Marker Pro"옆에있는 "수동으로 업데이트 확인"링크를 클릭하여 업데이트 확인을 수동으로 트리거 할 수도 있습니다.

수동 업데이트 확인

"업데이트 확인"링크가 표시되지 않고 1.7 미만의 버전을 사용중인 경우 현재 패키지를 다운로드하여 수동으로 한 번 업데이트하십시오. https://www.mapsmarker.com/download-pro FTP를 통해 서버의 기존 플러그인 파일을 덮어 씁니다. 이는 오래된 SSL 라이브러리를 사용하는 여러 호스트에서 필요할 수 있으며, 이로 인해 Maps Marker Pro가 mapsmarker.com에서 업데이트 패키지를 검색하기 위해 보안 연결을 설정할 수 없습니다. Pro v1.7에는 이러한 종류의 서버에 대한 해결 방법이 포함되어 있으며 다음 업데이트는 평소와 같이 다시 작동해야합니다. 영향을 받고 도움이 필요하면 지원 티켓을여십시오..

플러그인 패키지의 무결성을 확인하는 방법

SHA-256 해시 값 :

A125D1A97D27CDBC848A8E4CFFE8F59D35772795713EDB680B8BE9D16D34E873

파일 수 : 511

플러그인 패키지의 무결성을 확인하는 방법에 대한 자습서를 보려면 여기를 클릭하십시오 (새 설치용 플러그인 패키지가 https://www.mapsmarker.com에서 다운로드되지 않은 경우 권장 됨 – 자동 업데이트 프로세스를 사용하는 경우 확인이 필요하지 않습니다)

파일 수 : 511

베타 테스터에 대한 추가 업데이트 정보

베타에서 최종 버전으로의 플러그인 업데이트에 대한 추가 조치는 필요하지 않습니다.

코멘트를 남겨

XHTML : 다음 태그를 사용할 수 있습니다. <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

en English
X