Info: dette er ikke endringsloggen for siste stabile versjon 4.13.1
se alle skiftelogger

Pro v2.3.1 med støtte for bootstrap-faner og sikkerhetsrettinger er tilgjengelig

Når Maps Marker Pro kjører på serveren din, er det veldig viktig for oss å levere et sikkert produkt.

For 24 timer siden ble vi kontaktet av Akamai som utførte en intensiv sikkerhetsgjennomgang av Maps Marker Pro og fant 3 potensielle XSS-sårbarheter. Selv om utnyttbarheten ble rapportert å være ganske lav, begynte vi umiddelbart å jobbe med denne utgivelsen og fikse disse problemene. Tusen takk spesielt til Chad fra Akamai for den ansvarlige avsløringen!

En oppdatering til den nyeste versjonen er - som alltid og spesielt i dette tilfellet - sterkt anbefalt.


La oss få vite hva du synes om denne nye utgivelsen av sende inn en anmeldelse eller legge igjen en kommentar nedenfor!

Hvis du vil holde deg oppdatert med den siste Maps Marker-utviklingen, følg @MapsMarker på twitter (= siste oppdateringer), på Facebook , Google+ eller abonner på nyheter via RSS eller via RSS / e-post.

Vi vil også invitere deg til å bli med på vår affiliate program som tilbyr provisjoner opptil 50%. Hvis du er interessert i å bli forhandler, kan du gå til https://www.mapsmarker.com/reseller


La oss nå komme til de andre høydepunktene i pro v2.3.1:

legg til støtte for å vise kart i bootstrap-fanene

Kart vises nå også på riktig måte når de lastes i bootstrap-faner (samt jQuery UI-faner som allerede er støttet siden v1.1.2).

Andre endringer og optimaliseringer

  • optimalisert installasjons- og oppdateringsrutineskript (mindre databaseforespørsler nødvendig)

Feilrettinger

  • 3 potensielle XSS-sårbarheter oppdaget av Akamai - mange takk for ansvarlig avsløring!

Oversettelser oppdateres

Takket være mange motiverte bidragsytere inkluderer denne utgivelsen oppdateringer til følgende oversettelser:

  • Norsk (bokmål) oversettelse takket være Inge Tang, http://drommemila.no
  • Russisk oversettelse takket være Ekaterina Golubina (støttet av Teplitsa fra Social Technologies - http://te-st.ru) og Vyacheslav Strenadko, http://poi-gorod.ru

Hvis du vil bidra til oversettelser (nye hindi-oversettere vil bli satt pris på!), Vennligst besøk https://translate.mapsmarker.com/projects/lmm for mer informasjon.

Vær oppmerksom på at oversetterne også blir kompensert for deres bidrag - for eksempel hvis en oversettelse er ferdig mindre enn 50%, får oversetteren en gratis pakke på 25 lisenser til en verdi av € 149 som kompensasjon for å fullføre oversettelsen til 100%.

Kjente problemer

Dessverre er det for øyeblikket ett problem som ikke kan løses direkte i Maps Marker Pro:

Med WordPress 4.2 ble Emoji-støtte lagt til. Dessverre er det en åpen feil (detaljer) som kan føre til frosne kart eller krasjer på Internet Explorer - så WordPress 4.2, 4.2.1 og 4.2.2 blir berørt. I henhold til den relaterte sporingsbilletten er en reparasjon allerede tilgjengelig og vil forhåpentligvis bli distribuert snart med WordPress 4.2.3.

Som løsning til WordPress 4.2.3 er tilgjengelig, kan du bare deaktiver Emojis for øyeblikket for at kart også fungerer som de skal i Internet Explorer.

Vi beklager dette problemet, men dette er utenfor vår innflytelse - vi kontaktet allerede gutta og damene på WordPress og håper at løsningen for Emoji / SVG-feilen snart vil være tilgjengelig.

Outlook - planer for de neste utgivelsene

Vær oppmerksom på at vi ikke kan love noen utgivelsesdatoer for nye funksjoner. De veikart for viktige nye funksjoner gir deg en ide hvor Maps Marker Pro er på vei - uansett vil vi bare beholde fleksibiliteten til å legge til optimaliseringer og bugfixes med ganske ikke planlagte mindre utgivelser som hovedsakelig skyldes tilbakemeldinger fra brukerne.

Abonner på denne bloggen (via RSS or E-post) eller følg @MapsMarker på twitter (= mest aktuelle oppdateringer) hvis du vil holde deg oppdatert med de siste utviklingsnyhetene.

Full changelog

legg til støtte for å vise kart i bootstrap-fanene
optimalisert installasjons- og oppdateringsrutineskript (mindre databaseforespørsler nødvendig)
3 potensielle XSS-sårbarheter oppdaget av Akamai - mange takk for ansvarlig avsløring!
Oversettelsesoppdateringer
Hvis du vil hjelpe med oversettelser, kan du gå til nettbasert oversettelsesplattform
oppdatert norsk (bokmål) oversettelse takket være Inge Tang, http://drommemila.no
oppdatert russisk oversettelse takket være Ekaterina Golubina (støttet av Teplitsa fra Social Technologies - http://te-st.ru) og Vyacheslav Strenadko, http://poi-gorod.ru
Kjente problemer
Internet Explorer kan krasje med WordPress 4.2 til 4.2.2 på grunn av Emoji-konflikt (detaljer) - planlagt å bli løst med WordPress 4.2.3, midlertidig løsning til WordPress 4.2.3 er tilgjengelig: deaktiver Emojis

vis tidligere veksler

Hvordan laste ned / oppdatere

Den enkleste måten å oppdatere er å bruke WordPress-oppdateringsprosessen: logg inn med en bruker som har administratorrettigheter, naviger til Dashboard / Updates, velg plugins som skal oppdateres og trykk på knappen “Update Plugins”. Pro-plugin sjekker hver 12. time om en ny versjon er tilgjengelig. Du kan også utløse oppdateringssjekken manuelt ved å gå til Plugins og klikke på lenken "Manuelt se etter oppdateringer" ved siden av "Maps Marker Pro":

manual-update-sjekk

Hvis du ikke ser lenken "Sjekk etter oppdateringer" og bruker en versjon under 1.7, må du oppdatere manuelt en gang ved å laste ned gjeldende pakke fra https://www.mapsmarker.com/download-pro og overskrive eksisterende plugin-filer på serveren din via FTP. Dette kan være nødvendig på flere verter, som bruker utdaterte SSL-biblioteker, som forhindrer Maps Marker Pro i å opprette en sikker forbindelse for å hente oppdateringspakken fra mapsmarker.com. Pro v1.7 inkluderer en løsning for den typen servere, og følgende oppdateringer skal fungere som vanlig. Hvis du er berørt og trenger hjelp, vær så snill åpne en støtte billett.

Slik bekrefter du integriteten til plugin-pakken

SHA-256 hashverdi:

0a182d9736c28763819daf006cc236408a18482c1653bfc9bc8f9522a249a7ef

Klikk her for en veiledning for å bekrefte integriteten til plugin-pakken (anbefales hvis plugin-pakken for en ny installasjon ikke ble lastet ned fra https://www.mapsmarker.com - bekreftelse er ikke nødvendig, men hvis den automatiske oppdateringsprosessen brukes)

Ytterligere oppdateringsnotater for betatester

Ingen ekstra handling på plugin-oppdatering kreves.

Legg igjen en kommentar

XHTML: Du kan bruke disse kodene: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

en English
X