Info: dette er ikke endringsloggen for siste stabile versjon 4.13.1
se alle skiftelogger

Pro v2.4 med støtte for tilordning av markører til flere lag og oversettelsesoppdateringer er tilgjengelig

Det er jeg glad for å kunngjøre Waseem Senjer som allerede har hjulpet meg med kodingsproblemer i det siste, og som har hjulpet kunder med tilpassede utviklingskrav som involverer Maps Marker Pro, tar nå en mer aktiv rolle i den fremtidige utviklingen - velkommen til teamet! Vi håper å kunne få nye utgivelser raskere som et resultat, og vil ha flere ressurser til å jobbe med funksjoner som har vært på veikartet i lang tid.

Maps Marker Pro v2.4 som Waseem allerede ledet som hovedutvikler, legger til den ofte etterspurte funksjonen for å kunne legge til en markør i flere lag samtidig - vær oppmerksom på at det er noen ødelagte endringer som må vurderes hvis du bruker GeoJSON-utgang av lagkart rett utenfor Maps Marker Pro-miljøet. Vennligst les detailled changelog for mer informasjon.

En oppdatering til den nyeste versjonen er - som alltid - sterkt anbefalt.


La oss få vite hva du synes om denne nye utgivelsen av sende inn en anmeldelse eller legge igjen en kommentar nedenfor!

Hvis du vil holde deg oppdatert med den siste Maps Marker Pro-utviklingen, følg @MapsMarker på twitter (= siste oppdateringer), på Facebook , Google+ eller abonner på nyheter via RSS eller via RSS / e-post.

Vi vil også invitere deg til å bli med på vår affiliate program som tilbyr provisjoner opptil 50%. Hvis du er interessert i å bli forhandler, kan du gå til https://www.mapsmarker.com/reseller


La oss nå komme til de andre høydepunktene i pro v2.4:

tilordne markører til flere lag

Du kan nå tilordne en markør til flere lag:

pro-feature-multi-layer-oppdrag

En databaseoppdatering vil automatisk bli laget for å støtte disse endringssparende lagrede tildelte lagene som JSON-kodet streng i wp_leafletmapsmarker_markers i stedet for en heltallverdi. Vær oppmerksom på at følgende APIer også har endret seg som resultat, og i tilfelle du bygde en tilpasset dev på de APIene, kan det hende du må tilpasse koden din:

GeoJSON-utgang for markørkart:

Utgangen til de tildelte lagene for markørkart måtte endres for å levere en gyldig JSON-fil:

Før v2.4:

GeoJSON-før

Etter v2.4:

GeoJSON-markør

Maps Marker API:

Import / eksportfunksjonen støtter nå også å legge til markører i flere lag - bare legg til lagene du vil tilordne en markør til som komma-separerte verdier for parameterlaget i API-forespørselen (f.eks. ... & lag = 1,2,3)

Vær også oppmerksom på at JSON som blir vist om API-forespørselen er blitt laget, nå også vurderer de strukturelle endringene fra GeoJSON-eksemplet ovenfor.

Import / Export-funksjonen

Import / eksportfunksjonen støtter nå også å legge til markører i flere lag - bare legg til lagene du vil tilordne en markør til som komma-separerte verdier i kolonnelaget (f.eks. 1,2,3)

alternativet for å skjule lenken “last ned GPX-fil” i GPX-panelet

Som anmodet av noen kunder, legger v2.4 til et nytt alternativ som lar deg fjerne koblingen "last ned GPX-fil" fra GPX-panelet. Dette alternativet er aktivert som standard og kan finnes i Innstillinger / Kartdefaults / “GPX sporinnstillinger”:

gpx-download-alternativ

alternativet for å velge markører fra flere lag når du eksporterer til XLSX / XLS / CSV / ODS

Eksportfunksjonen støtter nå også valg av markører fra flere lag:

eksport-flere-sjikt

multisite: alternativ for å aktivere lisensnøkkel på tilpassede domener

Som forespurt av kunder som bruker WordPress multisite, kan du nå velge hvilket domene du vil aktivere for lisensnøkkelen din:

multisite-domene-aktivering

Dette fjerner behovet for å åpne en supportbillett for å legge til et tilpasset domene i listen over gyldige lisensforekomster, hvis WordPress-nettstedene kjøres på et annet domene enn WordPress Multisite-forekomsten. Husk også at etter at du har aktivert det egendefinerte domenet, vil du fortsatt måtte bruke "propagand License" -funksjonen for å synkronisere den nye lisensinformasjonen med underlagene dine:

multisite-forplantning

Andre endringer og optimaliseringer

  • støtte for visning av MaqQuest basemaps via https (thx Duncan!)
  • legg til gpx_url og gpx_panel til GeoJSON-utdata for markører og lag
  • kompatibilitetssjekk for Autoptimize plugin som kan bryte kart hvis den ikke er riktig konfigurert
  • forbedrede eksempler for å tilpasse stylingsalternativer for geolocation (thx Bart!)
  • Visualead API for å lage QR-koder bruker nå sikre https som standard

Feilrettinger

  • forvrengt minimap-kontrollboksikon hvis CSS-boksstørrelse ble brukt på alle elementer av temaer som fold
  • XML-utdata for søkeresultater via MapsMarker API var ikke gyldig
  • QR-kodebufferbilde for lag ble ikke slettet via API
  • XLSX-importør for markøroppdateringer: hvis lagsett ikke eksisterer, ble verdien satt til ikke tilordnet i stedet for nåværende verdi
  • fikse kompatibilitet for WordPress-installasjoner ved bruk av HHVM (thx Rolf!)
  • uønskede linebreaks henholdsvis ødelagte kortkoder i popuptexter på layermaps (takk CJ!)

Oversettelser oppdateres

Takket være mange motiverte bidragsytere inkluderer denne utgivelsen oppdateringer til følgende nye oversettelser:

I tillegg har også følgende oversettelser blitt oppdatert:

Hvis du vil bidra til oversettelser (nye hindi-oversettere vil bli satt pris på!), Vennligst besøk https://translate.mapsmarker.com/projects/lmm for mer informasjon.

Vær oppmerksom på at oversetterne også blir kompensert for deres bidrag - for eksempel hvis en oversettelse er ferdig mindre enn 50%, får oversetteren en gratis pakke på 25 lisenser til en verdi av € 149 som kompensasjon for å fullføre oversettelsen til 100%.

Kjente problemer

Dessverre er det for øyeblikket ett problem som ikke kan løses direkte i Maps Marker Pro:

Med WordPress 4.2 ble Emoji-støtte lagt til. Dessverre er det en åpen feil (detaljer) som kan føre til frosne kart eller krasjer på Internet Explorer - så WordPress 4.2, 4.2.1 og 4.2.2 blir berørt. I følge den relaterte sporingsbilletten er en reparasjon allerede tilgjengelig og vil forhåpentligvis bli distribuert snart med WordPress 4.2.3 og 4.3.

Som en løsning inntil WordPress 4.2.3 eller 4.3 er tilgjengelig, kan du bare deaktiver Emojis for øyeblikket for at kart også fungerer som de skal i Internet Explorer.

Vi beklager dette problemet, men dette er utenfor vår innflytelse - vi kontaktet allerede gutta og damene på WordPress og håper at løsningen for Emoji / SVG-feilen snart vil være tilgjengelig.

Outlook - planer for de neste utgivelsene

Vær oppmerksom på at vi ikke kan love noen utgivelsesdatoer for nye funksjoner. De veikart for viktige nye funksjoner gir deg en ide hvor Maps Marker Pro er på vei - uansett vil vi bare beholde fleksibiliteten til å legge til optimaliseringer og bugfixes med ganske ikke planlagte mindre utgivelser som hovedsakelig skyldes tilbakemeldinger fra brukerne.

Abonner på denne bloggen (via RSS or E-post) eller følg @MapsMarker på twitter (= mest aktuelle oppdateringer) hvis du vil holde deg oppdatert med de siste utviklingsnyhetene.

Full changelog

tilordne markører til flere lag (thx Waseem!)
støtte for visning av MaqQuest basemaps via https (thx Duncan!)
alternativet for å skjule lenken “last ned GPX-fil” i GPX-panelet
legg til gpx_url og gpx_panel til GeoJSON-utdata for markører og lag
alternativet for å velge markører fra flere lag når du eksporterer til XLSX / XLS / CSV / ODS
kompatibilitetssjekk for Autoptimize plugin som kan bryte kart hvis den ikke er riktig konfigurert
multisite: alternativ for å aktivere lisensnøkkel på tilpassede domener
forbedrede eksempler for å tilpasse stylingsalternativer for geolocation (thx Bart!)
Visualead API for å lage QR-koder bruker nå sikre https som standard
forvrengt minimap-kontrollboksikon hvis CSS-boksstørrelse ble brukt på alle elementer av temaer som fold
XML-utdata for søkeresultater via MapsMarker API var ikke gyldig
QR-kodebufferbilde for lag ble ikke slettet via API
XLSX-importør for markøroppdateringer: hvis lagsett ikke eksisterer, ble verdien satt til ikke tilordnet i stedet for nåværende verdi
fikse kompatibilitet for WordPress-installasjoner ved bruk av HHVM (thx Rolf!)
uønskede linebreaks henholdsvis ødelagte kortkoder i popuptexter på layermaps (takk CJ!)
Oversettelsesoppdateringer
Hvis du vil hjelpe med oversettelser, kan du gå til nettbasert oversettelsesplattform
Afrikansk (af) oversettelse takket være Hans, http://bmarksa.org/nuus/
Arabisk (ar) oversettelse takket være Abdelouali Benkheil, Aladdin Alhamda - http://bazarsy.com, Nedal Elghamry - http://arabhosters.com, yassin og Abdelouali Benkheil - http://www.benkh.be
Finsk (fi_FI) oversettelse takket være Jessi Björk - @jessibjork
Gresk (el) oversettelse takket være Philios Sazeides - http://www.mapdow.com, Evangelos Athanasiadis - http://www.wpmania.gr og Vardis Vavoulakis - http://avakon.com
Hebraisk (he_IL) oversettelse takket være Alon Gilad - http://pluto2go.co.il og kobi levi
Litauisk (lt_LT) oversettelse takket være Donatas Liaudaitis - http://www.transleta.co.uk
Thai (th) oversettelse takket være Makarapong Chathamma og Panupong Siriwichayakul - http://siteprogroup.com/
Uighur (ug) oversettelse takket være Yidayet Begzad - http://ug.wordpress.org/
oppdatert tsjekkisk oversettelse takket være Viktor Kleiner og Vlad Kuzba, http://kuzbici.eu
oppdatert galisisk oversettelse takket være Fernando Coello, http://www.indicepublicidad.com
oppdatert tysk oversettelse
oppdaterte japanske oversettelser takket være Shu Higash
oppdatert latvisk oversettelse takket være Juris Orlovs, http://lbpa.lv og Eriks Remess http://geekli.st/Eriks
oppdatert norsk (bokmål) oversettelse takket være Inge Tang, http://drommemila.no
oppdatert rumensk oversettelse takket være Arian, http://administrare-cantine.ro, Daniel Codrea, http://www.inadcod.com og Flo Bejgu, http://www.inboxtranslation.com
oppdatert russisk oversettelse takket være Ekaterina Golubina (støttet av Teplitsa fra Social Technologies - http://te-st.ru) og Vyacheslav Strenadko, http://poi-gorod.ru
oppdatert spansk oversettelse takket være David Ramírez, http://www.hiperterminal.com, Alvaro Lara, http://www.alvarolara.com, Victor Guevara, http://1sistemas.net, Ricardo Viteri, http://www.labviteri.com og Juan Valdes
oppdatert spansk / Mexico-oversettelse takket være Victor Guevera, http://1sistemas.net og Eze Lazcano
oppdatert svensk oversettelse takket være Olof Odier http://www.historiskastadsvandringar.se, Tedy Warsitha http://codeorig.in/, Dan Paulsson http://www.paulsson.eu, Elger Lindgren, http://20x.se og Anton Andreasson, http://andreasson.org/
Kjente problemer
Internet Explorer kan krasje med WordPress 4.2 til 4.2.2 på grunn av Emoji-konflikt (detaljer) - planlagt å bli løst med WordPress 4.2.3 & 4.3, midlertidig løsning til WordPress 4.2.3 & 4.3 er tilgjengelig: deaktiver Emojis

vis tidligere veksler

Hvordan laste ned / oppdatere

Den enkleste måten å oppdatere er å bruke WordPress-oppdateringsprosessen: logg inn med en bruker som har administratorrettigheter, naviger til Dashboard / Updates, velg plugins som skal oppdateres og trykk på knappen “Update Plugins”. Pro-plugin sjekker hver 12. time om en ny versjon er tilgjengelig. Du kan også utløse oppdateringssjekken manuelt ved å gå til Plugins og klikke på lenken "Manuelt se etter oppdateringer" ved siden av "Maps Marker Pro":

manual-update-sjekk

Hvis du ikke ser lenken "Sjekk etter oppdateringer" og bruker en versjon under 1.7, må du oppdatere manuelt en gang ved å laste ned gjeldende pakke fra https://www.mapsmarker.com/download-pro og overskrive eksisterende plugin-filer på serveren din via FTP. Dette kan være nødvendig på flere verter, som bruker utdaterte SSL-biblioteker, som forhindrer Maps Marker Pro i å opprette en sikker forbindelse for å hente oppdateringspakken fra mapsmarker.com. Pro v1.7 inkluderer en løsning for den typen servere, og følgende oppdateringer skal fungere som vanlig. Hvis du er berørt og trenger hjelp, vær så snill åpne en støtte billett.

Slik bekrefter du integriteten til plugin-pakken

SHA-256 hashverdi:

de88406fe2822dea7921f5946b6b51f0ce10d7cdff113010c0fb79aed20b9f24

Klikk her for en veiledning for å bekrefte integriteten til plugin-pakken (anbefales hvis plugin-pakken for en ny installasjon ikke ble lastet ned fra https://www.mapsmarker.com - bekreftelse er ikke nødvendig, men hvis den automatiske oppdateringsprosessen brukes)

Ytterligere oppdateringsnotater for betatester

Ingen ekstra handling på plugin-oppdatering kreves.

Legg igjen en kommentar

XHTML: Du kan bruke disse kodene: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

en English
X