Info: este não é o changelog para o versão estável mais recente 4.14.3
ver todos os changelogs

Pro v1.7 com leaflet.js v0.7.3 e correções de compatibilidade estão disponíveis

Esta versão atualiza o leaflet.js biblioteca à qual me refiro como "o mecanismo do plug-in" - obrigado a todos os colaboradores, especialmente ao Mourner de mapbox.com, que está liderando o desenvolvimento.

Além disso, também criei soluções alternativas para instalações em servidores com bibliotecas SSL desatualizadas. Alguns usuários desse servidor relataram problemas ao tentar ativar sua chave de licença, por exemplo, portanto, uma solução alternativa para esses servidores foi adicionada ao pro v1.7.

Se você não encontrar a atualização atual disponível, também poderá ser afetado por esse problema e, portanto, precisará atualizar manualmente o plug-in uma vez para o pro v1.7. Consulte a seção "Como fazer o download / atualizar" abaixo para obter mais detalhes. Se você é afetado e não sabe o que fazer, por favor abrir um ticket de suporte!


Deixe-me saber o que você pensa sobre este novo lançamento de enviando uma revisão!

Se você deseja manter-se atualizado com o desenvolvimento mais recente do Maps Marker, siga @MapsMarker no twitter (= atualizações mais recentes), em Facebook, Google+ ou assine notícias via RSS ou através RSS / email.

Eu também gostaria de convidar você para se juntar ao nosso programa de afiliados que oferece comissões de até 50%. Se você estiver interessado em se tornar um revendedor, visite https://www.mapsmarker.com/reseller


Agora vamos ao destaque do pro v1.7:

atualizar para leaflet.js v0.7.3

Leaflet.js, a principal biblioteca javascript deste plug-in foi lançada. Esta versão é rotulada como uma versão de manutenção com 8 correções de bugs, changelog completo.

Outras otimizações e mudanças

  • atualizar a base de código do cluster de marcadores (usando a compilação 28/05/14 em vez de 14/03/14)
  • mostrar mensagens de erro mais detalhadas sobre problemas com chamadas à API de licença do mapsmarker.com

correções de bugs

  • imagem editar + remover botões de sobreposição no editor TinyMCE para textos pop-up em páginas de edição de marcadores estavam ausentes desde o WordPress 3.9 (thx De Bruno)
  • os blocos do Google Maps desapareceram durante o zoom ao beliscar o zoom em telefones celulares
  • API de licença quebrada chama servidores em bibliotecas SSL desatualizadas

Atualizações de traduções

Graças a muitos colaboradores motivados, esta versão vem com as seguintes traduções atualizadas:

Se você quiser contribuir com traduções (novos tradutores de hindi serão apreciados!), Visite https://translate.mapsmarker.com/projects/lmm Para maiores informações.

Observe que os tradutores também são compensados ​​por sua contribuição - por exemplo, se uma tradução for concluída com menos de 50%, o tradutor receberá um pacote gratuito de 25 licenças no valor de € 149 como uma compensação pela conclusão da tradução para 100%.

Outlook - meus planos para o próximo lançamento

Por favor, entenda que não estou conseguindo prometer nenhuma data de lançamento para novos recursos. O roteiro para novos recursos importantes (suporte para o Google Street View e suporte para filtragem de camadas no front-end) ainda é válido. Gostaria apenas de manter a flexibilidade de adicionar otimizações e correções de bugs com lançamentos secundários não planejados, resultantes principalmente do feedback dos usuários.

Por favor, também veja o roteiro para uma programação detalhada dos recursos planejados e assine este blog (via RSS or Email) ou siga @MapsMarker no twitter (= atualizações mais recentes) se você deseja manter-se atualizado com as últimas notícias de desenvolvimento.

Registro de alterações completo

atualize para leaflet.js v0.7.3 (versão de manutenção com 8 correções, changelog)
atualizar a base de código do cluster de marcadores (usando a compilação 28/05/14 em vez de 14/03/14)
mostrar mensagens de erro mais detalhadas sobre problemas com chamadas à API de licença do mapsmarker.com
imagem editar + remover botões de sobreposição no editor TinyMCE para textos pop-up em páginas de edição de marcadores estavam ausentes desde o WordPress 3.9 (thx De Bruno)
os blocos do Google Maps desapareceram durante o zoom ao beliscar o zoom em telefones celulares
API de licença quebrada chama servidores em bibliotecas SSL desatualizadas
Atualizações de tradução Caso você queira ajudar com traduções, visite o site plataforma de tradução baseada na web
tradução alemã atualizada
tradução italiana atualizada, graças a Luca Barbetti, http://twitter.com/okibone
tradução atualizada em romeno graças a Arian, http://administrare-cantine.roDaniel Codrea, http://www.inadcod.com e Flo Bejgu, http://www.inboxtranslation.com

mostrar changelogs anteriores

Como baixar / atualizar

A maneira mais fácil de atualizar é usar o processo de atualização do WordPress: faça login com um usuário que tenha privilégios de administrador, navegue até Painel / Atualizações, selecione plugins para atualizar e pressione o botão “Atualizar Plugins”. O plug-in pro verifica a cada 12 horas se uma nova versão está disponível. Você também pode acionar manualmente a verificação da atualização, acessando Plug-ins e clicando no link "Verificar manualmente atualizações" ao lado de "Maps Marker Pro":

verificação de atualização manual

Se você não vir o link "Verificar atualizações" e estiver usando uma versão abaixo de 1.7, atualize manualmente uma vez baixando o pacote atual de https://www.mapsmarker.com/download-pro e substituindo os arquivos de plug-in existentes em seu servidor via FTP. Isso pode ser necessário em vários hosts, que usam bibliotecas SSL desatualizadas, que impedem o Maps Marker Pro de fazer uma conexão segura para recuperar o pacote de atualização do mapsmarker.com. O Pro v1.7 inclui uma solução alternativa para esse tipo de servidor e as seguintes atualizações devem funcionar novamente como de costume. Se você é afetado e precisa de ajuda, por favor abrir um ticket de suporte.

Notas de atualização adicionais para o beta tester

Nenhuma ação adicional na atualização do plug-in é necessária.

Uma resposta para "Pro v1.7 com leaflet.js v0.7.3 e correções de compatibilidade estão disponíveis"

Deixe um comentário

XHTML: Você pode usar estas tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

en English
X