Pro v2.8.1 с улучшениями юзабилити провайдеров геокодирования и исправлениями ошибок

В версии 2.8.1 мы исправили несколько ошибок, а также оптимизировали удобство использования новой функции поставщика геокодирования.

Пожалуйста, посмотрите на наш новый сообщение в блоге о нашем новом партнерстве с Mapzen - нашим новым поставщиком геокодирования по умолчанию для Maps Marker Pro.

Как всегда, настоятельно рекомендуется обновить его до последней версии. Для получения более подробной информации об этом выпуске, пожалуйста, смотрите ниже.


Дайте нам знать, что вы думаете об этом новом выпуске отправив отзыв или оставив комментарий ниже!

Если вы хотите быть в курсе последних разработок Maps Marker Pro, следуйте инструкциям @MapsMarker в твиттере (= самые последние обновления), в Facebook, Google+ или подпишитесь на новости через RSS или через RSS / электронная почта.

Мы также хотели бы пригласить вас присоединиться к нашему Партнерская программа который предлагает комиссионные до 50%. Если вы заинтересованы в том, чтобы стать торговым посредником, пожалуйста, посетите https://www.mapsmarker.com/reseller

дядя-сэм-MMP
Мы хотим, чтобы вы для Maps Marker Pro!
Присоединяйтесь к нашей команде в качестве внештатного разработчика и подайте заявку прямо сейчас!
https://www.mapsmarker.com/join-the-team


Теперь давайте перейдем к основным моментам про v2.8.1:

оптимизация юзабилити провайдера геокодирования и исправления ошибок

  • не очищать (существующие) результаты поиска геокодирования, если (больше никаких дополнительных) результатов не найдено
  • показать 10 вместо 5 результатов геокодирования для Mapzen, Algolia и Photon @ MapsMarker
  • не переключайтесь на альтернативного поставщика геокодирования, если Google Geocoding не возвращает результатов
  • показать подробное сообщение об ошибке, если MapQuest Geocoding не удалось
  • индикатор загрузки для поиска геокодирования не отображался на страницах редактирования маркера
  • Предупреждение PHP, если используется Photon @ MapsMarker для API или импортера и указан пустой адрес

новая настройка совместимости «режим совместимости maxZoom»

В этом выпуске мы представили новый параметр совместимости, который должен помочь решить проблемы с несовместимыми темами, в результате чего маркеры не отображаются должным образом на (Google) базовых картах. Вы найдете эти новые настройки в меню «Настройки» / «Разное» / «Настройки совместимости»:

MaxZoom-Compat-настройка

HTTPS теперь также требуется на iOS / Safari 10+ для правильной работы геолокации

Имейте в виду, что с момента выпуска iOS 10 Apple, в Safari 10+ теперь требуется https для вашего сайта, если вы хотите предложить своим посетителям функцию геолокации. Видеть это сообщение Больше подробностей.

Другие изменения и оптимизации

  • удалена поддержка MemCached для ограничения импорта и скорости Stiphle из-за проблем совместимости
  • автоматически выбирать маркер / имя слоя, ширину карты, высоту карты и масштабировать входные значения на бэкенде при фокусе ввода

Другие исправления

  • массовые действия на странице «перечислить все маркеры» и «перечислить все слои» могут быть прерваны, начиная с версии 2.8 (спасибо!)
  • «Добавить ссылку на маркер» для значка центра слоя была повреждена после того, как на страницах слоя был выбран результат геокодирования
  • фатальная ошибка при активации, если другой плагин также использует WP_Session_Utils-class (спасибо Jan-Willem!)
  • ненужный проверенный = проверенный вывод на страницах импорта на бэкэнде
  • openpopup-ссылки в списке маркеров после поиска не работали начиная с v2.8 (спасибо Takeo!)
  • Maps Marker Pro не может быть активирован при установке PHP 5.2 (спасибо, Клайв!)

известные проблемы

Функция геолокации больше не работает с Google Chrome 50+, если ваш сайт не доступен через https

В Chrome 50 (и Safari 10) существенные изменения в поддержке геолокации были внесены соответствующими поставщиками браузеров: все приложения, запрашивающие текущую позицию пользователя (не только для функции геолокации в Maps Marker Pro), теперь могут только получать текущая позиция пользователя, если сайт настроен для безопасной доставки через https - вместо этого пользователи увидят следующее или подобное предупреждение:

геолокации ошибок-инфо

Подробнее об этом решении Google читайте на https://developers.google.com/web/updates/2016/04/geolocation-on-secure-contexts-only, Geolocation будет по-прежнему работать на сайтах, отличных от https, если пользователи получат доступ к сайту через альтернативные браузеры, такие как Firefox, сафари или Internet Explorer - в любом случае вполне вероятно, что эти браузеры также добавят подобное ограничение безопасности в будущем.

Обновление ноябрь 2016: начиная с iOS 10 также Safari 10+ теперь требует https для поддержки геолокации. Реализация еще более строгая, чем в Google Chrome - геолокация не будет работать, например, если на вашем сайте есть предупреждения со смешанным содержанием.

Поэтому, если на вашем сайте требуется функция геолокации Maps Marker Pro, настоятельно рекомендуется перенести сайт на https. Некоторые хостеры уже предоставляют бесплатные сертификаты https от letsencrypt.org например. Для конфигураций, необходимых на вашем сайте WordPress для того, чтобы настроить его на поддержку https, пожалуйста, посмотрите учебники, такие как https://css-tricks.com/moving-to-https-on-wordpress/.

Так как https имеет больше преимуществ для вашего сайта, чем просто геолокация, снова работая с Google Chrome 50+ и Safari 10+ (например, обеспечение целостности данных, аутентификация отправителя и конфиденциальность пользователя, а также более высокий рейтинг Google, поскольку https используется в качестве сигнала ранжирования), мы Настоятельно советуем переключить ваш сайт на https, только если вы этого еще не сделали.

Если вы переключили свой сайт на https и по-прежнему получаете ошибку геолокации (например, «Ошибка геолокации: пользователь отклонил геолокацию»), проверьте настройки местоположения вашего устройства, если приложениям / веб-сайтам разрешено получать геолокацию.

Обновления переводов

Благодаря множеству мотивированных авторов, этот выпуск включает в себя следующие обновленные переводы:

  • Немецкий
  • Русский спасибо Екатерине Голубиной (при поддержке Теплица Социальных Технологий -http://te-st.ru) и Вячеслав Стренадко, http://slavblog.ru

Если вы хотите внести свой вклад в перевод (новые переводчики хинди приветствуются!), Пожалуйста, посетите https://translate.mapsmarker.com/projects/lmm чтобы получить больше информации.

Обратите внимание, что переводчикам также выплачивается компенсация за их вклад - например, если перевод выполнен менее чем на 50%, переводчик получает бесплатный пакет из 25 лицензий стоимостью 249 евро в качестве компенсации за завершение перевода до 100%.

Outlook - планы на следующие выпуски

Пожалуйста, поймите, что мы не можем обещать даты выпуска новых функций. Дорожная карта Основные новые функции дают вам представление о том, куда движется Maps Marker Pro - в любом случае, мы просто хотим сохранить гибкость, чтобы добавлять оптимизации и исправления ошибок с довольно незапланированными второстепенными выпусками, полученными в основном из отзывов пользователей.

Пожалуйста, подпишитесь на этот блог (через RSS or Эл. адрес) или следуйте @MapsMarker в твиттере (= самые последние обновления), если вы хотите быть в курсе последних новостей развития.

Полный список изменений

сообщение в блоге о нашем новом партнерстве с Mapzen - новым поставщиком геокодирования по умолчанию для Maps Marker Pro
новый параметр совместимости «режим совместимости maxZoom» для конфликтов тем, когда маркеры на (Google) картах отображаются неправильно
HTTPS теперь также требуется на iOS / Safari 10+ для правильной работы геолокации (детали)
не очищать (существующие) результаты поиска геокодирования, если (больше никаких дополнительных) результатов не найдено
показать 10 вместо 5 результатов геокодирования для Mapzen, Algolia и Photon @ MapsMarker
не переключайтесь на альтернативного поставщика геокодирования, если Google Geocoding не возвращает результатов
удалена поддержка MemCached для ограничения импорта и скорости Stiphle из-за проблем совместимости
автоматически выбирать маркер / имя слоя, ширину карты, высоту карты и масштабировать входные значения на бэкенде при фокусе ввода
показать подробное сообщение об ошибке, если MapQuest Geocoding не удалось
массовые действия на странице «перечислить все маркеры» и «перечислить все слои» могут быть прерваны, начиная с версии 2.8 (спасибо!)
«Добавить ссылку на маркер» для значка центра слоя была повреждена после того, как на страницах слоя был выбран результат геокодирования
фатальная ошибка при активации, если другой плагин также использует WP_Session_Utils-class (спасибо Jan-Willem!)
Предупреждение PHP, если используется Photon @ MapsMarker для API или импортера и указан пустой адрес
ненужный проверенный = проверенный вывод на страницах импорта на бэкэнде
openpopup-ссылки в списке маркеров после поиска не работали начиная с v2.8 (спасибо Takeo!)
индикатор загрузки для поиска геокодирования не отображался на страницах редактирования маркера
Maps Marker Pro не может быть активирован при установке PHP 5.2 (спасибо, Клайв!)
Функция геолокации больше не работает с Google Chrome 50+ и iOS / Safari 10+, если ваш сайт не доступен через https (детали)
Перевод обновлений
Если вы хотите помочь с переводом, посетите веб-платформа для перевода
обновленный немецкий перевод
обновленный русский перевод благодаря Екатерине Голубиной (при поддержке Теплица Социальных Технологий - http://te-st.ru) и Вячеслав Стренадко, http://slavblog.ru

показать все доступные журналы изменений

Как скачать / обновить

Самым простым способом обновления является использование процесса обновления WordPress: войдите в систему с пользователем, обладающим правами администратора, перейдите к Dashboard / Updates, выберите плагины для обновления и нажмите кнопку «Обновить плагины». Профессиональный плагин проверяет каждые 24 часов, доступна ли новая версия. Вы также можете вручную запустить проверку обновлений, перейдя в Плагины и нажав на ссылку «Проверка обновлений вручную» рядом с «Maps Marker Pro»:

ручное обновление проверка

Если вы не видите ссылку «Проверить наличие обновлений» и используете версию ниже 1.7, обновите вручную один раз, загрузив текущий пакет с https://www.mapsmarker.com/download-pro и перезаписать существующие файлы плагинов на вашем сервере через FTP. Это может потребоваться на нескольких хостах, которые используют устаревшие библиотеки SSL, которые не позволяют Maps Marker Pro создать безопасное соединение для получения пакета обновления с mapsmarker.com. Pro v1.7 включает обходной путь для серверов такого типа, и следующие обновления должны снова работать как обычно. Если вы затронуты и нуждаетесь в помощи, пожалуйста, открыть билет поддержки.

Как проверить целостность пакета плагинов

Хеш-значение SHA-256:

B6972C3D29274A917157CC8A7D177EC7F521C806AFF40937D781C2601E314E10

Нажмите здесь, чтобы узнать, как проверить целостность пакета плагинов. (рекомендуется, если пакет плагина для новой установки не был загружен с https://www.mapsmarker.com - хотя проверка не требуется, если используется процесс автоматического обновления)

Дополнительные примечания к обновлению для бета-тестера

Никаких дополнительных действий по обновлению плагина с бета-версии до финальной версии не требуется.

Оставить комментарий

XHTML: Вы можете использовать эти теги: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

en English
X