Info: detta är inte ändringsloggen för senaste stabila version 4.14.3
se alla växlar

Pro v1.7 med leaflet.js v0.7.3 och kompatibilitetsfixer är tillgängliga

Den här versionen uppdaterar leaflet.js bibliotek som jag refererar till som “plugin-motorn” - tack till alla bidragsgivare, särskilt till Sörjande från mapbox.com, som leder utvecklingen.

Dessutom har jag också byggt lösningar för installation på servrar med föråldrade SSL-bibliotek. Vissa användare av dessa server rapporterade problem när de försökte aktivera sin licensnyckel till exempel, så en lösning för dessa servrar har lagts till med pro v1.7.

Om du inte ser att den aktuella uppdateringen är tillgänglig kan du också påverkas av det här problemet och måste därför uppdatera plugin manuellt en gång till pro v1.7. Se avsnittet "Hur man laddar ner / uppdaterar" nedan för mer information. Om du är påverkad och osäker på vad du ska göra, snälla öppna en supportbiljett!


Låt mig veta vad du tycker om den här nya versionen av lämna in en recension!

Om du vill hålla dig uppdaterad med den senaste utvecklingen av Maps Marker, följ @MapsMarker på twitter (= senaste uppdateringar), på Facebook, Google+ eller prenumerera på nyheter via RSS eller via RSS / e-post.

Jag skulle också vilja bjuda in dig till vårt affiliate program som erbjuder provisioner upp till 50%. Besök gärna om du är intresserad av att bli återförsäljare https://www.mapsmarker.com/reseller


Nu ska vi komma till höjdpunkten i pro v1.7:

uppgradera till leaflet.js v0.7.3

Leaflet.js, har det här javascriptbiblioteket för detta plugin släppts. Denna utgåva är märkt som en underhållsrelease med 8 bugfixes, full changelog.

Andra optimeringar och förändringar

  • uppdatera markörklusterkodbasen (med build 28/05/14 istället för 14/03/14)
  • visa mer detaljerade felmeddelanden i problem med API-samtal för mapsmarker.com licens

Bug fixar

  • bildredigering + ta bort överläggsknappar i TinyMCE-redigeraren för popuptexter på markörredigeringssidor saknades sedan WordPress 3.9 (thx Bruno)
  • brickor för Google Maps försvann under zoomning när man nypade zoomning på mobiltelefoner
  • trasig licens API anropar servrar med föråldrade SSL-bibliotek

Uppdateringar av översättningar

Tack vare många motiverade bidragsgivare kommer denna utgåva med följande uppdaterade översättningar:

Om du vill bidra till översättningar (nya hindi-översättare skulle uppskattas!), Besök https://translate.mapsmarker.com/projects/lmm för mer information.

Observera att översättare också kompenseras för deras bidrag - till exempel om en översättning är färdig mindre än 50%, får översättaren ett gratis 25 licenspaket till ett värde av € 149 som kompensation för att slutföra översättningen till 100%.

Outlook - mina planer för nästa utgåva

Förstå att jag inte kan lova några släppdatum för nya funktioner. Färdplanen för stora nya funktioner (stöd för Google Street View och stöd för filtrering av lager på frontend) är fortfarande giltig, jag vill bara behålla flexibiliteten för att lägga till optimeringar och bugfixes med ganska oplanerade mindre utgåvor som främst beror på användarens feedback.

Snälla också se färdplanen för ett grovt schema för planerade funktioner och prenumerera på denna blogg (via RSS or E-post) eller följ @MapsMarker på twitter (= senaste uppdateringar) om du vill hålla dig uppdaterad med de senaste utvecklingsnyheterna.

Full förändringslogg

uppgradera till leaflet.js v0.7.3 (underhållsrelease med 8 bugfixes, changelog)
uppdatera markörklusterkodbasen (med build 28/05/14 istället för 14/03/14)
visa mer detaljerade felmeddelanden i problem med API-samtal för mapsmarker.com licens
bildredigering + ta bort överläggsknappar i TinyMCE-redigeraren för popuptexter på markörredigeringssidor saknades sedan WordPress 3.9 (thx Bruno)
brickor för Google Maps försvann under zoomning när man nypade zoomning på mobiltelefoner
trasig licens API anropar servrar med föråldrade SSL-bibliotek
Översättningsuppdateringar Om du vill hjälpa till med översättningar, besök webbaserad översättningsplattform
uppdaterad tysk översättning
uppdaterad italiensk översättning tack vare Luca Barbetti, http://twitter.com/okibone
uppdaterad rumänsk översättning tack vare Arian, http://administrare-cantine.roDaniel Codrea, http://www.inadcod.com och Flo Bejgu, http://www.inboxtranslation.com

visa tidigare växlar

Hur man laddar ner / uppdaterar

Det enklaste sättet att uppdatera är att använda WordPress-uppdateringsprocessen: logga in med en användare som har administratörsbehörighet, navigera till Dashboard / Updates, välj plugins som ska uppdateras och tryck på knappen “Update Plugins”. Pro-plugin kontrollerar var 12: e timme om en ny version är tillgänglig. Du kan också aktivera uppdateringskontrollen manuellt genom att gå till Plugins och klicka på länken "Manuellt leta efter uppdateringar" bredvid "Maps Marker Pro":

manuell uppdatering-check

Om du inte ser länken "Sök efter uppdateringar" och använder en version under 1.7, uppdatera manuellt en gång genom att ladda ner det aktuella paketet från https://www.mapsmarker.com/download-pro och att skriva över befintliga plugin-filer på din server via FTP. Detta kan behövas på flera värdar, som använder föråldrade SSL-bibliotek, som förhindrar Maps Marker Pro från att skapa en säker anslutning för att hämta uppdateringspaketet från mapsmarker.com. Pro v1.7 innehåller en lösning för den typen av servrar och följande uppdateringar bör fungera som vanligt. Om du är drabbad och behöver hjälp, snälla öppna en supportbiljett.

Ytterligare uppdateringsanteckningar för betatestare

Ingen ytterligare åtgärd för plugin-uppdatering krävs.

Ett svar på “Pro v1.7 med leaflet.js v0.7.3 och kompatibilitetsfixar är tillgängligt”

Lämna en kommentar

XHTML: Du kan använda dessa taggar: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

en English
X