Pro v2.6.2 –兼容性和错误修复版本,可推迟加载–已推出

一些用户报告了最新版本引入的新Google延迟加载功能的问题。 我们分析了这些问题,发现如果激活此功能,则某些主题可能会导致问题。

这就是为什么我们发布了v2.6.2,允许您禁用延迟的Google加载功能并在v2.6.1之前使用旧方法的原因。 请参阅下面的更多细节。

与往常一样,强烈建议将其更新为最新版本。


让我们知道您对以下新版本的看法 提交评论 或在下面发表评论!

如果您想了解最新的Maps Marker Pro开发最新信息,请关注@MapsMarker 在Twitter(=最新更新),在 FacebookGoogle+的 或通过订阅新闻 RSS 或者通过 RSS /电子邮件.

我们也想邀请您加入我们 联盟计划 提供高达50%的佣金。 如果您有兴趣成为经销商,请访问 https://www.mapsmarker.com/reseller


现在让我们来看看pro v2.6.2的亮点:

添加了禁用递延Google Maps API的选项 

如果您默认使用Google Maps作为地图的底图,并且遇到在前端显示这些地图的问题,现在可以切换回加载Google Maps API脚本的旧方法。 您可以在“设置” /“ Google地图” /“ Google Maps API”中找到此新设置:

设置延迟的Google加载

如果您没有遇到任何问题或使用基于OpenStreetMap的地图,则不建议更改此设置,否则(基于OpenStreetMap的)地图的加载时间会增加。

始终通过https加载地图图块(如果有) 

在此版本之前,如果您的WordPress网站也使用https,则仅通过https加载OpenStreetMap,MapQuest,Mapbox和OGD Vienna的地图图块。 对于您网站的访问者而言,这不是关于隐私和安全的最佳方法。

在v2.6.2中,我们现在对此进行了更改,默认情况下通过https加载了这些底图的地图图块。 仅当您在WordPress安装中使用中文语言环境时,才会使用http(因为过去曾报道过中国的https性能问题)。

Bug修复

  • 自v2.6.1起,默认情况下使用Google底图的地图上的标记聚类在某些主题上已被破坏
  • 带有full = yes的标记的GeoJSON输出已损坏
  • 在“设置”页面上恢复了旧的标题顺序(h2 + h3 + h4),因为管理员通知未正确显示在页面顶部

翻译更新

感谢许多积极的贡献者,此版本包括以下更新的翻译:

如果您想为翻译做出贡献(不胜感激新的印地语翻译!),请访问 https://translate.mapsmarker.com/projects/lmm 了解更多信息。

请注意,翻译人员的贡献也得到补偿-例如,如果翻译完成量不足50%,翻译人员将获得25份免费的许可证包,价值149欧元,以补偿完成100%的翻译。

Outlook –下一个版本的计划

请理解,我们无法保证任何新功能的发布日期。 的 路线图 对于主要的新功能,您可以了解Maps Marker Pro的发展方向-无论如何,我们只想保持灵活性,即可添加优化和错误修正,而这些修正和计划外的次要发行主要来自用户反馈。

请订阅此博客(通过 RSS or 电子邮件)或关注@MapsMarker 如果您想了解最新的开发新闻,请访问Twitter(=最新更新)。

完整的变更日志

添加了选项以禁用延迟的Google Maps API加载,因为报告了一些主题兼容性问题
始终通过https加载OpenStreetMap,MapQuest,Mapbox和OGD Vienna的图块(除非已报告中国语言环境设置为在中国使用https的性能问题)
自v2.6.1起,默认情况下使用Google底图的地图上的标记聚类在某些主题上已被破坏
带有full = yes的标记的GeoJSON输出已损坏
在“设置”页面上恢复了旧的标题顺序(h2 + h3 + h4),因为管理员通知未正确显示在页面顶部
翻译更新
如果您想帮助翻译,请访问 基于网络的翻译平台
更新德语翻译
感谢叶卡捷琳娜·古鲁比娜(Ekaterina Golubina)更新的俄语翻译(由社会技术的Teplitsa支持– http://te-st.ru)和Vyacheslav Strenadko, http://slavblog.ru 

显示所有可用的变更日志

如何下载/更新

最简单的更新方法是使用WordPress更新过程:以具有管理员权限的用户身份登录,导航至“仪表盘/更新”,选择要更新的插件,然后按“更新插件”按钮。 专业版插件每12小时检查一次新版本是否可用。 您也可以通过转到插件并单击“ Maps Marker Pro”旁边的链接“手动检查更新”来手动触发更新检查:

手动更新检查

如果您没有看到“检查更新”链接,并且使用的版本低于1.7,请通过从以下位置下载当前软件包来手动更新一次 https://www.mapsmarker.com/download-pro 并通过FTP覆盖服务器上的现有插件文件。 在使用过时的SSL库的几台主机上可能需要这样做,这会阻止Maps Marker Pro建立安全连接以从mapsmarker.com检索更新包。 Pro v1.7包括针对此类服务器的解决方法,并且以下更新应照常运行。 如果您受到影响并需要帮助,请 打开支持票.

如何验证插件包的完整性

SHA-256哈希值:

38E72D6758D615A78F5F4ECA8E2EBCA4A59EAFC1DF8B3EF7B8F92A6003BA5322

单击此处以获取有关如何验证插件包完整性的教程。 (如果未从https://www.mapsmarker.com下载用于新安装的插件程序包,则建议–尽管使用了自动更新过程,也不需要验证)

Beta测试器的其他更新说明

从Beta版本更新到此最终版本时,无需采取其他措施。

意见或其他问题?

如果您正在寻找技术支持 请点击这里,对于其他所有问题,请 使用我们的联系表格 取得联系! 我们期待着您的回音!

您的Maps Marker Pro团队

en English
X