v3.2.2 – really no more edits needed – is available

Conditional CSS loading is great – unfortunately not all theme developers follow WordPress best practices and therefore I just released v3.2.2 which focuses on compatibility and not having users to edit template files or changing options in order to run Leaflet Maps Marker out of the box. If you encounter any problems nethertheless, please use the support forum and I will try to help.

One personal request: as WordPress added a new review feature for plugins hosted on wordpress.org, I kindly invite you to leave your opinion about my plugin at http://wordpress.org/support/view/plugin-reviews/leaflet-maps-marker.

If you want to keep up to date with the latest Maps Marker development, please follow @MapsMarker on twitter or on Facebook

And now let´s get into the highlights of v3.2.2:

map shortcode can now also be used in widgets out of the box

v3.2.2 allows you to use shortcodes directly in widgets as you can do now in posts or pages:

widget

added check for wp_footer() in template files & added troubleshooting link on frontpage if map could not be loaded

Templates which don´t use the recommended template tag wp_footer(); dont work out of the box – users have to add this tag or switch the option include javascripts in the header. As this caused some irritation, I added a check in the backend, if the template tag wp_footer(); is used within your index.php or footer.php of your current template file. Furthermore I added an info link on frontend for administrators which links to this FAQ if maps could not be loaded:

troubleshooting

option to disable conditional css loading

If I forgot a usecase (which I hope I didnt ;-), you can now turn off conditional css loading again and load the needed css files on every page. Just navigate to Settings / Misc / General settings. Anyway – in 99% you should not have to change this setting.

conditional-css

Translations updates

Thanks to many motivated contributors, v3.2.2 comes with the following translation updates:

Updated translations

  • Dutch thanks to Patrick Ruers, http://www.stationskwartiersittard.nl
  • German

If you want to contribute to translations (Persian would be great 😉 ), please visit http://translate.mapsmarker.com/projects/lmm for more information.

Bugfixes

  • W3C validator errors for marker maps, layer maps and recent marker widget

Outlook – my plans for the next release

Hopefully this was the last release before X-mas 🙂

Full changelog (show previous changelogs)

map shortcode can now also be used in widgets out of the box
added check for wp_footer() in template files (footer.php or index.php)
added troubleshooting link on frontpage if map could not be loaded
option to disable conditional css loading
updated Dutch translation thanks to Patrick Ruers, http://www.stationskwartiersittard.nl
updated German translation
W3C validator errors for marker maps, layer maps and recent marker widget

Please let me what you think of this new release. If you have any issues, please see this page on how to get support. If an important feature is missing, please add your feature requests on Github. I am also looking for more translations – if you would like to contribute a new one, please visit this page for more information. And of course I´d very appreciate your review for my plugin on wordpress.org 😉

Leave a Reply

Your email address will not be published. Required fields are marked *