Pro v1.8.1 with compatibility fixes is available

This release focuses on fixing compatibility issues with other plugins and the upcoming WordPress 4.0 release. See below for more details.


Let me know what you think about this new release by submitting a review!

If you want to keep up to date with the latest Maps Marker development, please follow @MapsMarker on twitter (= most current updates), on FacebookGoogle+ or subscribe to news via RSS or via RSS/email.

I would also like to invite you to join our affiliate program which offers commissions up to 50%. If you are interested in becoming a reseller, please visit https://www.mapsmarker.com/reseller


Highlights

Other changes and optimizations

  • optimized version compare functions by using PHP version_compare();

Bugfixes

  • not all sections within settings could be selected on smaller screens (thx Francesco!)
  • display of popuptext in GeoRSS feed was broken (thx Indrajit!)
  • fixed broken incompatibility check with Better WordPress Minify plugin v1.3.0

Translations updates

Thanks to many motivated contributors, this release comes with the following updated translations:

If you want to contribute to translations (new Hindi translators would be appreciated!), please visit https://translate.mapsmarker.com/projects/lmm for more information.

Please note that translators are also compensated for their contribution – for example if a translation is finished less than 50%, the translator gets a free 25 licenses pack worth €149 as a compensation for completing the translation to 100%.

Outlook – my plans for the next release

For pro v1.9 I plan to add geolocation support, which means adding a button which shows the current position of the user viewing the map. See a demo here.

Please understand that I am not being able to promise any release dates for new features. The roadmap for major new features (support for Google Street View and support for filtering of layers on frontend) is still valid, I just would want to keep the flexibility to add optimizations and bugfixes with rather unplanned minor releases resulting mostly from users feedback.

Please also see the roadmap for a rough schedule for planned features and please subscribe to this blog (via RSS or Email) or follow @MapsMarker on twitter (= most current updates) if you want to stay up to date with the latest development news.

Full changelog

10% discount code to celebrate the 1st anniversary of Maps Marker Pro
enabled SSL by default for MapsMarker.com website & installed EV SSL certificate (=verified identity)
compatibility check for “Page Builder by SiteOrigin” plugin (thx porga!)
tested against WordPress 4.0
optimized version compare functions by using PHP version_compare();
not all sections within settings could be selected on smaller screens (thx Francesco!)
display of popuptext in GeoRSS feed was broken (thx Indrajit!)
fixed broken incompatibility check with Better WordPress Minify plugin v1.3.0
Translation updates
In case you want to help with translations, please visit the web-based translation plattform
updated Chinese translation thanks to John Shen, http://www.synyan.net and ck
updated Dutch translation thanks to Patrick Ruers, http://www.stationskwartiersittard.nl
updated Latvian translation thanks to Juris Orlovs, http://lbpa.lv and Eriks Remess http://geekli.st/Eriks
updated Russian translation thanks to Ekaterina Golubina (supported by Teplitsa of Social Technologies – http://te-st.ru) and Vyacheslav Strenadko, http://poi-gorod.ru

show previous changelogs

How to download / update

The easiest way to update is to use the WordPress update process: login with an user who has admin privileges, navigate to Dashboard / Updates, select plugins to update and press the button “Update Plugins”. The pro plugin checks every 12 hours if a new version is available. You can also manually trigger the update check by going to Plugins and clicking on the link “Manually check for updates” next to “Maps Marker Pro”:

manual-update-check

If you do not see the link “Check for updates” and are using a version below 1.7, please update manually once by downloading the current package from https://www.mapsmarker.com/download-pro and overwritting the existing plugin files on your server via FTP. This might be needed on several hosts, which use outdated SSL libraries, which prevent Maps Marker Pro from making a secure connection to retrieve the update package from mapsmarker.com. Pro v1.7 includes a workaround for those kind of servers and the following updates should work again as usual. If you are affected and need help, please open a support ticket.

Additional update notes for beta tester

No additional action on plugin update required.

Leave a Reply

Your email address will not be published. Required fields are marked *