Info: este não é o changelog para o versão estável mais recente 4.14.3
ver todos os changelogs

O Pro v2.3 com aprimoramentos de localização geográfica e correções de compatibilidade está disponível

Nosso objetivo é oferecer um serviço sustentável, além de produtos estáveis ​​e seguros para todos os nossos usuários. Como resultado, nos concentramos em melhorar os serviços e infraestrutura de back-end, bem como nos processos operacionais durante os últimos 2 meses, e tivemos que adiar os desenvolvimentos regulares como consequência.

No entanto, a versão 2.3 agora está concluída e inclui não apenas correções de compatibilidade, mas também novos recursos relacionados à geolocalização e aprimoramentos, especialmente para desenvolvedores e integradores.

Uma atualização para a versão mais recente é - como sempre - altamente recomendada. Leia abaixo para mais detalhes.


Deixe-nos saber o que você pensa sobre este novo lançamento por enviando uma revisão ou deixando um comentário abaixo!

Se você deseja manter-se atualizado com o desenvolvimento mais recente do Maps Marker, siga @MapsMarker no twitter (= atualizações mais recentes), em Facebook, Google+ ou assine notícias via RSS ou através RSS / email.

Gostaríamos também de convidá-lo para participar de nosso programa de afiliados que oferece comissões de até 50%. Se você estiver interessado em se tornar um revendedor, visite https://www.mapsmarker.com/reseller


Agora vamos aos destaques do pro v2.3:

melhorias de localização geográfica

Em Configurações / Padrões do mapa / “Configurações de localização geográfica”, você encontrará uma nova opção chamada Começo automático:

autostart-geolocate

Por padrão, essa configuração é definida como false. Se definir esta opção como verdadeira, a geolocalização será iniciada automaticamente em todos os mapas. Se você deseja iniciar a geolocalização apenas nos mapas selecionados, prossiga para o próximo destaque da v2.3:

nova variável javascript para desenvolvedores / integradores

Com a v2.3, as novas variáveis ​​javascript mapid_js e nos mapname_js foram adicionados ao código fonte de cada mapa. Isso facilita a reutilização da função javascript fora da estrutura do Map Marker Pro.

Digamos, por exemplo, que você queira iniciar a geolocalização para todos os mapas exibidos apenas no arquivo do seu blog. Para conseguir isso, você deve adicionar o seguinte código javascript ao seu arquivo de modelo (geralmente archives.php, mas isso pode ser diferente com base no tema que você está usando):

<script type = ”text / javascript”>
eval ('locatecontrol _' + mapname_js) .start ();
</ Script>

Essa alteração também oferece a flexibilidade de chamar com mais facilidade os comandos diretos da API leaflet.js de fora da estrutura do plug-in, por exemplo, adicionar um botão ao seu tema que altera o nível de zoom.

A referência completa da API do folheto pode ser encontrada aqui.

novo tutorial para o MapTiler

Com MapTiler você pode transformar imagens em camadas de mapa interativas que podem ser exibidas com o Maps Marker Pro, configurando-as como mapa base personalizado ou sobreposição personalizada.

Matthew Sangster criou agora um tutorial sobre como criar mapas base personalizados usando o MapTiler - muito obrigado por isso!

novo logotipo 3d para o Maps Marker Pro

Os rapazes e senhoras de cgi-branding.com criou um novo logotipo 3D para o Maps Marker, que agora também é usado em todos os nossos produtos e serviços:

mapsmarkerpro-logo

muito obrigado pelo excelente trabalho!

nova tradução eslovena

Graças a Anna Dukan, http://www.unisci24.com/blog/ O esloveno foi adicionado como número de tradução disponível 36.

Se você também quiser contribuir com traduções (em troca de uma licença profissional), visite https://translate.mapsmarker.com/projects/lmm Para maiores informações.

Outras mudanças e otimizações

  • use classes CSS em vez de estilos embutidos para widgets de marcadores recentes para melhor suportar substituições (thx Patrick!)
  • área de cliente atualizada em mapsmarker.com, bem como mudar para o PHP 5.6 - por favor relate quaisquer problemas!

correções de bugs

  • As faixas GPX usando UTF8 com codificação de BOM não aparecem no Google Chrome (thx José!)
  • SiteOrigin Corrigido um conflito de plug-in liberando Page Builder v2.1
  • Removido unset () para validate_local_key (), pois poderia causar falha na segunda validação da chave local após a atualização
  • problemas com chamadas de API de licença em servidores em que a diretiva SSLVerifyClient está definida como "necessária" (thx Ron!)
  • o ícone padrão personalizado não foi salvo depois que o link "adicionar novo marcador" foi usado uma segunda vez (thx Cyrille!)
  • configurações personalizadas do separador PHP para floatval () podem resultar em mapas quebrados (thx Tamas!)
  • link de edição de camada quebrada nas páginas de edição do marcador após clicar no botão publicar ou atualizar
  • verifique se o patch do PHP Suhosin levou a telas brancas em configurações especiais de servidor se phpinfo () foi bloqueado

Atualizações de traduções

Graças a muitos colaboradores motivados, esta versão inclui atualizações para as seguintes traduções:

Se você quiser contribuir com traduções (novos tradutores de hindi serão apreciados!), Visite https://translate.mapsmarker.com/projects/lmm Para maiores informações.

Observe que os tradutores também são compensados ​​por sua contribuição - por exemplo, se uma tradução for concluída com menos de 50%, o tradutor receberá um pacote de 25 licenças grátis no valor de € 149 como uma compensação pela conclusão da tradução para 100%.

Problemas conhecidos

Infelizmente, atualmente há um problema que não pode ser resolvido diretamente no Maps Marker Pro:

Com o WordPress 4.2, o suporte a Emoji foi adicionado. Infelizmente, existe um erro aberto (detalhes), que pode resultar em mapas congelados ou falhas no Internet Explorer - portanto, o WordPress 4.2, 4.2.1 e 4.2.2 são afetados. De acordo com o ticket trac relacionado, uma correção já está disponível e, esperamos, será implantada em breve com o WordPress 4.2.3.

Como solução alternativa até o WordPress 4.2.3 estar disponível, você pode apenas desativar Emojis no momento, os mapas também funcionam corretamente no Internet Explorer.

Lamentamos muito esse problema, mas isso está além de nossa influência - já contatamos os funcionários do WordPress e esperamos que a correção do bug Emoji / SVG esteja disponível em breve.

Outlook - planos para os próximos lançamentos

Por favor, entenda que não podemos prometer datas de lançamento para novos recursos. o roteiro para os principais novos recursos, você tem uma idéia de para onde o Maps Marker Pro está indo - de qualquer forma, gostaríamos de manter a flexibilidade de adicionar otimizações e correções de bugs com versões secundárias não planejadas, resultantes principalmente do feedback dos usuários.

Inscreva-se neste blog (via RSS or Email) ou siga @MapsMarker no twitter (= atualizações mais recentes) se você deseja manter-se atualizado com as últimas notícias de desenvolvimento.

Registro de alterações completo

nova opção para iniciar automaticamente a localização geográfica globalmente em todos os mapas (consulte o registro de alterações sobre como iniciar a localização geográfica apenas para mapas selecionados)
adicionadas variáveis ​​javascript mapid_js e nos mapname_js para facilitar a reutilização da função javascript de fora do plug-in
novo tutorial: como criar mapas base personalizados usando o MapTiler
novo logotipo 3d para o Maps Marker Pro
use classes CSS em vez de estilos embutidos para widgets de marcadores recentes para melhor suportar substituições (thx Patrick!)
área de cliente atualizada no mapsmarker.com, bem como mudar para o PHP 5.6 - informe quaisquer problemas!
As faixas GPX usando UTF8 com codificação de BOM não aparecem no Google Chrome (thx José!)
SiteOrigin Corrigido um conflito de plug-in liberando Page Builder v2.1
Removido unset () para validate_local_key (), pois poderia causar falha na segunda validação da chave local após a atualização
problemas com chamadas de API de licença em servidores em que a diretiva SSLVerifyClient está definida como "necessária" (thx Ron!)
o ícone padrão personalizado não foi salvo depois que o link "adicionar novo marcador" foi usado uma segunda vez (thx Cyrille!)
configurações personalizadas do separador PHP para floatval () podem resultar em mapas quebrados (thx Tamas!)
link de edição de camada quebrada nas páginas de edição do marcador após clicar no botão publicar ou atualizar
verifique se o patch do PHP Suhosin levou a telas brancas em configurações especiais de servidor se phpinfo () foi bloqueado
Atualizações de tradução
Caso você queira ajudar com traduções, visite o site plataforma de tradução baseada na web
Tradução esloveno (sl_SL) graças a Anna Dukan, http://www.unisci24.com/blog/
tradução atualizada para o francês graças a Vincèn Pujol, http://www.skivr.com e Rodolphe Quiedeville, http://rodolphe.quiedeville.org, Fx Benard, http://wp-translator.com, cazal cédric, http://www.cedric-cazal.comFabian Hurelle, http://hurelle.fr e Thomas Guignard,http://news.timtom.ch
tradução alemã atualizada
tradução atualizada da letão graças a Juris Orlovs, http://lbpa.lv e Eriks Remess http://geekli.st/Eriks
tradução atualizada do norueguês (Bokmål) graças a Inge Tang, http://drommemila.no
tradução atualizada em romeno graças a Arian, http://administrare-cantine.roDaniel Codrea, http://www.inadcod.com e Flo Bejgu, http://www.inboxtranslation.com
tradução atualizada para o russo graças a Ekaterina Golubina (suportada por Teplitsa of Social Technologies - http://te-st.ru) e Vyacheslav Strenadko, http://poi-gorod.ru
tradução atualizada para o espanhol graças a David Ramírez, http://www.hiperterminal.comAlvaro Lara, http://www.alvarolara.comVictor Guevara, http://1sistemas.netRicardo Viteri, http://www.labviteri.com e Juan Valdes
tradução sueca atualizada graças a Olof Odier http://www.historiskastadsvandringar.se, Tedy Warsitha http://codeorig.in/, Dan Paulsson http://www.paulsson.euElger Lindgren, http://20x.se e Anton Andreasson, http://andreasson.org/
tradução atualizada do vietnamita (vi) graças a Hoai Thu, http://bizover.net
Problemas conhecidos
O Internet Explorer pode falhar com o WordPress 4.2 a 4.2.2 devido ao conflito de Emoji (detalhes) - planejado para ser corrigido com o WordPress 4.2.3, solução alternativa até que o WordPress 4.2.3 esteja disponível: desativar Emojis

mostrar changelogs anteriores

Como baixar / atualizar

A maneira mais fácil de atualizar é usar o processo de atualização do WordPress: faça login com um usuário que tenha privilégios de administrador, navegue até Painel / Atualizações, selecione plugins para atualizar e pressione o botão “Atualizar Plugins”. O plug-in pro verifica a cada 12 horas se uma nova versão está disponível. Você também pode acionar manualmente a verificação da atualização, acessando Plug-ins e clicando no link "Verificar manualmente atualizações" ao lado de "Maps Marker Pro":

verificação de atualização manual

Se você não vir o link "Verificar atualizações" e estiver usando uma versão abaixo de 1.7, atualize manualmente uma vez baixando o pacote atual de https://www.mapsmarker.com/download-pro e substituindo os arquivos de plug-in existentes em seu servidor via FTP. Isso pode ser necessário em vários hosts, que usam bibliotecas SSL desatualizadas, que impedem o Maps Marker Pro de fazer uma conexão segura para recuperar o pacote de atualização do mapsmarker.com. O Pro v1.7 inclui uma solução alternativa para esse tipo de servidor e as seguintes atualizações devem funcionar novamente como de costume. Se você é afetado e precisa de ajuda, por favor abrir um ticket de suporte.

Como verificar a integridade do pacote de plugins

Valor de hash SHA-256:

238F109F0057EBBACBE0984B01AFFBA2C52E81B93C767F53A28668CFB7F7EFA5

Clique aqui para obter um tutorial sobre como verificar a integridade do pacote de plugins (recomendado se o pacote de plug-ins para uma nova instalação não tiver sido baixado de https://www.mapsmarker.com - a verificação não é necessária, se o processo de atualização automática for usado)

Notas de atualização adicionais para o beta tester

Nenhuma ação adicional na atualização do plug-in é necessária.

3 respostas para “Pro v2.3 com aprimoramentos de localização geográfica e correções de compatibilidade disponíveis”

    Meus mapas não estão carregando após a atualização 2.3. Quando clico no botão "debug" na primeira página dos mapas, recebo uma página morta.

    Ajuda !!!

    Como atualização, instalei o plug-in “desativar emoji” e os mapas estão funcionando agora.

    Eu não considerei isso porque estava visualizando os mapas no chrome v 43.0.2357.81 m. Portanto, eu afirmaria que o problema emoji afeta o navegador Chrome, além do navegador IE.

    Saudações
    Vontade

      Oi Will,
      Ainda não consegui reproduzir o problema com o chrome. De qualquer forma, conforme escrito no changelog, a única coisa que posso aconselhar sobre esse problema é instalar o plug-in desativar o emoji: - / Enquanto isso, conversei novamente com os caras e mulheres do WordPress e eles confirmaram que haverá uma versão 4.2.3 (como já existe uma tag no SVN do WordPress) - de qualquer maneira, ainda não pude descobrir quando o 4.2.3 está planejado para ser lançado - espero que mais cedo ou mais tarde, espero ...
      melhor,
      Robert

Deixe um comentário

XHTML: Você pode usar estas tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

en English
X