Доступен Pro v2.3 с улучшениями геолокации и исправлениями совместимости

Мы стремимся предлагать всем нашим пользователям устойчивое обслуживание, а также стабильные и безопасные продукты. В результате мы сосредоточились на улучшении внутренних сервисов и инфраструктуры, а также операционных процессов в течение последних 2 месяцев и, как следствие, должны были отложить регулярные разработки.

Тем не менее, v2.3 теперь закончен и включает не только исправления совместимости, но и новые функции, касающиеся геолокации и улучшений, особенно для разработчиков и интеграторов.

Как всегда, настоятельно рекомендуется обновить его до последней версии. Пожалуйста, прочитайте ниже для более подробной информации.


Дайте нам знать, что вы думаете об этом новом выпуске отправив отзыв или оставив комментарий ниже!

Если вы хотите быть в курсе последних разработок Maps Marker, следуйте инструкциям @MapsMarker в твиттере (= самые последние обновления), в Facebook, Google+ или подпишитесь на новости через RSS или через RSS / электронная почта.

Мы также хотели бы пригласить вас присоединиться к нашему Партнерская программа который предлагает комиссионные до 50%. Если вы заинтересованы в том, чтобы стать торговым посредником, пожалуйста, посетите https://www.mapsmarker.com/reseller


Теперь давайте перейдем к основным моментам про v2.3:

улучшения геолокации

В меню «Настройки» / «Настройки карты по умолчанию» / «Настройки Geolocate» вы найдете новую опцию под названием Автоматический старт:

автостарт-Geolocate

По умолчанию для этого параметра установлено значение false. Если для этой опции задано значение true, геолокация будет автоматически запускаться на всех картах. Если вы хотите начать геолокацию только на выбранных картах, перейдите к следующему выделению v2.3:

новая переменная javascript для разработчиков / интеграторов

С v2.3 новые переменные javascript mapid_js и mapname_js были добавлены в исходный код каждой карты. Это облегчает повторное использование javascript-функции за пределами платформы Map Marker Pro.

Допустим, например, что вы хотите запустить геолокацию для всех карт, отображаемых только в вашем блог-архиве. Для этого вам необходимо добавить следующий код javascript в файл шаблона (обычно это archives.php, но он может отличаться в зависимости от используемой темы):

<script type="text/javascript">
Eval ( 'locatecontrol _' + mapname_js) .start ();
</ Скрипт>

Это изменение дает вам также возможность более легко вызывать прямые API-команды leaflet.js вне рамок плагина, например, добавление кнопки в вашей теме, которая изменяет уровень масштабирования.

Полную ссылку на листовку API можно найти здесь, .

новый учебник для MapTiler

Работы С Нами MapTiler Вы можете превратить изображения в слои интерактивной карты, которые можно отображать с помощью Maps Marker Pro, настроив их как пользовательскую базовую карту или пользовательское наложение.

Мэтью Сангстер теперь создал учебник о том, как создавать собственные базовые карты с помощью MapTiler - большое спасибо за это!

новый 3d логотип для Maps Marker Pro

Ребята и дамы из cgi-branding.com создал новый 3D-логотип для Maps Marker, который теперь также используется во всех наших продуктах и ​​услугах:

mapsmarkerpro-логотип

большое спасибо за отличную работу!

новый словенский перевод

Благодаря Анне Дукан, http://www.unisci24.com/blog/ Словенский язык был добавлен в качестве доступного перевода № 36.

Если вы также хотите внести свой вклад в переводы (в обмен на профессиональную лицензию), пожалуйста, посетите https://translate.mapsmarker.com/projects/lmm чтобы получить больше информации.

Другие изменения и оптимизации

  • используйте CSS-классы вместо встроенных стилей для последних виджетов маркеров, чтобы лучше поддерживать переопределения (спасибо Патрик!)
  • обновил клиентскую зону на mapsmarker.com, а также переключился на PHP 5.6 - пожалуйста, сообщайте о любых проблемах!

Исправление ошибок

  • Треки GPX, использующие UTF8 с кодировкой BOM, не отображаются в Google Chrome (спасибо Хосе!)
  • SiteOrigin исправил конфликт плагинов, выпустив Конструктор страниц v2.1
  • Удалено unset () для validate_local_key (), так как это может привести к сбою второй проверки локального ключа после обновления
  • проблемы с вызовами API лицензий на серверах, где для директивы SSLVerifyClient установлено значение «требуется» (спасибо Рон!)
  • пользовательский значок по умолчанию не был сохранен после «добавления нового маркера» - ссылка использовалась во второй раз (спасибо Кирилл!)
  • Пользовательские настройки разделителя PHP для floatval () могут привести к повреждению карт (спасибо, Тамас!)
  • ссылка редактирования поврежденного слоя на страницах редактирования маркера после нажатия кнопки публикации или обновления
  • проверка на наличие патча PHP Suhosin привела к появлению белых экранов на специальных конфигурациях сервера, если phpinfo () был заблокирован

Обновления переводов

Благодаря множеству мотивированных авторов, этот выпуск включает в себя обновления следующих переводов:

Если вы хотите внести свой вклад в перевод (новые переводчики хинди приветствуются!), Пожалуйста, посетите https://translate.mapsmarker.com/projects/lmm чтобы получить больше информации.

Обратите внимание, что переводчикам также выплачивается компенсация за их вклад - например, если перевод выполнен менее чем на 50%, переводчик получает бесплатный пакет из 25 лицензий стоимостью 149 евро в качестве компенсации за завершение перевода до 100%.

известные проблемы

К сожалению, в настоящее время есть одна проблема, которая не может быть решена непосредственно в Maps Marker Pro:

В WordPress 4.2 была добавлена ​​поддержка Emoji. К сожалению есть открытая ошибка (детали), что может привести к зависанию карт или сбоям в Internet Explorer - это влияет на WordPress 4.2, 4.2.1 и 4.2.2. Согласно соответствующей заявке, исправление уже доступно и, надеюсь, скоро будет развернуто с WordPress 4.2.3.

В качестве обходного пути до выхода WordPress 4.2.3 вы можете только отключить эмодзи на данный момент для правильной работы карт в Internet Explorer.

Мы очень сожалеем об этой проблеме, но это вне нашего влияния - мы уже связались с парнями и леди из WordPress и надеемся, что исправление для ошибки Emoji / SVG будет доступно в ближайшее время.

Outlook - планы на следующие выпуски

Пожалуйста, поймите, что мы не можем обещать даты выпуска новых функций. Дорожная карта Основные новые функции дают вам представление о том, куда движется Maps Marker Pro - в любом случае, мы просто хотели бы сохранить гибкость в добавлении оптимизаций и исправлений с довольно незапланированными второстепенными выпусками, полученными в основном из отзывов пользователей.

Пожалуйста, подпишитесь на этот блог (через RSS or Эл. адрес) или следуйте @MapsMarker в твиттере (= самые последние обновления), если вы хотите быть в курсе последних новостей развития.

Полный список изменений

новая опция для автоматического запуска геолокации глобально на всех картах (см. журнал изменений о том, как запустить геолокацию только для выбранных карт)
добавлены переменные JavaScript mapid_js и mapname_js чтобы облегчить повторное использование javascript-функции извне плагина
новый учебник: как создавать собственные базовые карты с помощью MapTiler
новый 3d логотип для Maps Marker Pro 🙂
используйте CSS-классы вместо встроенных стилей для последних виджетов маркеров, чтобы лучше поддерживать переопределения (спасибо Патрик!)
обновление клиентской зоны на mapsmarker.com, а также переход на PHP 5.6 - пожалуйста, сообщайте о любых проблемах!
Треки GPX, использующие UTF8 с кодировкой BOM, не отображаются в Google Chrome (спасибо Хосе!)
SiteOrigin исправил конфликт плагинов, выпустив Конструктор страниц v2.1
Удалено unset () для validate_local_key (), так как это может привести к сбою второй проверки локального ключа после обновления
проблемы с вызовами API лицензий на серверах, где для директивы SSLVerifyClient установлено значение «требуется» (спасибо Рон!)
пользовательский значок по умолчанию не был сохранен после «добавления нового маркера» - ссылка использовалась во второй раз (спасибо Кирилл!)
Пользовательские настройки разделителя PHP для floatval () могут привести к повреждению карт (спасибо, Тамас!)
ссылка редактирования поврежденного слоя на страницах редактирования маркера после нажатия кнопки публикации или обновления
проверка на наличие патча PHP Suhosin привела к появлению белых экранов на специальных конфигурациях сервера, если phpinfo () был заблокирован
Перевод обновлений
Если вы хотите помочь с переводом, посетите веб-платформа для перевода
Словенский (sl_SL) перевод благодаря Анне Дукан, http://www.unisci24.com/blog/
обновленный французский перевод благодаря Винчен Пухоль, http://www.skivr.com и Родольф Квидевиль, http://rodolphe.quiedeville.org, Fx Benard, http://wp-translator.com, Cazal Cédric, http://www.cedric-cazal.comФабиан Хурелле, http://hurelle.fr и Томас Гиньяр,http://news.timtom.ch
обновленный немецкий перевод
обновленный латышский перевод благодаря Юрису Орлову, http://lbpa.lv и Эрикс Ремесс http://geekli.st/Eriks
обновленный норвежский (букмол) перевод благодаря Инге Тан, http://drommemila.no
обновленный румынский перевод благодаря Arian, http://administrare-cantine.roДаниэль Кодря, http://www.inadcod.com и Фло Бэйгу, http://www.inboxtranslation.com
обновленный русский перевод благодаря Екатерине Голубиной (при поддержке Теплица Социальных Технологий - http://te-st.ru) и Вячеслав Стренадко, http://poi-gorod.ru
обновленный испанский перевод благодаря Давиду Рамиресу, http://www.hiperterminal.comАльваро Лара, http://www.alvarolara.comВиктор Гевара, http://1sistemas.netРикардо Витери, http://www.labviteri.com и Хуан Вальдес
обновленный шведский перевод благодаря Олофу Одиеру http://www.historiskastadsvandringar.se, Теди Варсита http://codeorig.in/, Дан Паулссон http://www.paulsson.euЭлгер Линдгрен, http://20x.se и Антон Андреассон, http://andreasson.org/
обновленный вьетнамский (vi) перевод благодаря Hoai Thu, http://bizover.net
известные проблемы
Internet Explorer может аварийно завершить работу с WordPress 4.2 до 4.2.2 из-за конфликта Emoji (детали) - планируется исправить с помощью WordPress 4.2.3, обходной путь до выхода WordPress 4.2.3: отключить эмодзи

показать предыдущие изменения

Как скачать / обновить

Самым простым способом обновления является использование процесса обновления WordPress: войдите в систему с пользователем, обладающим правами администратора, перейдите к Dashboard / Updates, выберите плагины для обновления и нажмите кнопку «Обновить плагины». Профессиональный плагин проверяет каждые 12 часов, доступна ли новая версия. Вы также можете вручную запустить проверку обновлений, перейдя в Плагины и нажав на ссылку «Проверка обновлений вручную» рядом с «Maps Marker Pro»:

ручное обновление проверка

Если вы не видите ссылку «Проверить наличие обновлений» и используете версию ниже 1.7, обновите вручную один раз, загрузив текущий пакет с https://www.mapsmarker.com/download-pro и перезаписать существующие файлы плагинов на вашем сервере через FTP. Это может потребоваться на нескольких хостах, которые используют устаревшие библиотеки SSL, которые не позволяют Maps Marker Pro создать безопасное соединение для получения пакета обновления с mapsmarker.com. Pro v1.7 включает обходной путь для серверов такого типа, и следующие обновления должны снова работать как обычно. Если вы затронуты и нуждаетесь в помощи, пожалуйста, открыть билет поддержки.

Как проверить целостность пакета плагинов

Хеш-значение SHA-256:

238F109F0057EBBACBE0984B01AFFBA2C52E81B93C767F53A28668CFB7F7EFA5

Нажмите здесь, чтобы узнать, как проверить целостность пакета плагинов. (рекомендуется, если пакет плагина для новой установки не был загружен с https://www.mapsmarker.com - хотя проверка не требуется, если используется процесс автоматического обновления)

Дополнительные примечания к обновлению для бета-тестера

Никаких дополнительных действий по обновлению плагина не требуется.

3 Ответа на «Pro v2.3 с улучшениями геолокации и исправлениями совместимости»

    Мои карты не загружаются после обновления 2.3. Когда я нажимаю «отладка» на первой странице карты, я получаю мертвую страницу.

    Помогите!!!

    В качестве обновления я установил плагин «отключить эмодзи», и карты теперь работают.

    Я не учел это, поскольку просматривал карты в chrome v 43.0.2357.81 m. Поэтому я бы сказал, что проблема с эмодзи влияет на браузер Chrome в дополнение к браузеру IE.

    С уважением
    Будет

      Привет Воля,
      Я не мог воспроизвести проблему с хромом еще. В любом случае, как написано в журнале изменений, единственное, что я могу посоветовать по этому вопросу, - это установить плагин для отключения смайликов: - / Тем временем я снова поговорил с парнями и дамами на WordPress, и они подтвердили, что будет выпуск 4.2.3. (поскольку в WordPress SVN уже есть тег) - во всяком случае, я пока не смог узнать, когда планируется выпуск 4.2.3, - надеюсь, раньше, чем позже, надеюсь ...
      лучше,
      Роберт

Оставить комментарий

XHTML: Вы можете использовать эти теги: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

en English
X