提供了具有针对多站点安装的重要修复程序的Maps Marker Pro v4.4

此版本包括针对WordPress多站点安装的重要修复程序,可防止在删除子站点时丢失数据-有关更多详细信息,请参见下文。

与往常一样,强烈建议将其更新为最新版本。


WordPress MultiSite修复

我们发现了WordPress多站点问题,其中删除多站点子站点导致删除了主站点的4个Maps Marker Pro数据库表,而不是子站点的4个Maps Marker Pro数据库表。 如果您未在多站点主站点上使用Maps Marker Pro或尚未删除子站点,则不会受到影响。

我们对此感到遗憾,这很遗憾。 v4.4解决了此问题,删除多站点子站点将再次按设计工作。


数据库API –提供更新的文档

我们还完成了更新的数据库API,该API为开发人员提供了一种面向未来的方法,可以以编程方式访问或修改Maps Marker Pro数据库。 有关完整的文档和用法示例,请访问 https://www.mapsmarker.com/database-api/.


启用或禁用内置图层的设置

使用v4.4,您现在还可以启用或禁用内置图层。 禁用图层时,在创建,编辑或查看地图时该图层将不可用。 请注意,即使已在此处添加凭据(API密钥等),要求注册的图层也将不可用。

相关设置可以在“设置” /“层” /“启用/禁用”中找到:


完整的变更日志

版本4.4的变更日志 -发布于07.06.2019(发行说明)

启用或禁用内置图层的设置
数据库API-提供了更新的文档(详情)
将geojson数据库字段更改为MEDIUMTEXT以允许更大的折线
尽可能在管理员中使用WP dashicons
多站点子站点的删除导致主站点的Maps Marker Pro数据库表被删除
为GPX元翻译添加缺少的变量
Maps Marker Pro团队和Daniel Luttermann更新了德语翻译→贡献

如果您遇到任何问题,请 搜索我们的知识库 或提交 服务台票.

祝您映射愉快!

您的Maps Marker Pro团队


如何更新

推荐的更新方式是使用WordPress更新过程:以具有管理员权限的用户身份登录,导航至“仪表盘/更新”,选择要更新的插件,然后按“更新插件”按钮。 专业版插件每24小时检查一次新版本是否可用。 您也可以通过转到插件并单击“ Maps Marker Pro”旁边的“检查更新”链接来手动触发更新检查。

如果有可用的更新,请单击“立即更新”链接开始更新。

如果您尝试从v3.1.1或更低版本进行更新,请参阅 我们知识库中的此用户指南 有关安装说明和迁移教程。


Beta测试人员的其他信息

Beta测试人员在更新到此版本时无需采取其他操作。


数据库API用户的其他信息

使用v4.4的字段类型 geojsontable wp_mmp_maps 从改变 TEXTMEDIUMTEXT 以保存较大的折线。


如何从头开始安装Maps Marker Pro

要以zip文件的形式直接下载和安装Maps Marker Pro, 请点击这里.


如何验证插件包的完整性

有关此版本的SHA-256哈希值和文件数,请检查以下文件: https://www.mapsmarker.com/SHA256SUMS.txt

此文件已使用我们的PGP密钥进行了数字签名,可以在以下位置找到密钥签名文件 https://www.mapsmarker.com/SHA256SUMS.txt.sig

单击此处以获取有关如何验证插件包完整性的教程。 (如果未从https://www.mapsmarker.com下载用于新安装的插件程序包,则建议–尽管使用自动更新过程,也不需要验证)。


有什么问题吗 反馈? 注释?

让我们知道您对以下新版本的看法 提交评论 或在下面发表评论!

如果您想了解最新的Maps Marker Pro开发最新信息,请关注@MapsMarker 在Twitter(=最新更新)或 Facebook,通过订阅新闻 RSS 或者通过 RSS /电子邮件.

我们也想邀请您加入我们 联盟计划 提供高达50%的佣金。 如果您有兴趣成为经销商,请访问 https://www.mapsmarker.com/reseller

意见或其他问题?

如果您正在寻找技术支持 请点击这里,对于其他所有问题,请 使用我们的联系表格 取得联系! 我们期待着您的回音!

您的Maps Marker Pro团队

en English
X